在线检测未来函数

飞狐新结构波浪+三角形主图指标公式

来源:Internet,编辑:股旁网,2011-08-04

S:=('股票代码:' + STKLABEL);
DRAWTEXT((SYSPARAM(2) = BARPOS),CLOSE,S),ALIGN4,Color00FFFF;
DRAWTEXT((BARPOS = SYSPARAM(2)),HIGH,((((((((((((((((((((((((((((((((((' 所属板块:' + BLKNAME) + '\n') + '发行价') + NUMTOSTR(FINANCE(51),2)) + '元') + ' 发行量') + NUMTOSTR(FINANCE(52),2)) + '万股') + '\n') + '总股本') + NUMTOSTR(FINANCE(1),0)) + '万股') + ' 流通A股') + NUMTOSTR(FINANCE(7),0)) + '万股') + ' 净资产') + NUMTOSTR(FINANCE(35),2)) + '亿元') + ' 每股收益') + NUMTOSTR(FINANCE(33),2)) + '元') + ' 每股未分配') + NUMTOSTR(FINANCE(32),2)) + '元') + '\n') + '市盈率') + NUMTOSTR(DYNAINFO(39),2)) + '%') + ' 投资收益') + NUMTOSTR(FINANCE(24),2)) + '元') + ' 股东总数') + NUMTOSTR(FINANCE(50),0)) + '户')),ALIGN4,ColorFFFF93;
variable:wday[7]='星期六';
wday[1]:='星期日';
wday[2]:='星期一';
wday[3]:='星期二';
wday[4]:='星期三';
wday[5]:='星期四';
wday[6]:='星期五';
fy:=年份;
fm:=月份;
fd:=日期;
wd:=星期;
p:=系统参数(1);
str1:='
今天是:'+numtostr(fy[p],0)+'年'+numtostr(fm[p],0)+'月'
+数字转化为字符串(fd[p],0)+'日, '+wday[wd[p]+1];
DRAWTEXT(BARPOS=SYSPARAM(2),h,str1),ALIGN1,coloryellow;
A1:=REF(HIGH,3)=HHV(HIGH,2*3+1); B1:=FILTER(A1,3); C1:=BACKSET(B1,3+1); D1:=FILTER(C1,3);{高点}
A2:=REF(LOW,3)=LLV(LOW,2*3+1); B2:=FILTER(A2,3); C2:=BACKSET(B2,3+1); D2:=FILTER(C2,3);{低点}
E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2; E2:=(HIGH+LOW)/2;{高低点出现在同一K线上时可作取舍}
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;
L1:=(D2 AND NOT(D1 AND E1=E2));
X1:=REF(BARSLAST(H1),1)+1; F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));
G1:=F1>REF(F1,1); I1:=BACKSET(G1,2); LD:=I1>REF(I1,1);{过滤后低点}
L2:=LD OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;
X2:=REF(BARSLAST(L2),1)+1; F2:=BACKSET(L2 AND COUNT(H1,X2)>0,HHVBARS(IF(H1,HIGH,0),X2));
G2:=F2>REF(F2,1); I2:=BACKSET(G2,2); HD:=I2>REF(I2,1);{过滤后高点}
DRAWLINE(LD,L,HD,H,0),COLORWHITE,LINETHICK1,POINTDOT;
DRAWLINE(HD,H,LD,L,0),COLORWHITE,LINETHICK1,POINTDOT;
J1:=BACKSET(BARSTATUS=2,MIN(BARSLAST(HD),BARSLAST(LD))+1); J2:=J1>REF(J1,1);
DRAWLINE(J2,IF(HD,H,L),BARSTATUS=2,IF(BARSLAST(HD)>BARSLAST(LD),H,L),0),COLORWHITE,LINETHICK1,POINTDOT;
A3:=H; B3:=REF(H,REF(BARSLAST(HD),1)+1)>REF(H,REF(BARSLAST(HD),1)+2+REF(BARSLAST(HD),REF(BARSLAST(HD),1)+2));
D3:=A3 AND B3 AND HD; E3:=BACKSET(D3,REF(BARSLAST(HD),1)+2); HH:=E3>REF(E3,1);{找出全部长期高点}
A4:=L>REF(L,REF(BARSLAST(LD),1)+1);
B4:=REF(L,REF(BARSLAST(LD),1)+1); D4:=A4 AND B4 AND LD; E4:=BACKSET(D4,REF(BARSLAST(LD),1)+2); LL:=E4>REF(E4,1);{找出全部长期低点}
DRAWICON(HH,H,10),ALIGN1; DRAWICON(LL,L,12),ALIGN1;
H3:=HH OR BARSTATUS=2 OR BARSCOUNT(C)=1; {后面进行过滤,方法同前。只是不用考虑高低点出现在同一K线}
X3:=REF(BARSLAST(H3),1)+1; F3:=BACKSET(H3 AND COUNT(LL,X3)>0,LLVBARS(IF(LL,L,POW(10,20)),X3));
G3:=F3>REF(F3,1); I3:=BACKSET(G3,2); LZ:=I3>REF(I3,1); {长期低点,也可供引用}
L4:=LZ OR BARSTATUS=2 OR BARSCOUNT(C)=1;
X4:=REF(BARSLAST(L4),1)+1; F4:=BACKSET(L4 AND COUNT(HH,X4)>0,HHVBARS(IF(HH,H,-POW(10,20)),X4));
G4:=F4>REF(F4,1); I4:=BACKSET(G4,2); HZ:=I4>REF(I4,1);{长期高点,也可供引用}
DRAWLINE(HZ,H,LZ,L,0),COLORGREEN,LINETHICK1;
DRAWLINE(LZ,L,HZ,H,0),COLORGREEN,LINETHICK1;{长期连线}
K1:=BACKSET(BARSTATUS=2,MIN(BARSLAST(HZ),BARSLAST(LZ))+1); K2:=K1>REF(K1,1);
DRAWLINE(K2,IF(HZ,H,L),BARSTATUS=2,C,0),COLORGREEN,LINETHICK1; {最后的长期连线,连在收盘价上}
UU:=BACKSET(BARSTATUS=2,BARSLAST(LD)+1);
VV:=UU>REF(UU,1);
WW:=BACKSET(VV,REF(BARSLAST(LD),1)+2);
XX:=WW>REF(WW,1);
DRAWLINE(XX,L,VV,L,1),COLORMAGENTA,LINETHICK1;
UU2:=BACKSET(BARSTATUS=2,BARSLAST(HD)+1);
VV2:=UU2>REF(UU2,1);
WW2:=BACKSET(VV2,REF(BARSLAST(HD),1)+2);
XX2:=WW2>REF(WW2,1);
DRAWLINE(XX2,H,VV2,H,1),COLORMAGENTA,LINETHICK1;
前一低:REF(L,BARSLAST(VV)),COLOR99FF66,POINTDOT,LINETHICK3;
前二低:REF(L,BARSLAST(XX)),COLORFF66FF,POINTDOT,LINETHICK3;
前一高:REF(H,BARSLAST(VV2)),COLOR99FF66,POINTDOT,LINETHICK3;
前二高:REF(H,BARSLAST(XX2)),COLORFF66FF,POINTDOT,LINETHICK3;
短高:=REF(H,BARSLAST(VV2));
短低:=REF(L,BARSLAST(VV));
短比: (C-短低)/(短高-短低),LINETHICK0;
常数:=REF(INDEXC,BARSLAST(VV))/REF(C,BARSLAST(VV));
{以下语句为三角形部分}
底:REF(L,BARSLAST(VV)),COLORred,LINETHICK2;
頂:REF(H,BARSLAST(VV2)),COLORGreen,LINETHICK2;
{下迭三角形:藍色三角形畫完介入}
StickLine(VV,頂,底,0,0),Colorff6633,linethick3;{}
DRAWLINE(VV2,H,VV,L,0),Colorff6633,linethick3;{斜}
DRAWLINE(VV2,H,VV,頂,0),Colorff6633,linethick3;{?}
{上漲三角形:紅色三角形畫完出局}
StickLine(VV2 ,頂,底,0,0),Colorred,linethick3;{}
{www.gUPang.com 股旁网_最新股票指标公式}
DRAWLINE(VV,L,VV2,H,0),Colorred,linethick3;{斜}
DRAWLINE(VV,L,VV2,底,0),Colorred,linethick3;{?};
VG:=(MA((REF(HIGH,1) / REF(CLOSE,2)),27) * REF(CLOSE,1));
VD:=(MA((REF(LOW,1) / REF(CLOSE,2)),27) * REF(CLOSE,1));
A5:=VD[SYSPARAM(1)];
RA5:=VD[(SYSPARAM(1) - 1)];
A10:=VG[SYSPARAM(1)];
RA10:=VG[(SYSPARAM(1) - 1)];
JT5:=IF((A5 > RA5),'↑','↓');
JT10:=IF((A10 > RA10),'↑','↓');
P:=SYSPARAM(1);
IF P < 0 THEN
DTR:=MAX(MAX((CLOSE - HIGH),ABS((REF(CLOSE,1) - CLOSE))),ABS((REF(CLOSE,1) - LOW)));
DTR1:=MA(DTR,13);
DTR2:=(REF(CLOSE,1) - REF(DTR1,1));
买卖:HHV(DTR2,13),LINETHICK0,PRECISION2,colorE9E9FF;
X1:=((((OPEN + (3 * CLOSE)) + LOW) + HIGH) / 6);
X2:=WMA(WMA(X1,3),5);
X3:=(REVERSE(X1) + (2 * X2));
X4:=WMA(WMA(X1,1),5);
X5:=(REVERSE(X1) + (2 * X4));
注意: ((3 * X5) - (2 * SMA(X5,2,1))),LINETHICK0,PRECISION2,color9F02;
FBARS:=(SYSPARAM(3) - 1);
TJ:=(BARSSINCE(CLOSE) > (FBARS - 8));
TJ1:=(BARSSINCE(CLOSE) > (FBARS - 9));
FC:=注意;
FO:=注意;
FL:=LLV(注意,3);
FH:=HHV(注意,3);
PARTLINE(TJ,FC),LINEDOT,SHIFT8,colorFF;
TD1:=(((7 * SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 30),4,1)) - (3 * SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 30),4,1),3,1))) - SMA(SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 30),4,1),3,1),2,1));
FO:=OPEN;
FH:=HIGH;
FL:=LOW;
FC:=CLOSE;
KK:=IF(((FC >= FO) AND ((FC >= REF(FC,1)) OR (REF(FC,1) >= REF(FO,1)))),1,IF(((FC < FO) AND ((FC < REF(FO,1)) OR (REF(FC,1) < REF(FO,1)))),(0 - 1),0));
DRAWTEXT((BARPOS = SYSPARAM(2)),HIGH,' 紅色三角形画完出局;'),ColorFF00FF;
DRAWTEXT((BARPOS = SYSPARAM(2)),HIGH,' \n 藍色三角形画完介入;'),Color00FF00;
DRAWTEXT((BARPOS = SYSPARAM(2)),HIGH,((' 开盘测最高:' + NUMTOSTR(VG[P],2)) + JT5)),ColorFF00FF;
DRAWTEXT((BARPOS = SYSPARAM(2)),HIGH,((' \n 开盘测最低:' + NUMTOSTR(VD[P],2)) + JT10)),Color00FF00;
PARTLINE(CLOSE,注意);

飞狐新结构波浪+三角形主图指标公式

 

相关文章