在线检测未来函数

大智慧自用MACD指标公式

来源:Internet,编辑:股旁网,2011-08-07

input:p(12,1,100),s(26,1,100),m(9,1,50),N(0,0,1);
MACD:="MACD.MACD#WEEK";
STICKLINE(周MACD>=0 AND DATATYPE=8,0,周MACD,11,0),Color000055;
STICKLINE(周MACD<0 AND DATATYPE=8,0,周MACD,11,0),Color515100;
DIFF:(EMA(CLOSE,P) - EMA(CLOSE,S)),LINETHICK1;
DEA :EMA(DIFF,M),Color1AFFFF,LINETHICK1,LAYER0;
macd:(diff-dea)*2,COLORRED,LINETHICK0;
PARTLINE(DIFF,DIFF>=REF(DIFF,1),RGB(200,0,200),DIFF<REF(DIFF,1),RGB(0,200,200)),LAYER0;;
STICKLINE(macd>0 and macd>=REF(macd,1),macd,0,4,0),Color0000F2;
STICKLINE(macd>0 and macd<REF(macd,1),macd,0,4,1),Color0000F2;
STICKLINE(macd<0 and macd<REF(macd,1),macd,0,4,0),Color008000;
STICKLINE(macd<0 and macd>=REF(macd,1),macd,0,4,1),Color008000;
ES:=IF(N=0,REF(EMA(C,S),1),EMA(C,S));
EP:=IF(N=0,REF(EMA(C,P),1),EMA(C,P));
DI:=IF(N=0,REF(DIFF,1),DIFF);
零度价:=((P+1)*(S-1)*ES-(S+1)*(P-1)*EP)/(2*(S+1)-2*(P+1));
IF N=0 AND REF(DIFF,1)<0 and barstatus=2 THEN BEGIN DRAWTEXTREL(5,10,'DIFF上穿零度对应的股价:'+NUMTOSTRN(零度价,2)+'元'),COLOR00D0D0;END;
IF N=1 AND DIFF<0 and barstatus=2 THEN BEGIN DRAWTEXTREL(5,10,'DIFF上穿零度对应的股价:'+NUMTOSTRN(零度价,2)+'元'),COLOR00D0D0;END;
DRAWTEXTABS(5,5,'股旁网 www.gupang.com'),linethick1,COLOR00EEff;
IF N=0 AND REF(DIFF,1)>0 and barstatus=2 THEN BEGIN DRAWTEXTREL(5,10,'DIFF下穿零度对应的股价:'+NUMTOSTRN(零度价,2)+'元'),COLORD0D0D0;END;
IF N=1 AND DIFF>0 and barstatus=2 THEN BEGIN DRAWTEXTREL(5,10,'DIFF下穿零度对应的股价:'+NUMTOSTRN(零度价,2)+'元'),COLORD0D0D0;END;
拐点价:=((P-1)*EP/(P+1)-(S-1)*ES/(S+1)-DI)*(S+1)*(P+1)/(2*(P+1)-2*(S+1));
IF N=0 AND REF(DIFF,1)<REF(DIFF,2) and barstatus=2 THEN BEGIN DRAWTEXTREL(5,80,'DIFF向上拐点对应的股价:'+NUMTOSTRN(拐点价,2)+'元'),COLOR00D0D0;END;
IF N=1 AND DIFF<REF(DIFF,1) and barstatus=2 THEN BEGIN DRAWTEXTREL(5,80,'DIFF向上拐点对应的股价:'+NUMTOSTRN(拐点价,2)+'元'),COLOR00D0D0;END;
IF N=0 AND REF(DIFF,1)>REF(DIFF,2) and barstatus=2 THEN BEGIN DRAWTEXTREL(5,80,'DIFF向下拐点对应的股价:'+NUMTOSTRN(拐点价,2)+'元'),COLORD0D0D0;END;
IF N=1 AND DIFF>REF(DIFF,1) and barstatus=2 THEN BEGIN DRAWTEXTREL(5,80,'DIFF向下拐点对应的股价:'+NUMTOSTRN(拐点价,2)+'元'),COLORD0D0D0;END;

大智慧自用MACD指标公式

 

相关文章