在线检测未来函数

飞狐主力路径指标公式

来源:Internet,编辑:股旁网,2011-08-11

STICKLINE(C>0,15,20,20,0),COLORBROWN;
STICKLINE(C>0,15,10,20,0),color18A4FF;
STICKLINE(C>0,5,10,20,0),COLORGRAY;
STICKLINE(C>0,0,5,20,0),COLORBLUE;
STICKLINE(C>0,25,20,20,0),ColorFFAA00;
C1:=10*CLOSE/ema(C,170),LINETHICK;
H1:=10*HIGH/ema(H,170);
L1:=10*LOW/ema(L,170);
{www.gUPang.com 股旁网_最新股票指标公式}
FA:=5;FB:=10;FC:=MA(C1,3);FD:=MA(C1,10);FE:=MA(C1,20);FF:=MA(C1,30);FG:=MA(C1,60);
FH:=ABS(FC-FD)/MIN(FC,FD);FI:=ABS(FC-FE)/MIN(FC,FE);FJ:=ABS(FC-FF)/MIN(FC,FF);
FK:=ABS(FE-FD)/MIN(FE,FD);FL:=ABS(FF-FD)/MIN(FF,FD);FM:=ABS(FE-FF)/MIN(FE,FF);
FN:=MAX(MAX(MAX(FH,FI),MAX(FJ,FK)),MAX(FL,FM))*100,LINETHICK2;
FO:EMA(FN,3),COLORWHITE;
FILLRGN(FO>FB AND C1<FE,FO,FB),COLOR00bb00;
FILLRGN(FO>FB AND C1>FE,FO,FB),ColorFFC0FF;
FILLRGN(FO>FB AND FO>=REF(fo,1)AND C1>FE,FO,FB),COLOR9900FF;
FILLRGN(FO<FA,FO,FA),COLORCYAN;
决策线:=EMA((eMA(C1,3)*7+eMA(C1,7)*3)/10,13),color18A4FF,LINETHICK2;
道2:=3*HHV(决策线,3)-2*决策线;
趋势:=((eMA(C1,4)+eMA(C1,18))/2-(eMA(C1,15)+eMA(C1,42))/2),COLORWHITE,LINETHICK2;
中:=eMA(趋势,9),COLOR00bb00,LINETHICK2;
MACD2:=2*(趋势-中),LINETHICK;
VAR34:=((C1-LLV(L1,24))/(HHV(C1,24)-LLV(L1,24))*100);
K3:=sMA(VAR34,13,8),COLORFF8800;
D3:=sMA(K3,13,8),COLORFF8800,LINETHICK1;
j3:=3*k3-2*D3,COLORWHITE;
A1:=COUNT(FO>5 AND FN>FO AND C1>FE,28);
A2:=COUNT(决策线=道2,28);
A3:=COUNT(趋势>REF(趋势,1)AND 趋势>中,28);
A4:=COUNT(J3>50 AND J3>D3,28),COLORWHITE;
多头动能:(A1+A2+A3+A4)/4,COLOR9900FF,LINETHICK2;
M3:SMA(多头动能,13,8),COLOR00bb00,LINETHICK2;

飞狐主力路径指标公式

 

相关文章