在线检测未来函数

飞狐主力全程主图指标公式

来源:Internet,编辑:股旁网,2011-08-11

VAR2:=SMA(ABS(LOW-REF((LOW+OPEN+CLOSE+HIGH)/4,1)),13,1)/SMA(MAX(LOW-REF((LOW+OPEN+CLOSE+HIGH)/4,1),0),10,1);
VAR3:=SMA(ABS(LOW-REF(LOW,1)),3,1)/SMA(MAX(LOW-REF(LOW,1),0),3,1)*100;
VAR4:=EMA(IF(CLOSE*1.3,VAR3*10,VAR3/10),3);
VAR6:=(CLOSE-LLV(LOW,28))/(HHV(HIGH,28)-LLV(LOW,28))*100;
VAR8:=EMA(IF(LOW<=LLV(LOW,13),(VAR4+HHV(VAR4,13)*2)/2,0),3)/618*IF(MA(CLOSE,34),1,0);
主力蓄势: IF(COUNT((CLOSE-COST(10))/COST(10)*100<-2.05,3)>=3,1,0),LINETHICK0,COLORWHITE;
主力进场:IF(EMA(IF(LOW<=LLV(LOW,33),EMA(VAR2,10),0),3)>REF(EMA(IF(LOW<=LLV(LOW,33),EMA(VAR2,10),0),3),1),1,0),LINETHICK0,COLORMAGENTA;
主力建仓: IF(SMA(SMA(VAR6,4,1),2,1)<8.5 AND SMA(VAR6,4,1)<11,1,0),LINETHICK0,COLORRED;
吸筹:IF(IF(VAR8>100,100,VAR8)>50,1,0),LINETHICK0,COLORYELLOW;
DRAWTEXT(主力蓄势=1,(L* 0.995),'O'),LINETHICK3,COLORWHITE;
DRAWTEXT(主力进场=1,(L* 0.99),'O'),LINETHICK3,COLORMAGENTA;
DRAWTEXT(主力建仓=1,(L* 0.985),'O'),LINETHICK3,COLORRED;
DRAWTEXT(吸筹=1,(L*0.98),'O'),LINETHICK3,COLORYELLOW;
STICKLINE(C>O ,H,L,0.1,0),COLORRED;
STICKLINE(C>O ,C,O,8.5,1),COLORRED;
STICKLINE(C<=O ,H,L,0.1,0),COLORCYAN;
STICKLINE(C<=O ,C,O,8.5,1),COLORCYAN;
DIFF:=( EMA(CLOSE,7) - EMA(CLOSE,19)),COLORwhite;
DEA:=EMA(DIFF,9),COLORf00ff0 ;
MACD:=0.90*(DIFF-DEA), COLORSTICK;
tj:=(diff>=dea);
tj1:=(diff>=0);
Var1:=(CLOSE*2+HIGH+LOW)/4;
SK:= EMA(Var1,13)-EMA(Var1,73);
SD:= EMA(SK,2);
drawtext((cross(sk,sd) and sk<-0.04 and (c-ref(c,1))/ref(c,1)>=0.03) or (cross(sk,sd) and sk<=-0.14 ) or (cross(sk,sd) and sk<=0.05 and (v/ma(v,5)>2 or c/ref(c,1)>0.035)) ,l*0.99,'短线'),coloryellow;
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(ff1,(LOW* 0.99),'异动'),Colorgreen;
MA5:MA(CLOSE,5);
MA24:MA(CLOSE,24);
MA30:MA(CLOSE,30);
MA60:MA(CLOSE,60);
MA120:MA(CLOSE,120);
{基本面\高送转选股要求}
//1、具有长期投资价值、且严重超跌
//2、企业的现金流量良好、动态市盈率小于静态市盈率。
SJV:=C/FINANCE(34)<5 and FINANCE(33)>0.2;
FZL:=FINANCE(11)/FINANCE(15)>1 and C/FINANCE(33)<40;
基本面选股:=sjv and fzl;
{www.gUPang.com 股旁网_最新股票指标公式}
aT1:=F10FIND('主要指标:',1);lTt:=FINANCE(7)/10000;gTb:=FINANCE(1)/10000;
cT1:=F10FIND('每股净资产(元)',aT1);
eT1:=F10FIND('每股现金净流量(元)',aT1);
fT1:=F10FIND('每股资本公积金(元)',aT1);
dT1:=F10FIND('每股未分配利润(元)',aT1);
xTj:=STRTONUM(F10TEXT(eT1+20,10));
gTj:=STRTONUM(F10TEXT(fT1+20,10));
jTz:=STRTONUM(F10TEXT(cT1+20,10));
lTr:=STRTONUM(F10TEXT(dT1+20,10));
tTj:=jTz>=5 and gTj>=1 and lTr>=0.5 and xTj>=0.5 and lTt<3 and gTb<10;
高送转概念选股:=tTj;
DRAWTEXTEX(1,1,5,820,'当前光标下共 '+NUMTOSTR(SYSPARAM(3)-SYSPARAM(2)+1,0)+' 交易日'),COLOR888888;
DRAWTEXTEX(c,1,1,10,'板块:'+BLKNAME),COLOR888888;
DRAWTEXTEX(c,1,1,60,'总股本:'+NUMTOSTR(FINANCE(1)/10000 ,2 )+'亿'+' 流通A股:'+ NUMTOSTR(FINANCE(7)/10000,2)+'亿'+
' 每股收益:'+ NUMTOSTR(FINANCE(33),2)+' 市盈率:'+NUMTOSTR(DYNAINFO(39),2)),COLOR888888;

飞狐主力全程主图指标公式

 

相关文章