在线检测未来函数

通达信DMI捕捉爆涨股指标公式

来源:Internet,编辑:股旁网,2011-08-17

N:=14;M:=6;
TR0:= SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),N);
HD := HIGH-REF(HIGH,1);LD := REF(LOW,1)-LOW;DMP:= SUM(IF(HD>0 AND HD>LD,HD,
0),N);DMM:= SUM(IF(LD>0 AND LD>HD,LD,0),N);PDI: DMP*100/TR0;MDI: DMM*100/TR0;
ADX: MA(ABS(MDI-PDI)/(MDI+PDI)*100,M);ADXR:(ADX+REF(ADX,M))/2;
预警:if(ADX>90 and PDI=0,30,0),coloryellow,linethick2;
买:if(cross(PDI,MDI) and (C >1.05*ref(C,1) or ref(C,1)>1.05*ref(C,2))
and (V>2*ref(V,1) or ref(V,1)>2*ref(V,2))and ma(V,5)>ma(V,60) ,20,0),colorred,
linethick2;买2:if(cross(PDI,MDI) and count(预警,10)>=1,10,0),linethick3; 10;90;20 ; 买3:if( cross(PDI,MDI) and cross(PDI,ADX) and cross(PDI,ADXR),30,0);

通达信DMI捕捉爆涨股指标公式

 

相关文章