在线检测未来函数

通达信牛股尽现主图指标公式

来源:Internet,编辑:股旁网,2011-08-18

HZ:HHV((H+L)/2,120);
AAA:=(2*C+H+L)/4;
VAR2:=EMA(SLOPE(CLOSE,21)*20+CLOSE,55);
VAR3:=EMA(CLOSE,3);
VAR4:=(2*CLOSE+LOW+HIGH)/4;
VAR5:=VAR2-VAR3;
VAR6:=CLOSE*VOL;
VAR7:=EMA((EMA(VAR6,3)/EMA(VOL,3)+EMA(VAR6,6)/EMA(VOL,6)+EMA(VAR6,12)/EMA(VOL,12)+EMA(VAR6,24)/EMA(VOL,24))/4,13);
VAR8:=EMA(CLOSE,9);
VAR9:=(CLOSE+OPEN)/2;
VAR11:=MA(CLOSE,3);
VAR12:=MA(CLOSE,2*3);
VAR13:=MA(CLOSE,3*3);
VAR14:=MA(CLOSE,4*3);
VAR15:=MA((VAR11+VAR12+VAR13+VAR14)/4,5);
上轨1:EMA(VAR8*1.14,5),COLORGREEN,LINETHICK1;
上轨2:=VAR15*1.08,COLORWHITE,LINETHICK1;
操作线:MA(AAA,5),COLORMAGENTA,LINETHICK2;
风险线:=MA(CLOSE,13);
黄线:(EMA(VAR9,3)+EMA(VAR9,6)+EMA(VAR9,12)+EMA(VAR9,24))/4,COLORYELLOW,LINETHICK3;
精品1:=EMA(EMA(EMA(CLOSE,2),2),2);
精品2:(MA(精品1,13) * 0.999),COLORWHITE,LINETHICK2;
道2:=6*HHV(精品2,3)-5*精品2;
IF(精品2=道2,精品2,DRAWNULL),LINETHICK3,COLORRED;
IF(精品2<道2,精品2,DRAWNULL),LINETHICK3,COLORWHITE;
青线:EMA(VAR4,45)*1.15,COLORCYAN,LINETHICK2;
绿线:EMA(VAR4,55),COLORGREEN,LINETHICK3;
牛股:=CROSS((100-100*(HHV(HIGH,5*8)-CLOSE)/(HHV(HIGH,5*8)-LLV(LOW,5*8))),99);
攻:=REF(C,REF(HHVBARS(V,21),0));
进攻:=MA(CLOSE,1);
指挥:=V>1*REF(V,1) AND (C/REF(C,1)-1)*100>9.5 AND 进攻>=攻;
DK:=EMA((CLOSE-MA((2*CLOSE+HIGH+LOW)/4,30))/MA((2*CLOSE+HIGH+LOW)/4,30)*100,3),COLORWHITE;
ZSQS:= EMA(100*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3),COLORCYAN,LINETHICK1;
ZLCC:=EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3),COLORRED,LINETHICK2;
CN1:=HHV(V,5);
CN2:=O>C;
CN02:=C>O;
CN03:=C=O;
CN04:=((SUM(V,5)/CN1));
CN05:=IF(CN04>0.3,1,0);
CN06:=IF(CN2 AND CN05,V,0);
CN07:=IF(CN02 AND CN05,V,0);
CN08:=IF(CN03 AND CN05,V,0);
LJLR:=SUM(CN07,9)/10000,COLORFF00FF,LINETHICK2;
LJLC:=SUM(CN06,9)/10000,COLORGREEN,LINETHICK2;
JLR:=(LJLR-LJLC),COLORYELLOW,LINETHICK2;
{www.gUPang.com 股旁网_最新股票指标公式}
组合:=牛股 AND 指挥 AND (CROSS(DK,5) OR CROSS(DK,10));
基础0:=DK>REF(DK,1) AND REF(DK,1)>REF(DK,2) AND REF(DK,2)>REF(DK,3);
基础5:=LJLR>REF(LJLR,1) AND REF(LJLR,1)>REF(LJLR,2) {AND REF(LJLR,2)>REF(LJLR,3)} AND JLR>REF(JLR,1) AND REF(JLR,1)>REF(JLR,2) {AND REF(JLR,2)>REF(JLR,3)} AND C/REF(C,1)>1.03;
DRAWICON(基础5,L*0.99,1);
三角1:=基础0 AND CROSS(DK,0);
三角2:=基础0 AND CROSS(DK,5);
三角3:=基础0 AND CROSS(DK,10);
买1:=基础5 AND LJLR>0 AND LJLR<100;
买2:=基础5 AND LJLR>=100 AND LJLR<200;
买3:=基础5 AND LJLR>=200 AND LJLR<300;
买4:=基础5 AND LJLR>=300 AND LJLR<400;
买5:=基础5 AND LJLR>=400 AND LJLR<500;
DRAWICON(组合,L*0.99,1);
DRAWTEXT(三角1,L*0.96,'▲'),COLORWHITE;
DRAWTEXT(三角2,L*0.96,'▲'),COLORMAGENTA;
DRAWTEXT(三角3,L*0.96,'▲'),COLORYELLOW;
DRAWTEXT(买1 OR 买2 OR 买3 OR 买4 OR 买5,H*1.09,'买'),COLORYELLOW;
DRAWTEXT(买1,H*1.06,'1'),COLORYELLOW;
DRAWTEXT(买2,H*1.06,'2'),COLORYELLOW;
DRAWTEXT(买3,H*1.06,'3'),COLORYELLOW;
DRAWTEXT(买4,H*1.06,'4'),COLORYELLOW;
DRAWTEXT(买5,H*1.06,'5'),COLORYELLOW;

通达信牛股尽现主图指标公式

 

相关文章