在线检测未来函数

通达信短线有钱途指标公式

来源:Internet,编辑:股旁网,2011-08-19

A:=4;
高1:=REF(HHV(H,1500),1);
低1:=REF(LLV(L,1500),1);
H1:=高1-(高1-低1)*0.191;
H2:=高1-(高1-低1)*0.382;
H3:=高1-(高1-低1)*0.5;
H4:=高1-(高1-低1)*0.618;
H5:=高1-(高1-低1)*0.809;
顶:REFDATE(高1,DATE),POINTDOT,COLORWHITE;
%19:REFDATE(H1,DATE),POINTDOT,COLORYELLOW;
%38:REFDATE(H2,DATE),POINTDOT,COLORYELLOW;
%50:REFDATE(H3,DATE),POINTDOT,COLORWHITE;
%61:REFDATE(H4,DATE),POINTDOT,COLORYELLOW;
%80:REFDATE(H5,DATE),POINTDOT,COLORYELLOW;
突破:REF(EMA(C,A),1)COLORMAGENTA,LINETHICK1;
A1X:=(EMA(C,A)-突破)/突破*100;
出击:IF(A1X>=0,REF(EMA(C,A),BARSLAST(CROSS(A1X,0))+1),DRAWNULL)COLORRED,LINETHICK1;
休假:IF(A1X<0,REF(EMA(C,A),BARSLAST(CROSS(0,A1X))+1),DRAWNULL)COLORGREEN,LINETHICK1;
STICKLINE(A1X>=0,出击,突破,0,-1),COLORRED;
STICKLINE(A1X<0,休假,突破,0,-1),COLORGREEN;
STICKLINE(CROSS(A1X,0),C,O,2,0),COLORYELLOW;
STICKLINE(CROSS(0,A1X),C,O,2,0),COLORGREEN;
{DRAWTEXT(CROSS(A1X,0),L-0.9,'B'),COLORYELLOW;
DRAWTEXT(CROSS(0,A1X),H+1,'S'),COLORGREEN;}
DRAWICON(CROSS(A1X,0),L-0.3,1),COLORYELLOW;
DRAWICON(CROSS(0,A1X),H+0.4,9),COLORGREEN;
{www.gUPang.com 股旁网_最新股票指标公式}
{※:IF(A1X<0,突破,DRAWNULL),COLORGREEN,LINETHICK2;}
DRAWTEXT(CROSS(A1X,0),H,'参考介入价:'+'C'+' ');
{DP:=REF(EMA(INDEXC,A),1);
DPX:=(EMA(INDEXC,A)-DP)/DP*100;
STICKLINE(DPX>=0 AND A1X>=0,REFDATE(低1,DATE),REFDATE(低1,DATE)*0.98,2,1)COLORRED;
STICKLINE(DPX<0 AND A1X<0,REFDATE(低1,DATE),REFDATE(低1,DATE)*0.98,2,1)COLORGREEN;
STICKLINE(NOT(DPX>=0 AND A1X>=0) AND NOT(DPX<0 AND A1X<0),REFDATE(低1,DATE),REFDATE(低1,DATE)*0.98,2,1)COLORYELLOW;};

通达信短线有钱途指标公式

 

相关文章