在线检测未来函数

同花顺听雪主力动向指标公式

来源:Internet,编辑:股旁网,2011-08-21

r:=((ZDMR[-1]+BDMR[-1])-(ZDMC[-1]+BDMC[-1]))/SHGZG*100;
t:=BARSCOUNT(SHGZG);
b:=SUM(r,t);
主力持仓:b;
n:=5;
x2:=HHV(r,n);
S:=STD(SHGZG,2)/1000000;
S1:=-STD(SHGZG,2)/1000000;
STICKLINE(r>0,r+b,b,2),colorred;
STICKLINE(r<0,b,b+r,2),colorgreen;
STICKLINE(s>0,x2+b,b+r*3,3),coloryellow;
STICKLINE(s1<0,b+r*3,b-x2,3),coloryellow;
IF(ISNULL(r))
a=(ZDMR[-1]+BDMR[-1]);
b=(ZDMC[-1]+BDMC[-1]);
a3=SUM(a,n)/1000000;
b3=SUM(b,n)/1000000;
VOL1=SUM(VOL,n)/1000000;
S3=STD(SHGZG,2)/10000;
IF(a3>b3)
{
y=a3-b3;
z=y/VOL1*100;
主力增加:TOSTRING(r,2)+"%."+TOSTRING(n,0)+"天主力净买入"+TOSTRING(y,1)+"万手.占总成交"+TOSTRING(z,1)+"%."+"流通盘增加"+TOSTRING(s3,2)+"万.";
}
ELSE
{
y=b3-a3;
z=y/VOL1*100;
主力增加:TOSTRING(r,2)+"%."+TOSTRING(n,0)+"天主力净买入"+TOSTRING(y,1)+"万手.占总成交"+TOSTRING(z,1)+"%."+"流通盘增加"+TOSTRING(s3,2)+"万.";
}
Var1:=(CLOSE+HIGH+LOW)/3;
Var2:=EMA(EMA(EMA(Var1,1),13),21);
控盘度: (Var2-REF(Var2,1))/REF(Var2,1)*1000;
强弱分界:= 0;

同花顺听雪主力动向指标公式

 

相关文章