在线检测未来函数

大智慧周日同显RSI指标公式

来源:Internet,编辑:股旁网,2011-08-22

REFLINE: 0, 20, 50, 80, 100;
N1:=6;
N2:=12;
N3:=12;
LC := REF(CLOSE,1);
RSI1:MA("RSI.RSI1#WEEK"(N1,N2,N3) ,5),LINETHICK3,COLORYELLOW;
周RSI2:MA("RSI.RSI2#WEEK"(N1,N2,N3) ,5),LINETHICK3,COLORFF00FF;
周RSI3:MA("RSI.RSI3#WEEK"(N1,N2,N3) ,5),LINETHICK3,COLORGREEN;
FILLRGN(周RSI1,周RSI2, 周RSI1>周RSI2,rGB(255,200,70),周RSI1<=周RSI2,RGB(70,100,50));
RSI1:SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100;
RSI2:SMA(MAX(CLOSE-LC,0),N2,1)/SMA(ABS(CLOSE-LC),N2,1)*100;
RSI3:SMA(MAX(CLOSE-LC,0),N3,1)/SMA(ABS(CLOSE-LC),N3,1)*100;
DRAWTEXTABS(5,5,'股旁网 www.gupang.com'),linethick1,COLOR00EEff;
FILLRGN(RSI1,RSI2,RSI1>RSI2,RGB(155,50,50),RSI1<=RSI2,RGB(50,208,155));
周金▲:DRAWTEXT(CROSS("RSI.RSI1#WEEK"(N1,N2,N3),"RSI.RSI2#WEEK"(N1,N2,N3)) ,15,'▲'),COLORRED;
周死▼:DRAWTEXT(CROSS("RSI.RSI2#WEEK"(N1,N2,N3),"RSI.RSI1#WEEK"(N1,N2,N3)) ,85,'▼'),COLORGREEN;
月金▲:DRAWTEXT(CROSS("RSI.RSI1#MONTH"(N1,N2,N3),"RSI.RSI2#MONTH"(N1,N2,N3)) ,10,'▲'),COLORMAGENTA;
月死▼:DRAWTEXT(CROSS("RSI.RSI2#MONTH"(N1,N2,N3),"RSI.RSI1#MONTH"(N1,N2,N3)) ,90,'▼'),COLORYELLOW;

大智慧周日同显RSI指标公式

 

相关文章