在线检测未来函数

通达信DMI黄金分割指标公式

来源:Internet,编辑:股旁网,2011-08-26

N:=14;
M:=6;
ADXP:=1;
TR1:= SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),N);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
DMP:= SUM(IF(HD>0 AND HD>LD,HD,0),N);
DMM:= SUM(IF(LD>0 AND LD>HD,LD,0),N);
PDI: DMP*100/TR1;
MDI: DMM*100/TR1;
ADX: MA(ABS(MDI-PDI)/(MDI+PDI)*100,M);
ADXR:(ADX+REF(ADX,M))/2;
{传统MDI加进四条线 两句话较好}
CD0:20;
CD1:40;
TD0:60;
TD1:80;
DRAWTEXT(CROSS( PDI,CD0), CD0,'●金'),COLORMAGENTA;
DRAWTEXT(CROSS( TD0,PDI), PDI,'●死'),COLORBLUE;
DRAWTEXT(CROSS( ADX,CD0), CD0,'●金'),COLORMAGENTA;
DRAWTEXT(CROSS( TD0,ADX), ADX,'●死'),COLORBLUE;
DRAWTEXT(CROSS( PDI,MDI), MDI,'★金'), COLORYELLOW;
DRAWTEXT(CROSS( MDI,PDI), PDI,'★死'), COLORGREEN;
DRAWTEXT(CROSS( ADX,ADXP), ADXP,'★金'), COLOR000999 ;
DRAWTEXT(CROSS( ADXP,ADX), ADX,'★死'), COLORCYAN;
DRAWTEXT(CURRBARSCOUNT=35,80.1,'梦的海洋友情提示:'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=35,76,'PDI线上穿20介入,下破60急出手 '),COLORBLUE;
DRAWTEXT(CURRBARSCOUNT=35,69.1,'ADX线上穿20介入,下破60急出手'),COLORCYAN;
{www.gUPang.com 股旁网_最新股票指标公式}
DRAWTEXT(CURRBARSCOUNT=35,64.1,'如果回调幅度在0.618内属强势调整后市方向不会改变'),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=35,59.1,'如果回调超过在0.618后市方向可能逆转:'),COLORBLUE;
DRAWTEXT(CURRBARSCOUNT=35,54.1,'如果反弹高度在0.382内属反弹行情后市方向不会改变:'),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=35,50,'如果反弹超过在0.382后市方向可能逆转:'),COLORBLUE;

通达信DMI黄金分割指标公式

 

相关文章