在线检测未来函数

通达信筹码多空趋势指标公式

来源:Internet,编辑:股旁网,2011-08-26

N:=3;
VAR1:=(CLOSE+HIGH+LOW+OPEN)/4;
VAR2:=SUMBARS(VOL,CAPITAL);
VAR3:=HHV(VAR1,VAR2);
VAR4:=LLV(VAR1,VAR2);
VAR5:=(2*VAR1-VAR4-REF(VAR4,1))/(VAR3-VAR4);
VAR6:=(VAR1-VAR4)/(VAR3-VAR4);
VAR7:=IF(VAR1<=VAR4,VAR5*60,VAR6*60);
VAR8:=600*(EMA(CLOSE,3)-EMA(LOW,30))/EMA(LOW,30);
VAR9:=EMA(VAR8,7);
VARA:=(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))*100;
VARB:=(-100)*(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))+5;
VARC:=HHV(HIGH,9)-LLV(LOW,9);
VARD:=HHV(HIGH,9)-CLOSE;
VARE:=CLOSE-LLV(LOW,9);
VARF:=VARD/VARC*100-70;
VAR10:=(CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100;
VAR11:=(2*CLOSE+HIGH+LOW)/4;
VAR12:=SMA(VARE/VARC*100,3,1);
VAR13:=LLV(LOW,34);
VAR14:=SMA(VAR12,3,1)-SMA(VARF,9,1);
VAR15:=IF(VAR14>100,VAR14-100,0);
VAR16:=HHV(HIGH,34);
VAR17:=EMA((VAR11-VAR13)/(VAR16-VAR13)*100,8);
VAR18:=EMA(VAR17,5);
STICKLINE(VAR17-VAR18>0,VAR17,VAR18,4,1),COLORRED ;
STICKLINE(VAR17-VAR18<0,VAR17,VAR18,4,1),COLORGREEN ;
DK:=(VAR17-VAR18)*20,LINETHICK0;
STICKLINE(DK>0 AND DK>REF(DK,1) AND C>REF(C,1),VAR17,VAR18,2,0),COLORRED ;
{www.gUPang.com 股旁网_最新股票指标公式}
STICKLINE(DK>0 AND DK<REF(DK,1) AND C<REF(C,1) ,VAR17,VAR18,2,0),COLORCYAN ;
STICKLINE(DK<0 AND DK>REF(DK,1) AND C>REF(C,1),VAR17,VAR18,2,0),COLORYELLOW ;
{-----------------------☆功能开关------------------------}
DQ_1:=LLV(L,55);
DQ_2:=HHV(H,55);
DQ_3:=C-DQ_1;
DQ_4:=DQ_2-DQ_1;
DQ_5:=DQ_3/DQ_4;
DQ_6:=3*SMA(DQ_5*100,7,1)-2*SMA(DQ_5*100,7,1);
DQ_7:=
SMA(DQ_6,2,1);
XY1:=(C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*200*10;
XY2:=SMA(XY1,3,1); XY3:=LLV(XY2,3); XY4:=HHV(XY2,3);
ZJ1:=DMA((H+L+C*2)/4,0.9); ZJ2:=V/((H-L)*2-ABS(C-O));
ZJ3:=IF(C>O,ZJ2*(H-L),IF(C<O,ZJ2*(H-O+(C-L)),V/2))+IF(C>O,0-ZJ2*(H-C+(O-L)),IF(C<O,0-ZJ2*(H-L),0-V/2));
ZJ4:=ZJ3/20/1.15; ZJ5:=ZJ4*0.55+REF(ZJ4,1)*0.33+REF(ZJ4,2)*0.22; ZJ6:=EMA(ZJ5,3);
ZJ7:= EMA( ZJ6,13)-EMA( ZJ6,34); ZJ8:=(ZJ7-EMA(ZJ7,3)); ZJ9:=IF(ZJ8>=0,1,0);
PH_1:=AMOUNT/(100*V); PH_2:=MA(PH_1,40); PH_3:=(C-LLV(L,34))/(HHV(H,34)-LLV(L,34))*100; PH_4:=SMA(SMA(PH_3,3,1),3,1);
PH_5:=SMA(PH_4,5,1)*15,COLORYELLOW;
弱:=XY1<XY3;
吸:=IF(ZJ9 OR (XY1>XY3 OR (XY1>PH_5)),1,0);
空:=XY1<PH_5 AND 吸=0;
强:=XY1>PH_5 AND XY1>XY4;
减:=XY1<XY2 AND XY1>PH_5;
VARO5:=LLV(LOW,27);
VARO6:=HHV(HIGH,34);
VARO7:=EMA((CLOSE-VARO5)/(VARO6-VARO5)*4,4)*25;
{建仓区: IF((VARO7<10),80,100) ,COLOR00CCFF,LINETHICK1;}
0,LINETHICK2 ,COLORFFCC00;
{-----------------【图解模板】---------------------}
{DRAWGBK((DATE > 0),COLORRGB(40,40,173),COLORRGB(1,1,14),1);}
弱势:STICKLINE(弱,30,30-PH_3/5,2,1),COLORFF8900;
吸货:STICKLINE(吸,30,30+PH_3/5*0.8,3,1),COLORYELLOW;
强势:STICKLINE(强,30,30+PH_3/5,1,0),COLORRED;
减仓:STICKLINE(减,30,30+PH_3/5,2,0),COLORGRAY;
空仓:STICKLINE(空,30,30+PH_3/5,3,0),LINETHICK3,COLORWHITE;
{主波}
{主波};

通达信筹码多空趋势指标公式

 

相关文章