在线检测未来函数

飞狐买入就盈利指标公式

来源:Internet,编辑:股旁网,2011-08-28

OSC:=C-REF(MA(C,13),5);
分界:=MA(OSC,8);
DIFF := EMA(OSC,12) - EMA(OSC,26);
DEA := EMA(DIFF,9);
MACD := 2*(DIFF-DEA);
Z_F:=IF(C>REF(H,1),EMA(L,5),IF(C<REF(EMA(L,5),1),H,EMA(L,5)));
K_d:=BARSLAST(C<=Z_F);
X_H:=K_d=1 and BARSLAST(MACD<REF(MACD,1));
{===================== 【解模板】===================== }
DRAWGBK((DATE > 0),COLORRGB(40,40,60),COLORRGB(10,10,10),1);
{柱线}
STICKLINE(MACD<ref(MACD,1) and MACD<0,0,MACD*4,0,0),LINEDOT,ColorFFCF78;
STICKLINE(MACD<ref(MACD,1) and MACD>0,0,MACD*4,0,0),LINEDOT,COLORYELLOW;
STICKLINE(MACD>ref(MACD,1) and MACD<0,0,MACD*4,0,0),LINEDOT,COLORMAGENTA;
STICKLINE(MACD>ref(MACD,1) and MACD>0,0,MACD*4,0,0),LINEDOT,COLORRED;
{www.gUPang.com 股旁网_最新股票指标公式}
{K柱}
STICKLINE(OSC<REF(OSC,1)||(AMOUNT/REF(AMOUNT,1)<0.97),OSC,REF(OSC,1),7,0),LINETHICK2,COLORWHITE;//离场
STICKLINE(CROSS(ref(MACD,1),MACD) and MACD<ref(MACD,1),OSC,REF(OSC,1),7,0),LINETHICK2,COLORYELLOW;//逃顶
STICKLINE(OSC>=REF(OSC,1),OSC,REF(OSC,1),7,0),LINETHICK2,COLORRED;//持股
STICKLINE(BARSLAST(X_H)<2,OSC,REF(OSC,1),7,0),LINETHICK2,COLORRED;//延时
STICKLINE(X_H,OSC,REF(OSC,1),7,0),LINETHICK2,COLORMAGENTA;//启动
STICKLINE(OSC<分界,OSC,REF(OSC,1),7,0),LINETHICK2,ColorFFA900;//空仓
动能线:OSC,ColorFFB5FF;
加速线:=(DEA-DIFF)*9.8,COLORGREEN;
{字}
DRAWTEXTEX(1,0,0,0,'粉启动'),COLORMAGENTA;
DRAWTEXTEX(1,0,40,0,'黄逃顶'),COLORYELLOW;
DRAWTEXTEX(1,0,80,0,'红持股'),COLORRED;
DRAWTEXTEX(1,0,120,0,'白警惕'),COLORWHITE;
DRAWTEXTEX(1,0,160,0,'兰空仓'),ColorFFA900;

飞狐买入就盈利指标公式

 

相关文章