在线检测未来函数

大智慧智能K线主图指标公式

来源:Internet,编辑:股旁网,2011-08-29

MA5:MA(CLOSE,5),ColorCCCCCC;
MA10:MA(CLOSE,10),Color00BBBB;
MA20:MA(CLOSE,20),Color00AA00;
MA30:MA(CLOSE,30),Color990099;
MA40:=MA(C,40);
MA60:MA(CLOSE,60),Color000088;
MA120:MA(CLOSE,120),Color777700;
买线:=ZIG(3,10);
卖线:=MA(买线,3);
BU:=cross(买线,卖线);
SEL:=cross(卖线,买线);
drawtext(bu,l*0.95,'真'),linethick2,align1,color00aaff;
DRAWICON(bu,l*0.97,7),ALIGN1,VALIGN1;
drawtext(sel,h*1.06,'真'),linethick2,align1,color00ff00;
DRAWICON(sel,h*1.02,8),ALIGN1,VALIGN1;
stickline(买线>=卖线,low,high,0.1,0),color0000CC;
stickline(买线>=卖线,close,open,7,0),color0000CC;
stickline(买线<卖线,close,open,7,0),colorCCCC00;
stickline(买线<卖线,low,high,0.1,0),colorCCCC00;
stickline(cross(买线,卖线),open,close,7,0),color00AAFF;
stickline(cross(卖线,买线),open,close,7,0),color00DD00;
VL:=REF(LOW,1);
VAR12:=(SMA(ABS(LOW-VL),13,1))/(SMA(MAX(LOW-VL,0),13,1))*100;
VAR14:=MA(VAR12,13);
VAR15:=LLV(LOW,34);
VAR18:=EMA(IF(LOW<=VAR15,VAR14,0),3);
VAR110:=SMA(SMA((CLOSE-LLV(LOW,54))/(HHV(HIGH,54)-LLV(LOW,54))*100,7,1),5,1);
VAR111:=SMA((CLOSE-LLV(LOW,54))/(HHV(HIGH,54)-LLV(LOW,54))*100,7,1)*16.18-VAR110*10.9;
T:=FILTER(IF(VAR111<=VAR110 AND VAR18>REF(VAR18,1),VAR18*8,0),20);
DRAWTEXT(T,LOW-0.4,'黎明前的黑暗'),COLORMAGENTA,ALIGN2;
bu:=cross(high,SAR(3,1,20));
sel:=cross(SAR(3,1,20),low);
var1:=last(high<SAR(3,1,20));
var2:=last(low>sar(3,1,20));
drawflagtext(bu,high,'买入'),color00aaff,linethick2;
drawflagtext(sel,low,'卖出'),colorgreen,linethick2;
drawflagtext(high<SAR(3,1,20) and high>=ref(high,1),high,'明日突破'+forcast(sar(3,1,20),max(var1,2))+'建议关注');
drawflagtext(high<SAR(3,1,20) and high<ref(high,1),high,'持币观望');
drawflagtext(low>SAR(3,1,20) and low<=ref(low,1),low,'明日跌破'+forcast(sar(3,1,20),max(var2,2))+'注意止盈');
VAR1:=(C+H+O+L)/4;
卖出:EMA(VAR1,25)*1.12,COLORGREEN,LINETHICK1;
买入:EMA(VAR1,25)*0.918,COLORMAGENTA,LINETHICK1;
EMA34多空平衡:EMA(C,34),COLORWHITE;
DRAWTEXTREL(5,970,'主营收入同比增长:'+NUMTOSTRN(FINANCE2(11),2)+'%'+' 净利润同比增长:'+NUMTOSTRN(FINANCE2(10),2)+'%'),COLORMAGENTA;
DRAWTEXTREL(5,920,'总股本:'+NUMTOSTRn(FINANCE2(35),0)+'万股' +' 流通A股:'+NUMTOSTRn(FINANCE2(37),0)+'万股'+' 每股收益:'+NUMTOSTRN(FINANCE2(3),3)+'元'+' 净资产:'+NUMTOSTRN(FINANCE2(4),2)+'元'+' 市盈率:'+NUMTOSTRN(DYNAINFO(39),2)),COLOR00FF00;
DRAWTEXTREL(5,870,'所属板块:'+BKNAME),Colorwhite;
DRAWTEXTREL(780,38,'股市如战场,6份股本分批杀入,分批撤离,勿贪。'),Color8000FF,LINETHICK2,ALIGN1;
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),3,1)/SMA(ABS(CLOSE-LC),3,1)*100;
SELL1:=FILTER((CROSS(RSI1,88)),7);
SELL2:=(CROSS(88,RSI1));
KDJ:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(KDJ,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
TYP:= (HIGH + LOW + CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
DRAWTEXT(SELL2,HIGH*1.02,'▼'),ColorFFCC33,ALIGN1;
DRAWTEXT(SELL2 AND (K>80 OR CCI>160),HIGH*1.04,'▼'),ColorCC6633,ALIGN1;
DRAWTEXT(SELL2 AND K>80 AND CCI>160,HIGH*1.06,'▼'),ColorFF3300,ALIGN1;
VB1:=AMOUNT/V;
VB2:=L<VB1*0.9;
VB3:=(C-REF(C,1))/REF(C,1)*100>1.2;
VB4:=L<MA(C,5)*0.921;
VB5:=V<MA(V,5)*1.5;
VB6:=VB2 AND VB3 AND VB4 AND VB5;
VB7:=EMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,34)-LLV(LOW,27))*4,4)*25;
VB8:=IF((VB7<10),80,100);
VB9:=IF(K<20,10,0);
VB10:=LLV(J,2)=LLV(J,8);
VB11:=IF(CROSS(J,REF(J+0.01,1)) AND VB10 AND J<20,30,0);
DRAWTEXT(VB11 AND VB8=100 AND VB9=10,low*0.99,'超跌'),Color8000FF,ALIGN2;
VB12:=C-REF(C,1);
VB13:=100*EMA(EMA(VB12,6),6)/EMA(EMA(ABS(VB12),6),6);
VB14:=IF(LLV(VB13,2)=LLV(VB13,7) AND COUNT(VB13<0,2) AND CROSS(VB13,MA(VB13,2)),1,0);
VB15:=filter(VB6,5);
DRAWTEXT(VB15,LOW*0.98,'莫手痒'),COLORMAGENTA,ALIGN2;
AA1:=MA(CLOSE,20);
AA2:=(CLOSE > MA(CLOSE,5));
AA3:=(MA(CLOSE,5) > MA(CLOSE,10));
AA4:=(CLOSE > MA(CLOSE,10));
AA5:=(MA(CLOSE,5) > MA(CLOSE,20));
AA6:=(CLOSE > MA(CLOSE,20));
AA7:=REF(AA1,1);
AA8:=(AA1 > AA7);
AAX:=(((((IF(AA2,10,(0 - 10)) + IF(AA3,10,(0 - 10))) + IF(AA4,10,(0 - 10))) + IF(AA5,10,(0 - 10))) + IF(AA6,10,(0 - 10))) + IF(AA8,10,(0 - 10)));
DSLX:=(CLOSE / INDEXC);
DSLX1:=MA(DSLX,5);
V1:=MA(VOL,5);
V2:=MA(VOL,10);
IF BARSTATUS=2 and c<200 and ((CROSS(AAX,1) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTREL(780,130,'量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右。'),colorRED,LINETHICK2,ALIGN1;
IF BARSTATUS=2 and c<200 and ((CROSS(AAX,1) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTREL(780,130,'虽然走势趋强,但量能还显不足,可以考虑短线进场,仓位在1/2左右。'),colorYELLOW,LINETHICK2,ALIGN1;
IF BARSTATUS=2 and c<200 and ((CROSS(AAX,1) AND (V1 > V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTREL(780,130,'量价配合良好,但相对其它股票并没有明显走强,可以考虑短线进场,仓位1/2左右。'),colorYELLOW,LINETHICK2,ALIGN1;
IF BARSTATUS=2 and c<200 and ((CROSS(AAX,1) AND (V1 <= V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTREL(780,130,'形态尚可,但量能不足,股票也未完全走强,可以短线参与,仓位1/3左右。'),colorYELLOW,LINETHICK2,ALIGN1;
IF BARSTATUS=2 and c<200 and ((CROSS(1,AAX) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTREL(780,130,'形态变坏,但走势相对其它股票尚可,重仓者减持大半,清仓者可以观望。'),colorGREEN,LINETHICK2,ALIGN1;
IF BARSTATUS=2 and c<200 and ((CROSS(1,AAX) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTREL(780,130,'随大盘一起下跌,呈明显缩量走势,考虑到大盘风险,减持或清仓。'),colorGREEN,LINETHICK2,ALIGN1;
IF BARSTATUS=2 and c<200 and ((CROSS(1,AAX) AND (V1 >= V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTREL(780,130,'放量下跌,走势明显偏弱,离场观望。'),colorGREEN,LINETHICK2,ALIGN1;
IF BARSTATUS=2 and c<200 and ((CROSS(1,AAX) AND (V1 < V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTREL(780,130,'缩量下跌,走势偏弱,离场观望。'),colorGREEN,LINETHICK2,ALIGN1;
IF BARSTATUS=2 and c<200 and ((((AAX >= 1) AND (REF(AAX,1) > 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTREL(780,930,'形态良好,强势明显,量能充足,可以继续持有。'),colorRED,LINETHICK2,ALIGN1;
IF BARSTATUS=2 and c<200 and ((((AAX >= 1) AND (REF(AAX,1) > 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTREL(780,930,'上行趋势不变,强势依然,但量能开始转弱,注意风险。'),colorRED,LINETHICK2,ALIGN1;
IF BARSTATUS=2 and c<200 and ((((AAX >= 1) AND (REF(AAX,1) > 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTREL(780,130,'仍然具备上涨潜力,但股性偏弱,可考虑减仓。'),colorGREEN,LINETHICK2,ALIGN1;
IF BARSTATUS=2 and c<200 and ((((AAX >= 1) AND (REF(AAX,1) > 0)) AND (V1 < V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTREL(780,130,'走势趋弱,量能不足,减持大部分筹码。'),colorGREEN,LINETHICK2,ALIGN1;
IF BARSTATUS=2 and c<200 and ((((AAX < 1) AND (REF(AAX,1) < 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTREL(780,130,'形态不佳,注意成交量的变化,但目前不适合参与。'),colorGREEN,LINETHICK2,ALIGN1;
IF BARSTATUS=2 and c<200 and ((((AAX < 1) AND (REF(AAX,1) < 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTREL(780,130,'趋势不明,股价偏弱,注意量能变化,目前不宜参与。'),colorGREEN,LINETHICK2,ALIGN1;
IF BARSTATUS=2 and c<200 and ((((AAX < 1) AND (REF(AAX,1) < 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTREL(780,130,'有走强迹象,但量能不足,趋势不明,不适合操作。'),colorGREEN,LINETHICK2,ALIGN1;
IF BARSTATUS=2 and c<200 and ((((AAX < 1) AND (REF(AAX,1) < 0)) AND (V1 < V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTREL(780,130,'走势太弱,没有参与价值。'),colorGREEN,LINETHICK2,ALIGN1;
IF BARSTATUS=2 and c>200 and (CROSS(AAX,1) AND (V1 >= V2)) THEN
DRAWTEXTREL(780,130,'大盘量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右,'),color8000FF,LINETHICK2,ALIGN1;
IF BARSTATUS=2 and c>200 and (CROSS(AAX,1) AND (V1 >= V2)) THEN
DRAWTEXTREL(780,130,'如前期经过一轮下跌,此时为最佳买点,但如果前期有过一段涨幅则介入需谨慎。'),color8000FF,LINETHICK2,ALIGN1;
IF BARSTATUS=2 and c>200 and (CROSS(AAX,1) AND (V1 < V2)) THEN
DRAWTEXTREL(780,130,'大盘虽然走势趋强,但量能还显不足,如果前期经过一轮下跌,'),color8000FF,LINETHICK2,ALIGN1;
IF BARSTATUS=2 and c>200 and (CROSS(AAX,1) AND (V1 < V2)) THEN
DRAWTEXTREL(780,130,'可以考虑短线进场,仓位在1/2左右,一旦量能放大可以加仓买入。'),color8000FF,LINETHICK2,ALIGN1;
IF BARSTATUS=2 and c>200 and (CROSS(1,AAX) AND (V1 >= V2)) THEN
DRAWTEXTREL(780,130,'大盘形态走坏,重仓者可以减去大部分仓位。'),color8000FF,LINETHICK2,ALIGN1;
IF BARSTATUS=2 and c>200 and (CROSS(1,AAX) AND (V1 < V2)) THEN
DRAWTEXTREL(780,130,'大盘缩量调整,注意风险,短线清仓观望。'),color8000FF,LINETHICK2,ALIGN1;
IF BARSTATUS=2 and c>200 and (((AAX >= 1) AND (REF(AAX,1) > 0)) AND (V1 >= V2)) THEN
DRAWTEXTREL(780,930,'大盘走势良好,量能理想,可以继续持有强势股。'),color8000FF,LINETHICK2,ALIGN1;
IF BARSTATUS=2 and c>200 and (((AAX >= 1) AND (REF(AAX,1) > 0)) AND (V1 < V2)) THEN
DRAWTEXTREL(780,930,'大盘形态良好,但量能稍显不足,随时准备减仓。'),color8000FF,LINETHICK2,ALIGN1;
IF BARSTATUS=2 and c>200 and (((AAX < 1) AND (REF(AAX,1) < 0)) AND (V1 >= V2)) THEN
DRAWTEXTREL(780,130,'大盘趋势不明,注意成交量变化,目前不适宜进场。'),color8000FF,LINETHICK2,ALIGN1;
IF BARSTATUS=2 and c>200 and (((AAX < 1) AND (REF(AAX,1) < 0)) AND (V1 < V2)) THEN
DRAWTEXTREL(780,130,'大盘趋势向下,量能萎缩,不适合进场。'),color8000FF,LINETHICK2,ALIGN1;
DRAWTEXTABS(5,5,'股旁网 www.gupang.com'),linethick1,COLOR00EEff;
BIAS:=(C-MA20)/MA20*100;
SHAMOUNT:=AMOUNT;
SHVOL:=VOL;
J12:=(HIGH - ((HIGH - LOW) / 3));
J23:=(LOW + ((HIGH - LOW) / 3));
t1:=(((IF((CLOSE = OPEN),1,0) + IF((CLOSE >= J12),1,0)) + IF((CLOSE <= J23),1,0)) > 1);
t2:=((((CLOSE > J23) AND (CLOSE < J12)) AND (OPEN > J23)) AND (OPEN < J12));
t3:=((CLOSE >= J12) AND (OPEN <= J23));
t4:=(((OPEN <= J12) AND (OPEN >= J23)) AND (CLOSE > J12));
t5:=(((OPEN <= J23) AND (CLOSE <= J12)) AND (CLOSE >= J23));
t6:=((CLOSE <= J23) AND (OPEN >= J12));
t7:=(((OPEN <= J12) AND (OPEN >= J23)) AND (CLOSE < J23));
t8:=(((OPEN >= J12) AND (CLOSE <= J12)) AND (CLOSE >= J23));
t9:=(((SHAMOUNT / SHVOL) / 100) > REF(HIGH,1));
t10:=(((SHAMOUNT / SHVOL) / 100) < REF(LOW,1));
if DISPSTATUS=2 then begin;
GP:=' ';
if t9>0 then GP:=GP+' 上涨趋势。';
if t10>0 then GP:=GP+' 下跌趋势。';
if t1>0 then GP:=GP+' 极端行情,在未来的几日内有85%的机会变更方向。';
if t2>0 then GP:=GP+' 中性行情,多空双方都未能取得当日行情主动性的控制权';
if t3>0 then GP:=GP+' 爬升行情,整个交易期间都有买方主导。';
if t4>0 then GP:=GP+' 爬升行情,信息很少,但收盘期间是买方主导,其他未知。';
if t5>0 then GP:=GP+' 爬升行情,买方把收盘价拉升到开盘价之上,卖方也在盘中主导一段行情,但不知道是谁主导最后的行情。';
if t6>0 then GP:=GP+' 漂流行情,整个交易期间都有卖方主导。';
if t7>0 then GP:=GP+' 漂流行情,信息很少,但收盘期间是卖方主导,其他未知。';
if t8>0 then GP:=GP+' 漂流行情,卖方把收盘价压至到开盘价之下,买方也在盘中主导一段行情,但不知道是谁主导最后的行情。';
if MA20>=MA60 AND CROSS(MA40,MA60) then GP:=GP+' 形成季托,待股价回落到20天均线或40天均线时介入,20天均价为:'+MA20+',40天均价为:'+MA40+' 。';
if BIAS>9.5 AND (C-REF(C,1))/REF(C,1)*100<9.8 then GP:=GP+' 短线涨幅过大,有整理要求。';
if MA20>=MA60 AND H>=MA20 AND L<=MIN(MA40,MA60) AND C>O AND C>REF(C,1) then GP:=GP+' 芙蓉出水,趋势向好。';
if BIAS<-18 AND (C-REF(C,1))/REF(C,1)*100>-9.8 then GP:=GP+' 股价严重超跌,有爆发要求。';
if BIAS<-7 AND ALL(CLOSE<OPEN,5) then GP:=GP+' 连收五阴,超跌有反弹要求。';
if ABS(HIGH-REF(HIGH,1))/HIGH<0.001 then GP:=GP+' 平顶,该高点有一定阻力。';
if ABS(LOW-REF(LOW,1))/LOW<0.001 and abs(ref(low,1)-ref(low,2))/ref(low,1)<=0.00 then GP:=GP+' 平底,该低点有一定支撑。';
if CLOSE=OPEN AND HIGH<>close and low<>close and HIGH/LOW > 1.03 then GP:=GP+' 长十字,多空激争 前途未明。';
if OPEN/CLOSE > 1.05 AND HIGH/LOW < OPEN/CLOSE+0.018 then GP:=GP+' 大阴烛,今日空方有绝对优势。';
if REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND CLOSE/OPEN<0.98 then GP:=GP+' 双飞乌鸦,多头力竭,行情走软。';
if (MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.667 then GP:=GP+' 长下影,下档支撑强或空方试探进攻。';
if (HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667 then GP:=GP+' 长上影,上档阻力大或多方试探进攻。';
if CLOSE=OPEN AND CLOSE=LOW AND CLOSE<>HIGH then GP:=GP+' 垂死十字,在顶部时重要 表强力多头开始疲软。';
if HIGH=CLOSE AND HIGH<>LOW then GP:=GP+' 光头阳线,今日尾盘多方气盛,行情可能延续到明天。';
if (HIGH<REF(LOW,1) OR LOW>REF(HIGH,1)) then GP:=GP+' 跳空缺口,当日未补,有与跳空同向进行,上涨欲望强烈,三日内为回补观察期。';
if LOW=CLOSE AND HIGH<>LOW then GP:=GP+' 赤脚阴线,尾盘空方胜。 注意股价下跌延续至次日。';
if CLOSE=OPEN AND HIGH<>close and low<>close and high <>close then GP:=GP+' 十字星,警告信号。原趋势停顿或反转,依上下影线长度判后市。';
if CLOSE/OPEN>1.05 AND HIGH/LOW < CLOSE/OPEN+0.018 then GP:=GP+' 大阳烛,上升行情中意味行情剧烈向上攀升;下跌行情中意味行情剧烈向上反弹。';
IF REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1) < REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1)AND CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2) THEN
GP:=GP+' 早晨十字 - 如同晨星。 从看空平衡到看涨转强;左右跳空曰弃婴 。';
IF REF(CLOSE,4)/REF(OPEN,4)>1.03 AND REF(CLOSE,3)<REF(OPEN,3) AND REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN>1.03 AND CLOSE>REF(CLOSE,4) THEN GP:=GP+' 上升三部曲,空方卖压被吸纳。 趋势易顺势走涨。';
IF (ref(high,2) -ref(o,2))/ref(high,2)<=0.0003 AND (c-low)/o<=0.0003 AND ref(c,2)<ref(o,2) AND ref(c,2)>ref(o,1) AND ref(c,1)>o AND ref(c,1)<ref(o,1) AND ref(high,1)-ref(o,1)>0 AND ref(low,1)-ref(c,1)<0 AND high-o>0 AND ref(c,2)-ref(low,2)>0 THEN GP:=GP+' 三胎乌鸦,多头走势被扭转。黑K价愈深量愈大,跳空愈大,反转信号愈强。';
IF ((REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002) OR (REF(CLOSE,1)>REF(OPEN,1) AND CLOSE<OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002)) THEN
GP:=GP+' 友好反攻 - 阴(阳)线结合,极线多方跳空向下(跳空向上)后反弹有企稳迹象 。';
IF close<>open and MIN(OPEN,CLOSE)=LOW AND HIGH-LOW > 3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE > MA(CLOSE,5) THEN
GP:=GP+' 射击之星 - 如伴大量上遇阻力,有短期见顶可能,股价转疲。';
IF REF(CLOSE,1)-REF(OPEN,1)<0 AND CLOSE-OPEN>0 AND OPEN-REF(CLOSE,1)<0 AND CLOSE<REF(OPEN,1) AND CLOSE>REF(CLOSE,1) AND CLOSE>(REF(CLOSE,1)+REF(OPEN,1))/2 THEN
GP:=GP+' 贯穿线,多头力道的反扑或是空单回补力道。长阴线之后开低收在昨天1/2之上,为多头反转信号。';
IF ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04 AND ABS(CLOSE-OPEN)/CLOSE<0.005 AND MAX(CLOSE,OPEN) < MAX(REF(CLOSE,1),REF(OPEN,1)) AND MIN(CLOSE,OPEN) > MIN(REF(CLOSE,1),REF(OPEN,1)) THEN
GP:=GP+' 身怀六甲 - 阴(阳)怀阳(阴),怪异的走势,显示该股行情可能转向。 若量由大转缩,下跌趋势更明确。';
IF (ref(c,1)-ref(o,1)<0 AND c-o>0 AND c>ref(o,1) AND o<ref(c,1)) THEN
GP:=GP+' 多头阳线吞噬,阳包阴。反转趋势需量能配合量。 ';
IF ((ref(c,2)-ref(o,2)>0 AND (ABS(ref(c,2)-ref(o,2)))/(ABS(ref(c,3)-ref(o,3)))>2.4 AND ABS(c-o)>3 AND ABS(ref(c,2)-ref(o,2))>(ABS(ref(c,1)-ref(o,1))) AND ref(c,1)-ref(o,1)>0 AND c-o<0 AND ref(o,1) >ref(c,2) AND o<ref(o,1) AND c<ref(c,2) AND c>ref(o,2)) OR (ref(c,2)-ref(o,2)>0 AND (ABS(ref(c,2)-ref(o,2)))/(ABS(ref(c,3)-ref(o,3)))>2.4 AND ABS(c-o)>3 AND (ABS(ref(c,2)-ref(o,2)))>(ABS(ref(c,1)-ref(o,1))) AND ref(c,1)-ref(o,1)<0 AND c-o<0 AND ref(c,1) >ref(c,2) AND c<ref(c,2) AND c>ref(o,2) AND o<ref(c,1))) THEN
GP:=GP+' 夜星 - 从看多平衡到看空转弱,转空。 ';
IF ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04 AND CLOSE=OPEN AND CLOSE < MAX(REF(CLOSE,1),REF(OPEN,1)) AND CLOSE > MIN(REF(CLOSE,1),REF(OPEN,1)) THEN
GP:=GP+' 十字胎 - 似身怀六甲,转向可能性更大,量缩观望为宜 。';
IF ref(c,1)<ref(o,1) AND c-o>0 AND c>ref(H,1) AND o<ref(L,1) and ref(O,1)>ref(max(O,C),2) and ref(C,1)>ref(min(O,C),2) and ref(max(O,C),2)>ref(max(O,C),3) THEN
GP:=GP+' 双人殉情 - 在上升趋势中最后之空头吞噬,也就是所谓的不见长红不回头。 ';
IF (ref(c,1)-ref(o,1)>0 AND c-o<0 AND c<ref(o,1) AND o>ref(c,1)) THEN
GP:=GP+' 阴线吞噬,阴包阳,向空反转。 ';
IF REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.03 AND OPEN<REF(CLOSE,1) AND CLOSE>REF(CLOSE,1) THEN GP:=GP+' 曙光,与乌云盖顶相反,行情将演化为V型反转或止跌横盘趋势 。';
IF (ref(c,1)-ref(o,1)<0 AND c-o>0 AND c<ref(o,1) AND o>ref(c,1)) THEN
GP:=GP+' 多头孕育线,阴育阳。多头反转可能。';
IF (ref(c,1)-ref(o,1)>0 AND (ABS(ref(c,1)-ref(o,1)))/(ABS(ref(c,2)-ref(o,2)))>2.4 AND c-o<0 AND c>ref(o,1) AND ref(c,1)-o>2) THEN
GP:=GP+' 空头孕育线,阳育阴。看空 。';
IF (ref(c,1)-ref(o,1)<0 AND c-o<0 AND c>ref(c,1) AND o<ref(o,1) AND o-c <6) THEN
GP:=GP+' 空头孕育线,阴育阴。看空。';
IF REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND REF(CLOSE,1)<REF(CLOSE,2) AND CLOSE<REF(CLOSE,1) THEN
GP:=GP+' 三只乌鸦 - 强烈转空趋势,阴线越深量越大越易下跌。';
IF REF(CLOSE,4)/REF(OPEN,4)<0.97 AND REF(CLOSE,3)>REF(OPEN,3) AND REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,4) THEN
GP:=GP+' 下跌三部曲,多方弱势不堪一击,趋势易顺势走跌。';
IF REF(CLOSE,4)/REF(OPEN,4)>1.02 AND REF(CLOSE,3)<REF(OPEN,3) AND REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND REF(close,4)<=REF(close,3) AND REF(high,2)<REF(high,3) AND REF(LOW,2)>=REF(open,4) AND REF(high,1)<REF(close,4) AND REF(low,1)>REF(open,4) AND CLOSE/OPEN>1.01 AND open>=REF(open,1) AND CLOSE>=REF(HIGH,3) THEN
GP:=GP+' 连续型态之执垫,比上升三法更具多头意义。';
IF ref(O,1)/ref(C,1) > 1.05 AND ref(H,1)/ref(L,1) < ref(O,1)/ref(C,1)+0.018 and C>O and O<ref(L,1) and C=ref(L,1) THEN
GP:=GP+' 颈上线 - 下降趋势。若第二天大量,维持原趋势的可能性大增。';
IF (ref(c,1)-ref(o,1)>0 AND (ABS(ref(c,1)-ref(o,1)))/(ABS(ref(c,2)-ref(o,2)))>2.5 AND c-o<0 AND c>ref(o,1) AND c<(REF(CLOSE,1)+REF(OPEN,1))/2 AND o>ref(c,1)) THEN
GP:=GP+' 乌云罩顶 - 上涨遇重大阻力。空头聚力。';
IF (ref(c,1)-ref(o,1)>0 AND c-o<0 AND c<ref(o,1) AND o>ref(c,1)) THEN
GP:=GP+' 最后吞噬 - 在下降趋势中为一阴一阳组合,多头吞噬;在上升趋势中为一阳一阴组合,空头吞噬。';
IF ref(open,1)<>ref(close,1) and REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1) < REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2) THEN
GP:=GP+' 晨星 - 多方势盛 变盘信号';
IF MIN(OPEN,CLOSE)=LOW AND HIGH-LOW > 3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE < MA(CLOSE,5) THEN GP:=GP+' 倒转槌头 - 高位抛压或低位多空争执';
IF HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW > 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE < MA(CLOSE,5) THEN GP:=GP+' 槌头 - 下影线有多头意义。在下降趋势之后看涨。注意反弹卖压 。';
IF HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW > 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE > MA(CLOSE,5) THEN GP:=GP+' 吊颈线 - 高档看跌。';
IF ((REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.96 AND CLOSE<REF(OPEN,1) AND OPEN>REF(CLOSE,1)) OR (REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04 AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1))) THEN
GP:=GP+' 穿头破脚 - 若第一根K为阴(阳) 表强劲上涨(下跌)力量。';
IF ref(open,1)<>ref(close,1) and REF(CLOSE,2)/REF(OPEN,2) > 1.03 AND REF(OPEN,1) > REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.02 AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,2) THEN
GP:=GP+' 黄昏之星 - 空方势盛。反转信号,跳空成弃婴。';
IF REF(CLOSE,2)>REF(OPEN,2) AND (REF(CLOSE,2)-REF(OPEN,2))/REF(OPEN,2)>=2/100 AND REF(OPEN,1)>=REF(CLOSE,1) AND (REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<=2/100 AND REF(OPEN,1)<=REF(CLOSE,2) AND REF(CLOSE,1)>=REF(OPEN,2) AND C>=OPEN AND (CLOSE-OPEN)/OPEN>=2/100 AND CLOSE>=REF(OPEN,1) AND OPEN<=REF(CLOSE,1) AND (MAX(CLOSE,REF(C,2))-MIN(CLOSE,REF(CLOSE,2)))/MIN(CLOSE,REF(CLOSE,2))<=1/100 THEN GP:=GP+' 二阳夹一阴,必须从后续的走势来研判。';
IF OPEN=REF(OPEN,1) AND (CLOSE-OPEN)*(REF(CLOSE,1)-REF(OPEN,1))<0 THEN
GP:=GP+' 分离 - 两日开盘相同 一阴一阳 变盘前彻底整理。';
IF ((O>C and open>MA(C,5) and Open>MA(C,10) and O>MA(C,20) and Close<MA(C,5) and Close<MA(C,10) and Close<MA(C,20)) OR (O<C and open<MA(C,5) and Open<MA(C,10) and O<MA(C,20) and Close>MA(C,5) and Close>MA(C,10) and Close>MA(C,20))) THEN GP:=GP+' 断头铡刀(出水芙蓉) -一根大阴(阳)线切断了三根均线 如果改变了其后均线的排列为空头(多头)排列 后势看空(多) 。';
end;
TIPTEXT(DISPSTATUS=2,0,GP);
V1:=ref(c,5)<ref(O,5) and ref(c,4)<ref(O,4) and ref(c,3)<ref(O,3);
DRAWICON((V1 AND all(C>O,2)) OR (V1 AND C>O AND REF(C,1)<REF(O,1) AND REF(C,2)>REF(O,2)),L*0.958,1),ALIGN2;
DRAWTEXT((V1 AND all(C>O,2)) OR (V1 AND C>O AND REF(C,1)<REF(O,1) AND REF(C,2)>REF(O,2)),L*0.97,'买点'),COLORred,ALIGN2;
V2:=(REF(HIGH,1)+REF(LOW,1))/2;
V3:=MA(CLOSE,20)+2*STD(CLOSE,20);
DRAWTEXT(CROSS(V2,V3),HIGH*1.03,'卖'),COLORgreen,ALIGN2;
V4:=REF(CLOSE,1);
V5:=SMA(MAX(CLOSE-V4,0),7,1)/SMA(ABS(CLOSE-V4),7,1)*100;
V6:=CROSS(79,V5);
V7:=FILTER(V6,4);
DRAWICON(V7,HIGH*1.025,2),ALIGN2;
DRAWTEXT(V7,HIGH*1.035,'绝卖'),COLORgreen,ALIGN2;

大智慧智能K线主图指标公式

 

相关文章