在线检测未来函数

通达信MACD量价指标公式

来源:Internet,编辑:股旁网,2011-09-11

成交额:AMOUNT/100000000,NODRAW;
主力:(LARGEINTRDVOL-LARGEOUTTRDVOL)*(11)/100,NODRAW;
大单:主力/成交额/100,NODRAW;
连红:BARSLASTCOUNT(主力>0),COLORRED,NODRAW;
预量:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,预量,0,3,-1),COLORFFFFFF;
量_价:=1;
CTKG:=1;
W:=量_价;
EPSL:=0.0001;
ZZ:=(C+H+L)/3;
TJA:=ZZ>=MAX(C,O) AND CTKG=1;
TJB:=ZZ<=MIN(C,O) AND CTKG=1;
ZF:=IF(TJA,1,IF(TJB,-1,0));
TJ0:=TJA OR TJB;
TJ1:=H=L AND C>REF(C,1);
TJ2:=H=L AND C<REF(C,1);
TJ3:=H=L AND C=REF(C,1);
量_价:=IF(W=1,VOL,AMOUNT),STICK,COLOREEFFEE;
EE:=IF(TJ1,EPSL,IF(TJ2,-EPSL,0));
ZL:=2*(H-L)+ABS(C-O)+3*IF(TJ3,EPSL,ABS(EE));
JGL_DX:=(IF(TJ0,2/3*(2*C-H-L)+ZF*ABS(C-O),(C-O))+EE)/ZL;
买卖差:=JGL_DX*量_价,COLOR13AADD,NODRAW;
DX%:JGL_DX*100,NODRAW,COLORGREEN;
DX连红:BARSLASTCOUNT(DX%>0),COLORRED,NODRAW;
买盘:=量_价*(1+JGL_DX)/2,COLOR1133AA,NODRAW;
卖盘:=量_价*(1-JGL_DX)/2,COLORFFFF00,NODRAW;
VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主动买盘:=IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),LINETHICK0;
主动卖盘:=IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-VAR1*(HIGH-LOW),0-VOL/2)),LINETHICK0,COLORGREEN;
DDX:=买盘-卖盘;
MADDX:=MA(DDX,5)*15;
{www.gUPang.com 股旁网_最新股票指标公式}
DDX1:SMA(MADDX,3,1),COLORRED,LINETHICK2;
DDX2:SMA(DDX1,3,1),COLORGREEN,LINETHICK2;
DDX3:SMA(DDX2,3,1),COLORYELLOW,LINETHICK2;
净量:=主动买盘+主动卖盘,NODRAW;
STICKLINE(C<O ,0,VOL,3.0,0),COLORFF1100;
STICKLINE(C<O ,0,VOL,2.5,0),COLORFF3300;
STICKLINE(C<O ,0,VOL,2.1,0),COLORFF5500;
STICKLINE(C<O ,0,VOL,1.5,0),COLORFF7700;
STICKLINE(C<O ,0,VOL,0.9,0),COLORFF9900;
STICKLINE(C<O ,0,VOL,0.3,0),COLORFFBB00;
STICKLINE(C=O AND C<REF(C,1),0,VOL,3.0,0),COLOR006000;
STICKLINE(C=O AND C<REF(C,1),0,VOL,2.5,0),COLOR007500;
STICKLINE(C=O AND C<REF(C,1),0,VOL,2.1,0),COLOR009100;
STICKLINE(C=O AND C<REF(C,1),0,VOL,1.5,0),COLOR00A600;
STICKLINE(C=O AND C<REF(C,1),0,VOL,0.9,0),COLOR00BB00;
STICKLINE(C=O AND C<REF(C,1),0,VOL,0.3,0),COLOR00CC00;
STICKLINE(C=O AND C>REF(C,1),0,VOL,3.0,0),COLOR555555;
STICKLINE(C=O AND C>REF(C,1),0,VOL,2.5,0),COLOR777777;
STICKLINE(C=O AND C>REF(C,1),0,VOL,2.1,0),COLOR999999;
STICKLINE(C=O AND C>REF(C,1),0,VOL,1.5,0),COLORBBBBBB;
STICKLINE(C=O AND C>REF(C,1),0,VOL,0.9,0),COLORDDDDDD;
STICKLINE(C=O AND C>REF(C,1),0,VOL,0.3,0),COLORFFFFFF;
STICKLINE(C>O,0,VOL,3.0,0),COLORFF11FF;
STICKLINE(C>O,0,VOL,2.5,0),COLORFF33FF;
STICKLINE(C>O,0,VOL,2.1,0),COLORFF55FF;
STICKLINE(C>O,0,VOL,1.5,0),COLORFF77FF;
STICKLINE(C>O,0,VOL,0.9,0),COLORFF99FF;
STICKLINE(C>O,0,VOL,0.3,0),COLORFFBBFF;
资金异动:=VOL/MA(VOL,55)*100,COLORYELLOW;
STICKLINE(主动买盘>0,0,主动买盘,3.0,0),COLOR000055;
STICKLINE(主动买盘>0,0,主动买盘,2.5,0),COLOR000077;
STICKLINE(主动买盘>0,0,主动买盘,2.1,0),COLOR000099;
STICKLINE(主动买盘>0,0,主动买盘,1.5,0),COLOR0000BB;
STICKLINE(主动买盘>0,0,主动买盘,0.9,0),COLOR0000DD;
STICKLINE(主动买盘>0,0,主动买盘,0.3,0),COLOR0000FF;
STICKLINE(主动卖盘<0,0,主动卖盘,3.0,0),COLOR006000;
STICKLINE(主动卖盘<0,0,主动卖盘,2.5,0),COLOR007500;
STICKLINE(主动卖盘<0,0,主动卖盘,2.1,0),COLOR009100;
STICKLINE(主动卖盘<0,0,主动卖盘,1.5,0),COLOR00A600;
STICKLINE(主动卖盘<0,0,主动卖盘,0.9,0),COLOR00BB00;
STICKLINE(主动卖盘<0,0,主动卖盘,0.3,0),COLOR00CC00;
STICKLINE(资金异动>100 ,0,VOL,0.6,0),COLORYELLOW;

通达信MACD量价指标公式

 

相关文章