在线检测未来函数

通达信贵族典雅MACD指标公式

来源:Internet,编辑:股旁网,2011-09-20

SHORT:=6;
LONG:=9;
MID:=3;
DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG),LINETHICK1,COLOR0000FF;
DEA:EMA(DIF,MID);
DRAWBAND(DIF,RGB(500,180,280),DEA,RGB(380,280,180));
MACD:(DIF-DEA)*2,COLORSTICK;
上敬:IF(DIF>=REF(DIF,1),DIF,DRAWNULL),LINETHICK2,COLORRED;
下尊:IF(DIF<REF(DIF,1),DIF,DRAWNULL),COLORGREEN,LINETHICK2;
DRAWICON(CROSS(DIF,DEA) AND DIF>REF(DIF,1) AND DEA<0,DIF,0);
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,2.7,0),COLOR000033;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,2.1,0),COLOR000066;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,1.5,0),COLOR000099;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,0.9,0),COLOR0000CC;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,0.3,0),COLOR0000FF;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,2.7,0),COLOR0035FF;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,2.1,0),COLOR0064FF;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,1.5,0),COLOR0093FF;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,0.9,0),COLOR00C2FF;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,0.3,0),COLOR00FFFF;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),MACD,0,2.7,0),COLORFF3300;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),MACD,0,2.1,0),COLORFF6600;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),MACD,0,1.5,0),COLORFF9900;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),MACD,0,0.9,0),COLORFFCC00;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),MACD,0,0.3,0),COLORFFFF00;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,2.7,0),COLORFF0033;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,2.1,0),COLORFF0066;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,1.5,0),COLORFF0099;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,0.9,0),COLORFF00CC;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,0.3,0),COLORFF00FF;
{www.gUPang.com 股旁网_最新股票指标公式}
A1:=BARSLAST(REF(CROSS(DIF,DEA),1));
背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);
DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORLIMAGENTA,LINETHICK2;
A2:=BARSLAST(REF(CROSS(DEA,DIF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF AND CROSS(DEA,DIF);
DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORBLUE,LINETHICK2;

通达信贵族典雅MACD指标公式

 

相关文章