在线检测未来函数

通达信量能红孩儿指标公式

来源:Internet,编辑:股旁网,2011-09-20

N:=23;
VAR1:=(100-100/(1+SUM(VOL,N)/CAPITAL))*CAPITAL*96/10000;
LNC:=VAR1*CLOSE;
B1:=REF(LNC,1);B2:=REF(LNC,2);
SS:=IF(LNC>REF(LNC,1) AND REF(LNC,1)>=REF(LNC,2),1,IF(LNC<REF(LNC,1) AND REF(LNC,1)<=REF(LNC,2),-1,IF(LNC>REF(LNC,2) AND REF(LNC,2)>REF(LNC,1),2,IF(LNC<REF(LNC,2) AND REF(LNC,2)<REF(LNC,1),-2,0))));
{www.gUPang.com 股旁网_最新股票指标公式}
SM:=IF(REF(SS,1)>0,REF(SS,1),IF(REF(SS,2)>0,REF(SS,2),IF(REF(SS,3)>0,REF(SS,3),IF(REF(SS,4)>0,REF(SS,4),IF(REF(SS,5)>0,REF(SS,5),IF(REF(SS,6)>0,REF(SS,6),IF(REF(SS,7)>0,REF(SS,7),0)))))));
MC:=IF(REF(SS,1)>0,B2,IF(SM>0,MIN(B1,B2),MAX(B1,B2))),COLORFF00FF;
SS1:=IF(LNC>REF(LNC,1) AND REF(LNC,1)>=REF(LNC,2),1,IF(LNC<REF(LNC,1) AND REF(LNC,1)<=REF(LNC,2),-1,IF(LNC>REF(LNC,2) AND REF(LNC,2)>REF(LNC,1),2,IF(LNC<REF(LNC,2) AND REF(LNC,2)<REF(LNC,1),-2,0))));
SM1:=IF(REF(SS,1)<0,REF(SS,1),IF(REF(SS,2)<0,REF(SS,2),IF(REF(SS,3)<0,REF(SS,3),IF(REF(SS,4)<0,REF(SS,4),IF(REF(SS,5)<0,REF(SS,5),IF(REF(SS,6)<0,REF(SS,6),IF(REF(SS,7)<0,REF(SS,7),0)))))));
MC1:=IF(REF(SS,1)<0,B2,IF(SM>0,MIN(B1,B2),MAX(B1,B2))),COLORFF00FF;
A:MA(SQRT(MC),1),COLORFF9933,LINETHICK2;
IF(A>=REF(A,1),A,DRAWNULL),COLORRED,LINETHICK4;
IF(A<REF(A,1),A,DRAWNULL),COLORFF9933,LINETHICK2;
A1:MA(SQRT(MC1),5),COLOR33FF33,LINETHICK2;
IF(A1>=REF(A1,1),A1,DRAWNULL),COLORFF00FF,LINETHICK3;
IF(A1<REF(A1,1),A1,DRAWNULL),COLOR33FF33,LINETHICK2;
IF(A1>REF(A1,1),A1,DRAWNULL),COLOR00FFFF,POINTDOT,LINETHICK5;

通达信量能红孩儿指标公式

 

相关文章