在线检测未来函数

通达信精进MACD指标公式

来源:Internet,编辑:股旁网,2011-09-21

收距:=(INDEXC-EMA(INDEXC,12))/EMA(INDEXC,12)*100;
九收:=EMA(收距,9);
DIF2:(EMA(C,12)-EMA(C,26))/EMA(C,26)*100;
DEA2:EMA(DIF2,9);
DRAWBAND(DIF2,RGB(205,92,92),DEA2,RGB(28,134,238));
MACD2:(DIF2-DEA2)*2,NODRAW;
STICKLINE(MACD2>=0 AND MACD2>REF(MACD2,1),0,MACD2,2.5,0),COLORRED;
STICKLINE(MACD2<0 AND MACD2<REF(MACD2,1),0,MACD2,2.5,0),COLORMAGENTA;
D升:IF(DIF2>=REF(DIF2,1),DIF2,DRAWNULL)COLORRED,LINETHICK2;
M升:STICKLINE(MACD2<0 AND MACD2>=REF(MACD2,1),0,MACD2,2.5,0)COLORWHITE;
M降:STICKLINE(MACD2>=0 AND MACD2<REF(MACD2,1),0,MACD2,2.5,0)COLORYELLOW;
M位:(MACD2-LLV(MACD2,20))/(HHV(MACD2,20)-LLV(MACD2,20))*10,COLORRED,LINETHICK2;
{www.gUPang.com 股旁网_最新股票指标公式}
上:IF(M位>REF(M位,1),M位,DRAWNULL),COLORRED;
下:IF(M位<REF(M位,1),M位,DRAWNULL),COLORGREEN,LINETHICK2;
D位:(DIF2-LLV(DIF2,20))/(HHV(DIF2,20)-LLV(DIF2,20))*10,COLORYELLOW;
E位:(DEA2-LLV(DEA2,20))/(HHV(DEA2,20)-LLV(DEA2,20))*10,COLORLICYAN;
DRAWICON(CROSS(E位,0.001),-9,13);
筑底:IF(M位=0 AND D位=0,-7,-10);
短底:IF(M位=0 AND D位=0 AND E位=0,-5,-10),LINETHICK2,COLORGREEN;
潜:IF(LAST(MACD2<0,5,0)AND MACD2>=REF(MACD2,1),-12,-10),COLORYELLOW;
DRAWICON(M位<10 AND REF(M位,1)=10,M位*0.985,2);
大盘超跌:IF(九收<=-5 AND DEA2<=-5,5,0);

通达信精进MACD指标公式

 

相关文章