在线检测未来函数

通达信飞毛腿量柱擒涨停超赢版之无敌量线王主图指标公式

来源:Internet,编辑:股旁网,2011-09-26

A7:=C-REF(C,1);
A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);
SHORT:=7; LONG:=19;
RMA:=EMA(CLOSE,SHORT);
NMA:=EMA(CLOSE,LONG);
UP:DRAWLINE(L=LLV(L,BARSLAST(CROSS(NMA,RMA))+1),LLV(L,BARSLAST(CROSS(NMA,RMA))+1),H=HHV(H,BARSLAST(CROSS(RMA,NMA))+1),HHV(H,BARSLAST(CROSS(RMA,NMA))+1),0);
DOWN:DRAWLINE(H=HHV(H,BARSLAST(CROSS(RMA,NMA))+1),HHV(H,BARSLAST(CROSS(RMA,NMA))+1),L=LLV(L,BARSLAST(CROSS(NMA,RMA))+1),LLV(L,BARSLAST(CROSS(NMA,RMA))+1),0);
买进:=(LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2))) AND REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1);
{www.gUPang.com 股旁网_最新股票指标公式}
趋势区:=IF((EVERY(DOWN>=REF(DOWN,1),1)),4,2);
低买:=IF(((CROSS(趋势区,2.1))),1.5,0),STICK,COLORRED,LINETHICK3;
高卖:=IF(((CROSS(3.9,趋势区))),-0.7,0),STICK,COLORFF9150,LINETHICK3;
TY:=C;
A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1); HD:=FILTER(C1,10);
A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10);
AA:=REF(C,BARSLAST(HD)); B:=REF(C,BARSLAST(LD));
T1:=BARSLAST(HD)<BARSLAST(LD) AND NOT(HD) ;
T2:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);
峰顶线:IF(T1>=1,AA,DRAWNULL),COLOR00FF60;
波峰射线:=IF(T1<1,AA,DRAWNULL),POINTDOT,COLOR00FF60;
峰谷线:IF(T2>=1,B,DRAWNULL),COLORRED;
波谷射线:=IF(T2<1,B,DRAWNULL),POINTDOT,COLORFF00FF;
YY:=(H+L+C)/3;DRAWKLINE(YY,YY,YY,YY+0.00006),COLORGREEN;
N:=13;
L0:=0.02;
L5:=ABS(L-REF(L,N))<=L0
OR ABS(C-REF(L,N))<=L0
OR ABS(O-REF(L,N))<=L0
OR ABS(L-REF(O,N))<=L0
OR ABS(C-REF(O,N))<=L0
OR ABS(O-REF(O,N))<=L0
OR ABS(L-REF(C,N))<=L0
OR ABS(C-REF(C,N))<=L0
OR ABS(O-REF(C,N))<=L0
OR ABS(L-REF(H,N))<=L0
OR ABS(C-REF(H,N))<=L0
OR ABS(O-REF(H,N))<=L0;
精准线首次:= L5;
精准左:=FILTER(精准线首次,N) ;
天数:=BARSLAST(精准左);
LTS:=REF(L,天数);
精准右:=ABS(L-LTS)<=L0;
STICKLINE(精准左,L,L,190,-1),COLORMAGENTA;
DRAWLINE(精准左,L,精准右,LTS,0),COLORMAGENTA;
TJ1:=LLV(CLOSE,3)>REF(L,3) AND HHV(V,1)<=REF(V,3) AND REF(C,3)>REF(O,3) AND REF(V,3)>0.8*REF(V,4) AND REF(V,3)>1.1*REF(V,5);
LJL:=FILTER(TJ1,1);
TJ2:=IF(BARSLAST(LJL)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(LJL)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(LJL)=3 AND CLOSE>REF(HIGH,3),1,0)));
TP:=TJ2=1;
STICKLINE(CLOSE,REF(LLV(L,3),BARSLAST(LJL)),REF(LLV(L,3),BARSLAST(LJL)),6,0),COLORYELLOW;
TJ3:=IF(BARSLAST(LJL)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(LJL)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(LJL)=3 AND CLOSE>REF(LOW,3),1,0)));
STFZ:=TJ3=1;
CL:=STFZ AND TP;
TJCL:=FILTER(CL,3);

通达信飞毛腿量柱擒涨停超赢版之无敌量线王主图指标公式

 

相关文章