在线检测未来函数

通达信猎豹趋势主图指标公式

来源:Internet,编辑:股旁网,2011-09-07

VAR1:=EMA(EMA(CLOSE,9),9);
主力:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
开始进场:=CROSS(主力,0);
无庄:=主力<0;
有庄:=主力>REF(主力,1) AND 主力>0;
VAR2:=100*WINNER(CLOSE*0.95);
强庄:=VAR2>50 AND COST(85)<CLOSE AND 主力>0;
出货:=主力<REF(主力,1) AND 主力>0;
操盘线:=MA(CLOSE,5),COLORWHITE;
工作线:EXPMA(CLOSE,12),COLORRED,LINETHICK2;
工作线下跌:IF(EXPMA(CLOSE,12)<REF(EXPMA(CLOSE,12),1),EXPMA(CLOSE,12),DRAWNULL),COLORGREEN,LINETHICK2;
生命线:EXPMA(CLOSE,50),COLORMAGENTA,LINETHICK2;
生命线下跌:IF(EXPMA(CLOSE,50)<REF(EXPMA(CLOSE,50),1),EXPMA(CLOSE,50),DRAWNULL),COLORBLUE,LINETHICK2;
强势:=主力>REF(主力,1) AND 主力>0;
进入短线强势区:=CROSS("KDJ.J",80) AND "MACD.DIF">"MACD.DEA"
AND MA(C,5)>MA(C,30) AND "MACD.MACD">REF("MACD.MACD",1);
TJ强于大盘:=C/REF(C,1)>INDEXC/REF(INDEXC,1);
DRAWICON("KDJ.J"-REF("KDJ.J",1)>30 AND C/REF(C,1)>1.043 AND "MACD.MACD">0 AND
工作线>生命线,L*0.90,5);
HD:=FILTER(BACKSET(FILTER(REF(C,10)=HHV(C,2*10+1),10),10+1),10);
LD:=FILTER(BACKSET(FILTER(REF(C,10)=LLV(C,2*10+1),10),10+1),10);
{www.gUPang.com 股旁网_最新股票指标公式}
波峰:IF(BARSLAST(HD)<BARSLAST(LD) AND NOT(HD),REF(C,BARSLAST(HD)),REF(C,BARSLAST(HD))),COLORFF00FF,POINTDOT;
波谷:IF(BARSLAST(HD)>BARSLAST(LD) AND NOT(LD),REF(C,BARSLAST(LD)),REF(C,BARSLAST(LD))),COLOR80FF00,POINTDOT;
突破:=CROSS(C,波峰) AND VOL>MA(VOL,25) AND C/REF(C,1)>1.0143;
DRAWTEXT(突破,L*0.85,'突破'),COLORMAGENTA;
起爆:="KDJ.J"-REF("KDJ.J",1)>30 AND C/REF(C,1)>1.043
AND "MACD.MACD">0 AND 工作线>生命线;
STICKLINE(有庄 AND C>=O AND "MACD.DEA">0,C,O,3,1),COLORRED;
STICKLINE(有庄 AND C<O AND "MACD.DEA">0,C,O,3,0),COLORRED;
STICKLINE(强庄 AND C>=O AND "MACD.DEA">0 AND "MACD.MACD">0,C,O,3,1),COLORMAGENTA;
STICKLINE(强庄 AND C<O AND "MACD.DEA">0 AND "MACD.MACD">0,C,O,3,0),COLORMAGENTA;
STICKLINE(出货 AND C>=O OR 主力<0 AND "MACD.DEA">0 AND C>=O ,C,O,3,1),COLORGREEN;
STICKLINE(出货 AND C<O OR 主力<0 AND "MACD.DEA">0 AND C<O ,C,O,3,0),COLORGREEN;
STICKLINE(主力<0 AND "MACD.DEA"<0 AND C<O OR "MACD.DEA"<0 AND C<O,C,O,3,0),COLORBLUE;
STICKLINE(主力<0 AND "MACD.DEA"<0 AND C>=O OR "MACD.DEA"<0 AND C>=O,C,O,3,1),COLORBLUE;
DRAWICON(突破 OR 起爆,L*0.97,1);

通达信猎豹趋势主图指标公式

 

相关文章