在线检测未来函数

通达信猎豹擒庄主图指标公式

来源:Internet,编辑:股旁网,2011-09-07

VAR1:=EMA(EMA(CLOSE,9),9);
主力:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
无庄:=主力<0;
有庄:=主力>REF(主力,1) AND 主力>0;
VAR2:=100*WINNER(CLOSE*0.95);
强庄:=VAR2>50 AND COST(85)<CLOSE AND 主力>0;
出货:=主力<REF(主力,1) AND 主力>0;
STICKLINE(有庄 AND C>=O,C,O,3,1),COLORRED;
STICKLINE(有庄 AND C<O,C,O,3,0),COLORRED;
STICKLINE(强庄 AND C>=O,C,O,3,1),COLORMAGENTA;
STICKLINE(强庄 AND C<O,C,O,3,0),COLORMAGENTA;
STICKLINE(出货 AND C>=O,C,O,3,1),COLORGREEN;
STICKLINE(出货 AND C<O,C,O,3,0),COLORGREEN;
STICKLINE(主力<0 AND C<O,C,O,3,0),COLORBLUE;
STICKLINE(主力<0 AND C>=O,C,O,3,1),COLORBLUE;
短线:=MA(CLOSE,3),COLORYELLOW,LINETHICK1;
操盘线:MA(CLOSE,5),COLORRED,LINETHICK1;
K311:=操盘线<REF(操盘线,1);K3121:=BACKSET(K311,2);
DRAWLINE(K3121,操盘线,K311,操盘线,0),COLORGREEN, LINETHICK1;
趋势:MA(CLOSE,30),COLORYELLOW,LINETHICK2;
上升趋势:IF(MA(CLOSE,30)>=REF(MA(CLOSE,30),1),MA(CLOSE,30),DRAWNULL),COLORMAGENTA,LINETHICK2;
下降趋势:IF(MA(CLOSE,30)<REF(MA(CLOSE,30),1),MA(CLOSE,30),DRAWNULL),COLORGREEN,LINETHICK2;
强势:=主力>REF(主力,1) AND 主力>0;
进入短线强势区:=CROSS("KDJ.J",80) AND "MACD.DIF">"MACD.DEA"
AND MA(C,5)>MA(C,30) AND "MACD.MACD">REF("MACD.MACD",1);
HD:=FILTER(BACKSET(FILTER(REF(C,10)=HHV(C,2*10+1),10),10+1),10);
LD:=FILTER(BACKSET(FILTER(REF(C,10)=LLV(C,2*10+1),10),10+1),10);
波峰:IF(BARSLAST(HD)<BARSLAST(LD) AND NOT(HD),REF(C,BARSLAST(HD)),REF(C,BARSLAST(HD))),COLORFF00FF,POINTDOT;
STICKLINE(BARSLAST(HD)<BARSLAST(LD) AND NOT(HD),REF(C,BARSLAST(HD)),REF(C,BARSLAST(HD)),9,2),COLORGREEN;
{www.gUPang.com 股旁网_最新股票指标公式}
突破波峰:=CROSS(C,波峰) AND VOL>MA(VOL,25) AND C/REF(C,1)>1.0143;
DRAWTEXT(突破波峰,L*0.870,'突破'),COLORMAGENTA;
DRAWICON("KDJ.J"-REF("KDJ.J",1)>30 AND C/REF(C,1)>1.043 AND "MACD.MACD">0
AND EXPMA(C,12)>EXPMA(C,50),L*0.90,5);
DRAWTEXT("KDJ.J"-REF("KDJ.J",1)>30 AND C/REF(C,1)>1.043
AND "MACD.MACD">0 AND
EXPMA(C,12)>EXPMA(C,50),L*0.95,'起爆'),COLORRED;

通达信猎豹擒庄主图指标公式

 

相关文章