在线检测未来函数

通达信主力现形指标公式

来源:Internet,编辑:股旁网,2011-09-09

MV5:=EMA(V,5);
MA5:=EMA(C,5);
MV5角度:=ATAN((MV5/REF(MV5,1)-1)*100)*180/3.1416;
MA5角度:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;
量角:IF(MV5角度>30,MV5角度,0),COLOR0000FF,LINETHICK0;
价角:IF(MA5角度>0,MA5角度,MA5角度),COLORFFFFFF,LINETHICK2;
IF(价角>REF(价角,1) AND 价角>=0,价角,DRAWNULL),COLORRED,LINETHICK2;
IF(价角<REF(价角,1) AND 价角>0,价角,DRAWNULL),COLOR00FF00,LINETHICK2;
QSXS:=MA5角度>REF(MA5角度,1) AND MV5角度>80;
∠45↑: IF(CROSS(MA5角度,30),1,0),COLORFFFFFF,POINTDOT,LINETHICK0;
买强:IF(MA5角度>45 AND QSXS,10,0),COLOR00FFFF,POINTDOT,LINETHICK0;
防火:IF(MA5角度>70 AND MV5角度>80,20,0),COLORFF00FF,POINTDOT,LINETHICK0;
卖疯:IF(MA5角度>80 AND MV5角度>80,30,0),COLOR0000FF,POINTDOT,LINETHICK0;
WK:=MA5角度=LLV(MA5角度,3) AND MA5角度-HHV(MA5角度,4)<=0-50;
{www.gUPang.com 股旁网_最新股票指标公式}
挖坑:IF(WK AND COUNT(买强 OR 防火,6),0-30,0),COLOR00FF00;
海底:IF(MA5角度<0-75,0-50,0-75),COLORFF8800;
{以下设置副图显示方式}
STICKLINE(MV5角度>30,MV5角度,30,0.1,0),COLOR0000FF;
STICKLINE(买强,0,10,2,0),COLOR00FFFF;
STICKLINE(防火,10,20,2,0),COLORFF00FF;
STICKLINE(卖疯,20,30,2,0),COLOR0000FF;
DRAWTEXT(∠45↑,30, '↑'),COLORFFFFFF;
STICKLINE(∠45↑,0-90,30,0.1,0),COLOR00FFFF;
30,COLORFFFFFF;
{以下设置短线强弱提示}
M3:=MA(C,3);
M5:=MA(C,5);
N1:=BARSLAST(CROSS(M3,M5));
N2:=BARSLAST(CROSS(M5,M3));
N:=IF(N1<N2,N1+1,0-N2-1);
STICKLINE(N>0,0-75,0-75+N*2,2,0),COLOR0000FF;
STICKLINE(N<0,0-75,0-75+N*2,2,0),COLORFFFF00;

通达信主力现形指标公式

 

相关文章