在线检测未来函数

通达信MACD神马版指标公式

来源:Internet,编辑:股旁网,2011-10-04

DIFF:EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIFF,9);
MACD:2*(DIFF-DEA),COLORSTICK;
STICKLINE(MACD<REF(MACD,1) AND MACD>0,0,MACD,0,0),COLORGREEN;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,0,0),COLORMAGENTA;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=1,21)=1;
STICKLINE(金叉,0,0.1,5,0),COLOR0000FF;
DRAWTEXT(金叉,-0.095,'金叉'),COLOR0000FF;
二金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二金叉,0,0.15,5,0),COLORLIRED;
DRAWTEXT(二金叉,0.23,'二次金叉'),COLORLIRED;
三金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=3,28)=1;
STICKLINE(三金叉,0,0.2,5,0),COLORLIGREEN;
DRAWTEXT(三金叉,0.28,'三次金叉'),COLORLIGREEN;
四金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=4,28)=1;
STICKLINE(四金叉,0,0.25,5,0),COLORCYAN;
DRAWTEXT(四金叉,0.33,'四次金叉'),COLORCYAN;
五金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=5,33)=1;
STICKLINE(五金叉,0,0.3,5,0),COLORBLUE;
DRAWTEXT(五金叉,0.37,'五次金叉'),COLORBLUE;
六金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=6,33)=1;
STICKLINE(六金叉,0,0.35,5,0),COLORYELLOW;
DRAWTEXT(六金叉,0.0.7,'黄金底'),COLORYELLOW;
DRAWTEXT(六金叉,0.42,'六次金叉'),COLORYELLOW;
七金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=7,33)=1;
STICKLINE(七金叉,0,0.4,5,0),COLORWHITE;
DRAWTEXT(七金叉,0.0.88,'白金底'),COLORWHITE;
DRAWTEXT(七金叉,0.47,'七次金叉'),COLORWHITE;
八金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=8,33)=1;
STICKLINE(八金叉,0,0.5,5,0),COLORMAGENTA;
DRAWTEXT(八金叉,0.0.8,'钻石底'),COLORMAGENTA;
DRAWTEXT(八金叉,0.57,'八次金叉'),COLORMAGENTA;
九金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=9,33)=1;
STICKLINE(九金叉,0,0.55,5,0),COLORRED;
DRAWTEXT(九金叉,0.0.8,'金钻底'),COLORRED;
DRAWTEXT(九金叉,0.6,'九次金叉'),COLORRED;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
{www.gUPang.com 股旁网_最新股票指标公式}
背离:=(REF(L,A1+1)>L OR REF(C,A1+1)>C) AND (L,DIFF)>REF((L,DIFF),A1+1) AND CROSS(DIFF,DEA);
STICKLINE(底背离,0,-0.1,5,0),COLORRED;
DRAWTEXT(底背离,DEA,'底背离')COLORRED;
DRAWLINE(A1=0,DEA,底背离,DEA,0),COLOR0000FF,LINETHICK3;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=(REF(C,A2+1)<C OR REF(H,A2+1)<H) AND REF((H,DIFF),A2+1)>(H,DIFF) AND CROSS(DEA,DIFF);
DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,LINETHICK3;
STICKLINE(顶背离,0,0.1,5,0),COLORGREEN;
DRAWTEXT(顶背离,DEA,'顶背离')COLORGREEN;
DRAWTEXT(CROSS(DIFF,DEA) AND 二金叉 AND 底背离,0.3,'三全底'),COLOR0000FF;
IF(DIFF>DEA,DIFF,DRAWNULL),COLORWHITE,LINETHICK2;
IF(DEA>REF(DEA,1) AND DIFF>DEA,DEA,DRAWNULL),COLORYELLOW,LINETHICK2;

通达信MACD神马版指标公式

 

相关文章