在线检测未来函数

通达信线的角度主图指标公式

来源:Internet,编辑:股旁网,2011-10-05

N:=10;
HH20:=CONST(HHV(H,N*3));
LL20:=CONST(LLV(L,N*3));
K:=(HH20-LL20)/(N),NODRAW;
XY:DRAWLINE(CURRBARSCOUNT=N,LL20,CURRBARSCOUNT=1,HH20,0),LINETHICK1,COLORFFFFFF;
YX:DRAWLINE(CURRBARSCOUNT=N,HH20,CURRBARSCOUNT=1,LL20,0),LINETHICK1,COLORFFFFFF;
中位线:(XY+YX)/2,LINETHICK1,COLORFFFFFF;
XX:IF(CURRBARSCOUNT<N+1,HH20,DRAWNULL),LINETHICK1,COLORFFFFFF;
YY:IF(CURRBARSCOUNT<N+1,LL20,DRAWNULL),LINETHICK1,COLORFFFFFF;
STICKLINE(CURRBARSCOUNT=1,HH20,LL20,0,0),COLORFFFFFF;
STICKLINE(CURRBARSCOUNT=N,HH20,LL20,0,0),COLORFFFFFF;
参考标准角:ATAN((HH20-LL20)/(N*K))*57.29633,COLORFFFFFF,NODRAW;
MAN:=MA(C,N),COLORAAAAFF;
DRAWTEXT(CURRBARSCOUNT=N-2,LL20*1.03,'主图画面参考标准角=45°'),COLORAAFFFF;
X角K:=CONST(REF(MAN,1)-MAN)*(CURRBARSCOUNT-1)+CONST(MAN);
{www.gUPang.com 股旁网_最新股票指标公式}
MAN角斜线:DRAWLINE(CURRBARSCOUNT=N,X角K,CURRBARSCOUNT=1,X角K,0),LINETHICK2,COLOR00FFFF;
MAN角水平线:IF(CURRBARSCOUNT<=N,CONST(REF(MAN角斜线,N-1)),DRAWNULL),LINETHICK2,COLOR00FFFF;
STICKLINE(CURRBARSCOUNT=1,CONST(MAN角水平线),MAN角斜线,0.03,0),COLOR00FFFF;
MAN线:MAN,LINETHICK2,COLORAAAAFF;
MAN角:CONST(ATAN((MAN角斜线-MAN角水平线)/(N*K))*57.29633),NODRAW;

通达信线的角度主图指标公式

 

相关文章