在线检测未来函数

通达信心爱画线主图指标公式

来源:Internet,编辑:股旁网,2011-10-06

M1:=7;M2:=21;
获利%:WINNER(CLOSE)*100,NODRAW,COLORRED;
参考:MA(CLOSE,M1),COLORYELLOW;
趋势:MA(CLOSE,M2),COLORMAGENTA;
JRH:=HHV(C,2);
JRL:=LLV(C,2);
MA3:=MA(CLOSE,3);
YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;
VAR1O:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VAR2O:=(REF(VAR1O,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR3O:=(REF(VAR2O,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR4O:=(REF(VAR3O,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR5O:=(REF(VAR4O,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR6O:=(REF(VAR5O,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR7O:=(REF(VAR6O,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR8O:=(REF(VAR7O,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR9O:=(REF(VAR8O,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARAO:=(REF(VAR9O,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARBO:=(REF(VARAO,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARCO:=(REF(VARBO,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARDO:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
VAREO:=(REF(VARDO,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARFO:=(REF(VAREO,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR10:=(REF(VARFO,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR19:=((REF(VARDO OR VAREO OR VARFO OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1O);
VAR1AO:=((REF(VAR1O OR VAR2O OR VAR3O OR VAR4O OR VAR5O OR VAR6O OR VAR7O OR VAR8O OR VAR9O OR VARAO OR VARBO OR VARCO,1)) AND VARDO);
红色持股:=VAR1O OR VAR2O OR VAR3O OR VAR4O OR VAR5O OR VAR6O OR VAR7O OR VAR8O OR VAR9O OR VARAO OR VARBO OR VARCO,COLOR0000FF,NODRAW;
离场A:=IF(红色持股,JRL,DRAWNULL);
明离场价:=离场A,COLORFF99FF,NODRAW;
今离场价:REF(离场A,1)COLOR0000FF,NODRAW;
青色观望:=VARDO OR VAREO OR VARFO OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,COLORFFFF00,NODRAW;
进:=IF(青色观望,JRH,DRAWNULL);
明进场价:=进,COLOR33AACC,NODRAW;
今进场价:REF(明进场价,1),COLORGREEN,NODRAW;
短买:VAR19,COLOR33AACC,NODRAW;
离场:VAR1AO,COLORFF99FF,NODRAW;
IF(MA(CLOSE,7)>=REF(MA(CLOSE,7),1),MA(CLOSE,7),DRAWNULL),COLORRED;
IF(MA(CLOSE,21)>=REF(MA(CLOSE,21),1),MA(CLOSE,21),DRAWNULL),COLORRED;
STICKLINE(ISLASTBAR AND (红色持股 OR REF(红色持股,1)=1),今离场价,今离场价,30,1),COLOR0000FF;
STICKLINE(ISLASTBAR AND (青色观望 OR REF(青色观望,1)=1),今进场价,今进场价,30,1),COLOR00FF00;
A7:=C-REF(C,1);
A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);
SHORT:=7; LONG:=19;
RMA:=EMA(CLOSE,SHORT);
NMA:=EMA(CLOSE,LONG);
上升:DRAWLINE(L=LLV(L,BARSLAST(CROSS(NMA,RMA))+1)
,LLV(L,BARSLAST(CROSS(NMA,RMA))+1),
H=HHV(H,BARSLAST(CROSS(RMA,NMA))+1),HHV(H,BARSLAST(CROSS(RMA,NMA))+1),0),COLORLIRED;
下降:DRAWLINE(H=HHV(H,BARSLAST(CROSS(RMA,NMA))+1),
HHV(H,BARSLAST(CROSS(RMA,NMA))+1),L=LLV(L,BARSLAST(CROSS(NMA,RMA))+1)
,LLV(L,BARSLAST(CROSS(NMA,RMA))+1),0),COLOR555555;
买进:=(LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND
CROSS(A8,MA(A8,2))) AND REF(下降,1)<REF(下降,2) AND 上升>REF(下降,1);
趋势区:=IF((EVERY(下降>=REF(下降,1),1)),4,2);
低买:=IF(((CROSS(趋势区,2.1))),1,0);
高卖:=IF(((CROSS(3.9,趋势区))),1,0);
DRAWICON(低买,上升-0.2,1);
DRAWICON(高卖,下降+0.2,2);
A1:=REF(H,8)=HHV(H,2*8+1);
B1:=FILTER(A1,8);
C1:=BACKSET(B1,8+1);
D1:=FILTER(C1,8);{高点}
R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1);S11:=R11>REF(R11,1);
DRAWLINE(D1,H,S11,H,1),COLORBLUE,LINETHICK1;
A2:=REF(L,8)=LLV(L,2*8+1);
B2:=FILTER(A2,8);
C2:=BACKSET(B2,8+1);
D2:=FILTER(C2,8);{低点}
T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1);U11:=T11>REF(T11,1);
DRAWLINE(D2,L,U11,L,1),COLORBLUE,LINETHICK1;
M:=INTPART(3*8/5);
A12:=REF(H,M)=HHV(H,2*M+1);
B12:=FILTER(A12,M);
C12:=BACKSET(B12,M+1);
D12:=FILTER(C12,M);{高点}
R112:=BACKSET(ISLASTBAR,BARSLAST(D12)+1);S112:=R112>REF(R112,1);
DRAWLINE(D12,H,S112,H,1),COLORFFFF00,LINETHICK1;
A22:=REF(L,M)=LLV(L,2*M+1);
B22:=FILTER(A22,M);
C22:=BACKSET(B22,M+1);
D22:=FILTER(C22,M);{低点}
T112:=BACKSET(ISLASTBAR,BARSLAST(D22)+1);U112:=T112>REF(T112,1);
DRAWLINE(D22,L,U112,L,1),COLORFFFF00,LINETHICK1;
ZT:=C/REF(C,1)>1.096;
ZTBPJ:=REF(C,BARSLAST(ZT)+1)*0.98;{涨停不破价}
ZTBP:=BARSLAST(ZT)<30 AND (LLV(C,BARSLAST(ZT))>=ZTBPJ OR
LLV(C,BARSLAST(ZT))=ZTBPJ);{涨停不破}
STICKLINE(ZTBP,REF(C,BARSLAST(ZT))-REF(C,BARSLAST(ZT))*0.001,
REF(C,BARSLAST(ZT)),0.5,-0.001),COLORYELLOW;
STICKLINE(ZTBP,REF(L,BARSLAST(ZT))-REF(L,BARSLAST(ZT))*0.001,
REF(L,BARSLAST(ZT)),0.5,-0.001),COLORYELLOW;
STICKLINE( ZT ,OPEN,CLOSE,1.5,0),COLORYELLOW;
三日不破:=MIN(MIN(L,REF(L,1)),REF(L,2))>=REF(L,3);
三日量缩:=(MAX(MAX(V,REF(V,1)),REF(V,2))<REF(V,3));
三日价涨A:=C>=REF(C,1);
三日价涨B:=C<REF(C,1);
三日价涨C:=MIN(MIN(C,REF(C,1)),REF(C,2))>=REF(L,3);
缩倍柱:=(VOL*1.95<=REF(VOL,1));
百日低量:=(VOL=LLV(VOL,100));
倍量柱:=C>REF(C,1)*1.04 AND (VOL>=1.9*REF(VOL,1));
四日前倍量柱:=(REF(VOL,3)>1.9*REF(VOL,4));
四日前高量柱:=(REF(VOL,3)>=REF(VOL,4) AND REF(VOL,3)<1.9*REF(VOL,4) AND 三日量缩);
前三引用不成立:=COUNT(REF(四日前倍量柱,1) AND (REF(三日不破,1) OR REF(三日价涨C,1)),3)=0 AND COUNT(REF(四日前高量柱,1) AND (REF(三日不破,1) OR REF(三日价涨C,1)),3)=0;
倍量黄金柱:=四日前倍量柱 AND 三日量缩 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
高量黄金柱:=四日前高量柱 AND 三日量缩 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
黄金柱:=倍量黄金柱 OR 高量黄金柱;
次倍量黄金柱:=NOT(黄金柱) AND 四日前倍量柱 AND 三日量缩 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次高量黄金柱:=NOT(黄金柱) AND 四日前高量柱 AND 三日量缩 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次黄金柱:=次倍量黄金柱 OR 次高量黄金柱;
准倍量黄金柱:=NOT(黄金柱 OR 次黄金柱) AND 四日前倍量柱 AND ((三日量缩 AND 三日价涨C) OR (COUNT(倍量柱,3)>=1 AND 三日不破)) AND 前三引用不成立;
准高量黄金柱:=NOT(黄金柱 OR 次黄金柱) AND 四日前高量柱 AND (三日量缩 AND 三日价涨C) AND 前三引用不成立;
准黄金柱:=准倍量黄金柱 OR 准高量黄金柱;
倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱) AND 四日前倍量柱 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱) AND 四日前高量柱 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
将军柱:=倍量将军柱 OR 高量将军柱;
BACKSET104:=BACKSET(将军柱,4);
FILTER104:=FILTER(BACKSET104,3);
STICKLINE(FILTER104,OPEN,CLOSE,1.5,0),COLORYELLOW;
立桩量:=VOL=HHV(VOL,40) AND VOL>1.9*REF(VOL,1);
立桩量三日突破:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(HIGH,3),1,0)));
立桩量三日不破:=BARSLAST(立桩量)=3 AND REF(LOW,3)<=MIN(MIN(C,REF(C,1)),REF(C,2));
BACKSET300:=BACKSET(立桩量三日不破,4);
BACKSET301:=BACKSET(立桩量三日突破,4);
{www.gUPang.com 股旁网_最新股票指标公式}
立桩量成立:=FILTER(BACKSET300,3) AND BACKSET301 AND 立桩量;
STICKLINE(立桩量成立,OPEN,CLOSE,1.5,0),COLORYELLOW;
量:=V,VOL;
倍量:=(V/REF(V,1)>=1.91 AND COUNT(C>O,1)) OR (L>REF(H,1) AND COUNT(O>C,1)
AND V/REF(V,1)>=1.91),NODRAW,COLORYELLOW;
STICKLINE(倍量,OPEN,CLOSE,0.8,0),COLORYELLOW;
JJ:=(3*C+H+L+O)/6;
VAR1A:=(8*JJ+7*REF(JJ,1)+6*REF(JJ,2)+5*REF(JJ,3)
+4*REF(JJ,4)+3*REF(JJ,5)+2*REF(JJ,6)+REF(JJ,8))/36;
TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND
CLOSE>VAR1A AND C>REF(C,1);
LJL:=FILTER(TJ1,5) AND 倍量;
TJ2:=IF(BARSLAST(LJL)=1 AND CLOSE>REF(HIGH,1),1,
IF(BARSLAST(LJL)=2 AND CLOSE>REF(HIGH,2),1,
IF(BARSLAST(LJL)=3 AND CLOSE>REF(HIGH,3),1,0)));
TP:=TJ2=1;
TJ3:=IF(BARSLAST(LJL)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(LJL)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(LJL)=3 AND CLOSE>REF(LOW,3),1,0)));
STFZ:=TJ3=1;
CL:=STFZ AND TP;
TJCL:=FILTER(CL,3);
STICKLINE(LJL,OPEN,CLOSE,1.5,0),COLORYELLOW;
M20:=MA(C,20);
M40:=MA(C,40);
M60:=MA(C,60),COLORRED;
AA:=BARSLAST(M60>M40 AND (M40=M20 OR M40>M20));
BB:=REF(COUNT(C<M60,AA)=AA,1);
CC:=CROSS(C,M60) AND VOL>MA(VOL,5) AND (C-REF(C,1))/REF(C,1)*100>3;
芙蓉出水:=BB AND CC;
STICKLINE(芙蓉出水,O,C,0.001,0),COLOR00FF00;
SR1:=REF(HIGH,10)=HHV(HIGH,2*10+1);
SR2:=FILTER(SR1,10);
SR3:=BACKSET(SR2,10+1);
HD:=FILTER(SR3,10);
前高:=REF(H,BARSLAST(HD));
突破前高:=CROSS(C,前高);
选股:=倍量 AND 突破前高;
STICKLINE(选股,OPEN,CLOSE,0.001,0),COLORMAGENTA;
AS1:=EMA(C,12)-EMA(C,25);
AS2:=EMA(AS1,6);
主力:=(AS2>=0)*AS2,COLORWHITE,LINETHICK0;
VAR8D:=VOL>2*MA(VOL,30);
VAR9D:="DMI.ADX"(12,6);
VARA:="DMI.ADXR"(12,6);
VARB:=CLOSE>MA(CLOSE,30) AND CLOSE<MA(CLOSE,30)*1.04;
VARC:=MA(CLOSE,30)>REF(MA(CLOSE,30),1);
VARD:=BARSLAST(CROSS(MA(CLOSE,5),MA(CLOSE,10)))<BARSLAST(CROSS(MA(CLOSE,10),MA(CLOSE,5)));
VARF:=TROUGHBARS(3,15,1)<4;
VAR10C:=EMA(CLOSE,30)>REF(EMA(CLOSE,30),2);
VAR11C:=IF(VARF=1,50,0);
机构:=EMA((CLOSE-MA((2*CLOSE+HIGH+LOW)/4,30))/MA((2*CLOSE+HIGH+LOW)/4,30)*100,3);
XGA:=IF(FILTER(VARF=1,5) AND 机构<-10,1,0);
XGB:=IF(FILTER(VARF=1,3),1,0);
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),NODRAW;
绝情谷:=CCI<-150 ,NODRAW;
绝底1:= XGB AND 绝情谷,NODRAW;
绝底2:= XGB AND XGA,NODRAW;
DRAWTEXT(绝底1,L*0.995,'●'),COLORBLUE;
STICKLINE(绝底1,OPEN,CLOSE,1.5,0),COLORBLUE;
DRAWTEXT(绝底2,L*0.995,'●'),COLORBLUE;
STICKLINE(绝底2,OPEN,CLOSE,1.5,0),COLORBLUE;
STICKLINE(ISLASTBAR AND (红色持股 OR REF(红色持股,1)=1),今离场价,今离场价,30,1),COLOR0000FF;
STICKLINE(ISLASTBAR AND (青色观望 OR REF(青色观望,1)=1),今进场价,今进场价,30,1),COLOR00FF00;
CO:=(C-O);
STICKLINE(短买,O,O+CO/3,2.8,0),COLOR335555;
STICKLINE(短买,O,O+CO/3,2,0),COLOR338888;
STICKLINE(短买,O,O+CO/3,1.5,0),COLOR33AAAA;
STICKLINE(短买,O,O+CO/3,1,0),COLOR33CCCC;
STICKLINE(短买,O,O+CO/3,0,0),COLOR33EEEE;
STICKLINE(离场,O,O+CO/3,2.8,0),COLOR550055;
STICKLINE(离场,O,O+CO/3,2,0),COLOR880088;
STICKLINE(离场,O,O+CO/3,1.5,0),COLORAA00AA;
STICKLINE(离场,O,O+CO/3,1,0),COLORCC00CC;
STICKLINE(离场,O,O+CO/3,0.5,0),COLOREE00EE;

通达信心爱画线主图指标公式

 

相关文章