在线检测未来函数

通达信多彩MACD指标公式

来源:Internet,编辑:股旁网,2011-10-08

DIF:EMA(CLOSE,12)-EMA(CLOSE,26),NODRAW;
DEA:EMA(DIF,9),NODRAW;
MACD:(DIF-DEA)*2,COLORSTICK,COLORRED;
{以下是COPY的,来源于理想论坛}
ES:=REF(EMA(C,26),1);EP:=REF(EMA(C,12),1);
DI:=REF(DIF,1);
DIF穿零价:((12+1)*(26-1)*ES-(26+1)*(12-1)*EP)/(2*(26+1)-2*(12+1)),NODRAW,COLORWHITE;
DIF拐点价:((12-1)*EP/(12+1)-(26-1)*ES/(26+1)-DI)*(26+1)*(12+1)/(2*(12+1)-2*(26+1)),COLORYELLOW,NODRAW;
{以下是自己的}
TJ1:=DEA<0 AND CROSS(DIF,DEA);{零下金叉}
TJ2:=BARSLAST(CROSS(0,DIF));{下跌起点到现在的周期数}
TJ3:=DEA<0 AND COUNT(TJ1,TJ2+1)>1;{从下跌起点算起,零下金叉两次以上}
TJ4:=DEA<0 AND MACD>0 AND REF(MACD,1)>0 AND REF(MACD,1)<REF(MACD,2) AND MACD>REF(MACD,1);{零下且MACD为正时,DIF,DEA收敛后发散}
TJ5:=BARSLAST(TJ1);{上一次零下金叉到现在的周期数}
TJ6:=DEA<0 AND TJ3 AND COUNT(TJ4,TJ5+1)>0,NODRAW;{零下两次金叉后发生至少一次收敛后发散}
TJ7:=DEA<0 AND COUNT(TJ6,TJ2)>0,NODRAW;{满足条件6的周期}
TJ8:=DEA<0 AND COUNT(TJ1,TJ2+1)>2;{从下跌起点算起,零下金叉三次以上}
TJ9:=DEA<0 AND COUNT(TJ8,TJ2)>0,NODRAW;{满足条件8的周期}
TJ10:=TJ7 AND DIF>0 AND DIF>REF(DIF,1) AND DEA<0;{条件6信号加强}
TJ11:=TJ9 AND DIF>0 AND DIF>REF(DIF,1) AND DEA<0;{条件8信号加强}
TJ12:=DIF>0 AND DEA>0 AND REF(MACD,1) AND REF(MACD,2)<0 AND MACD>REF(MACD,1) AND REF(MACD,1)<REF(MACD,2);{零上且DIF,DEA反向收敛}
STJ1:=DIF>0 AND MACD>0 AND REF(MACD,1)>0 AND REF(MACD,1)>REF(MACD,2) AND MACD<REF(MACD,1);{零上MACD为正时,DIF,DEA发生收敛}
STJ2:=BARSLAST(CROSS(DIF,0)),NODRAW;{上涨起点到现在的周期数}
STJ3:=BARSLAST(CROSS(DIF,DEA));{上一次金叉以来到现在的周期数}
STJ4:=DIF>0 AND COUNT(STJ1,STJ2)>1 AND COUNT(STJ1,STJ3)>1 AND STJ1;
{从上涨起点算起,发生零上收敛两次以上}
STJ5:=DIF>0 AND COUNT(STJ1,STJ2)>2 AND COUNT(STJ1,STJ3)>2 AND STJ1;
{从上涨起点算起,发生零上收敛三次以上}
STJ6:=DIF>0 AND COUNT(STJ1,STJ2)>3 AND COUNT(STJ1,STJ3)>3 AND STJ1;
{从上涨起点算起,发生零上收敛四次以上}
STJ7:=DIF>0 AND COUNT(STJ1,STJ2)<2 AND CROSS(DEA,DIF);
{从上涨起点算起,零上收敛一次即出现死叉}
STJ8:=COUNT(CROSS(DIF,DEA),STJ2)>0 AND STJ1;{零上金叉后出现零上收敛}
STJ9:=DIF>0 AND REF(CROSS(DIF,DEA),1) AND CROSS(DEA,DIF);{零上金叉后随即死叉}
STJ10:=COUNT(DIF>0 AND (STJ4 OR STJ7 OR STJ8 OR STJ9),STJ2);
STJ11:=DIF>0 AND MACD<0 AND REF(MACD,2)<0 AND MACD<REF(MACD,1) AND REF(MACD,1)>REF(MACD,2);{零上二次向下发散}
减仓提示:STJ10,NODRAW,COLORGREEN;
清仓提示:STJ10>4,NODRAW,COLORMAGENTA;
STICKLINE(DEA<0 AND MACD<0,0,MACD,2,0),COLORBLUE;
STICKLINE(DEA<0 AND MACD>=0,0,MACD,1,-1),COLORBLUE;
STICKLINE(DEA<0 AND MACD>=0 AND MACD<REF(MACD,1),0,MACD,1,1),COLORBLUE;
STICKLINE(DEA>=0 AND MACD>0,0,MACD,0,1),COLORLIRED;
STICKLINE(DEA>=0 AND MACD>0 AND MACD<REF(MACD,1),0,MACD,0,-1),COLORLIRED;
STICKLINE(DEA>=0 AND MACD<0 AND MACD>REF(MACD,1),0,MACD,0,-1),COLORLIRED;
STICKLINE(TJ7 AND MACD>0,0,MACD,2,1),COLORYELLOW;
STICKLINE(TJ7 AND MACD>0 AND MACD<REF(MACD,1),0,MACD,2,-1),COLORYELLOW;
STICKLINE(TJ7 AND MACD<0,0,MACD,2,0),COLORGREEN;
STICKLINE(TJ7 AND MACD<0 AND MACD>REF(MACD,1),0,MACD,2,1),COLORGREEN;
STICKLINE(TJ9 AND MACD>0,0,MACD,2,0),COLORYELLOW;
STICKLINE(TJ9 AND MACD>0 AND MACD<REF(MACD,1),0,MACD,2,1),COLORYELLOW;
STICKLINE(TJ9 AND MACD<0,0,MACD,2,1),COLORGREEN;
STICKLINE(TJ9 AND MACD<0 AND MACD>REF(MACD,1),0,MACD,2,-1),COLORGREEN;
STICKLINE(TJ10,0,MACD,2,1),COLORRED;
STICKLINE(TJ10 AND MACD<REF(MACD,1),0,MACD,2,-1),COLORRED;
STICKLINE(TJ11,0,MACD,2,0),COLORRED;
STICKLINE(TJ11 AND MACD<REF(MACD,1),0,MACD,2,1),COLORRED;
STICKLINE(TJ12,0,DIF,0,-1),COLORRED;
STICKLINE(STJ4,0,MACD,2,-1),COLORGREEN;
DRAWICON(STJ4,DIF*1.03,2);
STICKLINE(STJ5,0,MACD,2,1),COLORGREEN;
DRAWICON(STJ5,DIF*1.03,2);
STICKLINE(STJ6,0,MACD,2,0),COLORGREEN;
DRAWICON(STJ6,DIF*1.03,2);
STICKLINE(STJ7,0,MACD,2,0),COLORGREEN;
DRAWICON(STJ7,DEA*1.03,2);
STICKLINE(STJ8,0,MACD,2,0),COLORBLUE;
DRAWICON(STJ8,DIF*1.03,2);
STICKLINE(STJ9,0,MACD,2,0),COLORBLUE;
DRAWICON(STJ9,DEA*1.03,2);
DRAWTEXT(STJ10>4 AND (STJ4 OR STJ7 OR STJ8 OR STJ9),DIF*1.1,'逃'),COLORMAGENTA;
STICKLINE(STJ11,0,DIF,0,-1),COLORBLUE;
{www.gUPaNg.com 股旁网_最新股票指标公式}
J1:="MACD.DIF"(12,26,9);J2:="MACD.DEA"(12,26,9);
J3:="KDJ.K"(15,6,3);J4:="KDJ.D"(15,6,3);
J5:="RSI.RSI1"(6,12,24);J6:="RSI.RSI2"(6,12,24);
A1:=BARSLAST(REF(CROSS(J1,J2),1));
B1:=REF(C,A1+1)>C AND REF(J1,A1+1)<J1 AND CROSS(J1,J2);
A2:=BARSLAST(REF(CROSS(J3,J4),1));
B2:=REF(C,A2+1)>C AND REF(J3,A2+1)<J3 AND CROSS(J3,J4);
A3:=BARSLAST(REF(CROSS(J5,J6),1));
B3:=REF(C,A3+1)>C AND REF(J5,A3+1)<J5 AND CROSS(J5,J6);
C1:=BARSLAST(REF(CROSS(J2,J1),1));
D1:=REF(C,C1+1)<C AND REF(J1,C1+1)>J1 AND CROSS(J2,J1);
C2:=BARSLAST(REF(CROSS(J4,J3),1));
D2:=REF(C,C2+1)<C AND REF(J3,C2+1)>J3 AND CROSS(J4,J3);
C3:=BARSLAST(REF(CROSS(J6,J5),1));
D3:=REF(C,C3+1)<C AND REF(J5,C3+1)>J5 AND CROSS(J6,J5);
MACD底背离:=FILTER(B1>0,5);
DRAWTEXT(MACD底背离,REF(J1,A1+1),'M底'),COLORYELLOW;
KDJ底背离:=FILTER(B2>0,5);
DRAWTEXT(KDJ底背离,REF(J1,A1+2),'K底'),COLORWHITE;
RSI底背离:=FILTER(B3>0,5);
DRAWTEXT(RSI底背离,REF(J1,A1+3),'R底'),COLORFFCC66;
MACD顶背离:=FILTER(D1>0,5);
DRAWTEXT(MACD顶背离,REF(J1,D1+1),'M顶'),COLOR0066FF;
KDJ顶背离:=FILTER(D2>0,5);
DRAWTEXT(KDJ顶背离,REF(J1,D1+2),'K顶'),COLOR0000FF;
RSI顶背离:=FILTER(D3>0,5);
DRAWTEXT(RSI顶背离,REF(J1,D1+3),'R顶'),COLORFF00FF;
DIF,COLORDDDD00;DEA,COLORYELLOW;IF(DIF>=REF(DIF,1),DIF,DRAWNULL),COLORFF00FF;

通达信多彩MACD指标公式

 

相关文章