在线检测未来函数

飞狐黄金MACD指标公式

来源:Internet,编辑:股旁网,2011-10-11

均价:=(2*C+(H-L)/2+L+o)/4;
JgX:=(13*均价+12*REF(均价,1)+11*REF(均价,2)+10*REF(均价,3)+9*REF(均价,4)+8*REF(均价,5)+7*REF(均价,6)+ 6*REF(均价,7)+5*REF(均价,8)+4*REF(均价,9)+3*REF(均价,10)+2*REF(均价,11)+1*REF(均价,12))/(13+12+11+10+9+8+7+6+5+4+3+2+1),COLORRED,LINETHICK2;
决策线:=EMA(JgX,1),COLORRED,LINETHICK2;
黄金线:=((EMA(JGX,85)+EMA(JGX,15))/2+EMA(JGX,15))/2;
dif:决策线-黄金线,COLORWHITE,LINETHICK2;
DEA:ema(DIF,7),COLOR00bb00,LINETHICK2;
MACD:2*(dif-dea),COLORSTICK,LINETHICK2;
PARTLINE(dif>=REF(dif,1),dif),COLORRED,LINETHICK2;
PARTLINE(dea>=REF(dea,1),dea),COLOR9900FF,LINETHICK2;
n:=IF(DATATYPE=5,20,IF(DATATYPE=6,12,40));
A:REF(HHV(dif,n),1),COLORMAGENTA;{N日内dif的最高值}
B:REF(LLV(dif,n),1),COLORGRAY;{N日内dif的最低值}
{www.gUPaNg.com 股旁网_最新股票指标公式}
∑MACD:SUM(MACD,72)/10,Linethick;
PARTLINE(∑MACD>REF(∑MACD,1),∑MACD),COLORYELLOW,Linethick2;
PARTLINE(∑MACD<REF(∑MACD,1),∑MACD),color18A4FF,Linethick2;
A1:=BARSLAST(REF(CROSS(DIF,DEA),1));
底背:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);
背离:IF(底背,0.23,0),LINETHICK2,COLORWHITE;
DRAWTEXT(底背,0.23,'←底背离'),COLORWHITE;
DRAWTEXT(CROSS(a,dif)AND A>0.2,a+0.08,'逃顶'),COLORWHITE;

飞狐黄金MACD指标公式

 

相关文章