在线检测未来函数

同花顺太阳操盘线主图指标公式

来源:Internet,编辑:股旁网,2011-10-14

p1:=13;p2:=34;p3:=55;p4:=89;
//input:P1(13,0,300),P2(34,0,300),P3(55,0,300),P4(89,0,300),P5(144,0,9999),N(4,0,5);
VAR1:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR2:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
STICKLINE((VAR2 < MA(VAR3,6)),CLOSE,OPEN,5,1),colorFFFF33;
STICKLINE((VAR2 < MA(VAR3,6)),LOW,(MIN(OPEN,CLOSE) * 1.001),0.6,0),colorFFFF33;
STICKLINE((VAR2 < MA(VAR3,6)),MAX(OPEN,CLOSE),HIGH,0.6,0),colorFFFF33;
STICKLINE((VAR2 > MA(VAR3,6)),OPEN,CLOSE,7,1),color4440FF;
STICKLINE((VAR2 > MA(VAR3,6)),HIGH,MAX(CLOSE,OPEN),0.6,0),color4440FF;
STICKLINE((VAR2 > MA(VAR3,6)),LOW,(MIN(CLOSE,OPEN) * 1.001),0.8,0),color4440FF;
STICKLINE(((OPEN > CLOSE) AND (VAR2 > MA(VAR3,6))),(OPEN * 0.998),(CLOSE * 1.0025),4.5,0),colorFFFF33;
//{www.gUPaNg.com 股旁网_最新股票指标公式}
STICKLINE(((OPEN < CLOSE) AND (VAR2 < MA(VAR3,6))),(CLOSE * 0.998),(OPEN * 1.0025),4.5,0),color4440FF;
STICKLINE(((OPEN > CLOSE) AND (VAR2 < MA(VAR3,6))),CLOSE,OPEN,7,0),colorFFFF33;
DRAWTEXT(CROSS(VAR2,MA(VAR3,6)),(LOW * 0.984),'B '),color4440FF;
DRAWTEXT(CROSS(MA(VAR3,6),VAR1),(HIGH * 1.035),'S '),colorFFFF34;
WX:=MA(CLOSE,0);
M1:MA(CLOSE,P1),colorffff00;
M2:(MA(CLOSE,P2)),color00ff00;
M3:(MA(CLOSE,P3)),color00ffFF;
M4:(MA(CLOSE,P4)),color4440FF;

同花顺太阳操盘线主图指标公式

 

相关文章