在线检测未来函数

飞狐成本通道主图指标公式

来源:Internet,编辑:股旁网,2011-10-15

均价:=(2*C+(H-L)/2+L+o)/4;
操盘线:MA((eMA(均价,3)*7+eMA(均价,7)*3)/10,1),COLOR9900FF;
七妹:(7*均价+6*REF(均价,1)+5*REF(均价,2)+4*REF(均价,3)+3*REF(均价,4)+2*REF(均价,5)+1*REF(均价,6))/28;
JgX:=(13*均价+12*REF(均价,1)+11*REF(均价,2)+10*REF(均价,3)+9*REF(均价,4)+8*REF(均价,5)+7*REF(均价,6)+ 6*REF(均价,7)+5*REF(均价,8)+4*REF(均价,9)+3*REF(均价,10)+2*REF(均价,11)+1*REF(均价,12))/(13+12+11+10+9+8+7+6+5+4+3+2+1),COLORRED,LINETHICK2;
决策线:EMA(JgX,1),COLORRED,LINETHICK2;
黄金线:((EMA(JGX,89)+EMA(JGX,13))/2+EMA(JGX,13))/2,COLORYELLOW,LINETHICK2;
ajb:=IF(capital>20000000,capital*33/100,IF(capital>12000000,capital*27/100,capital*22/100));
AV:=if(INDEXC=C,amount/10000000000,100*V/(capital-AJB));
kk:=if(INDEXC=C,300,100);
SK:=IF(SUM(AV,0)<kk,BARSCOUNT(C),SUMBARS(AV,kk));
SV:=SUM(V,SK);
筹:=IF(INDEXC=c OR SV=0,MA(c,SK),SUM(AMOUNT,SK)/SV/100),LINETHICK1,color18A4FF,LINEDOT;
平均成本:EMA(((COST(85)+COST(15))/2+COST(50))/2,3),COLOR9900FF,LINETHICK3;

FF:=ABS(筹-平均成本)/平均成本;
DD:=DMA(筹,FF);
上:(1+8/100)*DD,LINEDOT,COLORYELLOW;
下:(1-8/100)*DD,LINEDOT,COLORYELLOW;
中:(上+下)/2,COLORWHITE,LINEDOT;
天:(1+16/100)*DD,COLORGRAY;
地:(1-16/100)*DD,COLORGRAY;
{www.gUPaNg.com 股旁网_最新股票指标公式}
疯牛:(1+24/100)*DD,LINETHICK,COLORMAGENTA;
极地:(1-24/100)*DD,LINETHICK,COLORGRAY;
PARTLINE(C>疯牛,疯牛),COLORWHITE,LINETHICK2,CIRCLEDOT;
PARTLINE(C<极地,极地),COLORWHITE,LINETHICK2,CIRCLEDOT;
PARTLINE(操盘线>=七妹,操盘线),COLOR9900FF,LINETHICK2;
PARTLINE(操盘线<七妹,操盘线),COLOR00bb00,LINETHICK2;
合:=2*EMA(LLV(均价,7),10)-均价;
空线:=3*合-2*SMA(合,10,1)*1,COLORGREEN;
x1:=REF(C,1);
x2:=SMA(MAX(C-x1,0),6,1)/SMA(ABS(C-x1),6,1)*100;
x3:=((3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-
2*SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1)-50)*1.032+50);
x4:=(x2+x3)/2;
多线:=c+(x4/50-1)*(ma(c,30)/20)*3,COLORYELLOW;
PARTLINE(多线<空线,决策线),COLOR408000,ColorFFAA00,LINETHICK2;
PARTLINE(多线>空线 AND 多线<决策线,决策线),color18A4FF,LINETHICK2;
PARTLINE(C>=REF(平均成本,1),平均成本)COLORYELLOW;
PARTLINE(C<REF(平均成本,1),平均成本),COLORCYAN;

飞狐成本通道主图指标公式

 

相关文章