在线检测未来函数

大智慧庄拉升主图指标公式

来源:Internet,编辑:股旁网,2011-10-17

P1:=5;P2:=5;P3:=5;P4:=5;P5:=5;
MA5:MA(CLOSE,P1),COLORWHITE,linethick1;
MA10:MA(CLOSE,P2),linethick0;
MA25:MA(CLOSE,P3),linethick1;
MA45:MA(CLOSE,P4),linethick2;
MA55:MA(CLOSE,P5),linethick0;
高1:=REF(HHV(H,120),3);
低1:=REF(LLV(L,120),3);H1:=高1-(高1-低1)*0.191;
H2:=高1-(高1-低1)*0.382;
H3:=高1-(高1-低1)*0.5;
H4:=高1-(高1-低1)*0.618;
H5:=高1-(高1-低1)*0.809;
突破:=REF(EMA(C,14),1);
A1X:=(EMA(C,10)-突破)/突破*100;
基准:=IF(A1X>=0,REF(EMA(C,10),BARSLAST(CROSS(A1X,0))+1),REF(EMA(C,10),BARSLAST(CROSS(0,A1X))+1));
{
stickline(A1X>=0,突破,突破,10,0),coloryellow;
stickline(A1X<0,突破,ref(突破,1),0,-1000);
}
STICKLINE(A1X>=0,基准,突破,10,0),COLOR330099;
STICKLINE(A1X<0,基准,突破,10,0),COLOR009966;
Var326:=IF(CLOSE>REF(CLOSE,1),88,0);
Var327:=IF(CLOSE/REF(CLOSE,1)>1.050 AND HIGH/CLOSE<1.010 AND Var326>0, 91, 0);
STICKLINE(Var327>90,L*0.99,L*0.95,4,0),COLORYELLOW;
TY:=C;
AA1:=REF(TY,5)=HHV(TY,2*5+1); B1:=FILTER(AA1,5); C1:=BACKSET(B1,5+1);
HD:=FILTER(C1,5);
AA2:=REF(TY,9)=LLV(TY,2*9+1); B2:=FILTER(AA2,9); C2:=BACKSET(B2,9+1); LD:=FILTER(C2,9);
AA3:=REF(TY,10)=HHV(TY,2*10+1); B3:=FILTER(AA3,10); C3:=BACKSET(B3,10+1); HD1:=FILTER(C3,10);
AA4:=REF(TY,60)=HHV(TY,2*60+1); B4:=FILTER(AA4,60); C4:=BACKSET(B4,60+1); HD2:=FILTER(C4,60);
长压:REF(C,BARSLAST(HD1)),COLORYELLOW{红色},POINTDOT;
STICKLINE(C,长压,长压,6,2),COLORYELLOW,linethick2;
超长压:REF(C,BARSLAST(HD2)),COLORYELLOW{红色},POINTDOT;
STICKLINE(C,超长压,超长压,6,2),COLORWHITE,linethick1;
天1:COST(99),POINTDOT,COLORWHITE,LINETHICK0;
现价:C*1.03,LINETHICK0;
A2: MA10;
PARTLINE(A2,A2>REF(A2,1),RGB(255,0,0),A2<REF(A2,1),RGB(250,250,0)),linethick3;
W:=BARSLAST(DISPSTATUS=1);
{www.gUPaNg.com 股旁网_最新股票指标公式}
天:BARSLAST(L=LLV(LOW,W)),COLOR00FFFF,LINETHICK0,PRECIS0;
DRAWTEXTREL(10,150,'■目前可见K线:'+NUMTOSTRN(W+1,0)+'天'),colorwhite;
低涨:(C/LLV(LOW,W)-1)*100,COLOR0000FF,LINETHICK0,PRECIS2;DRAWTEXTREL(10,100,'■低点至今上涨:'+NUMTOSTRN(低涨,2)+'% '+NUMTOSTRN(天,0)+'天'),COLOR0000FF;
DRAWTEXTREL(10,200,'■建议查阅K线:短线30天,中长线120天!'),COLORFF8899;
BEGIN DRAWTEXTREL(10,50,'所属板块:'+BKNAME),LINETHICK1,color00FFFF;end;
ZT:=C/REF(C,1)>1.097;
XH:=FILTER(ZT,13);
BH:=BARSLAST(ZT);
CZ:=REF(H,BH)-REF(L,BH);
STICKLINE(ZT,REF(O,BH),REF(C,BH),7,0),COLOR0066FF;
N:=REF("MACD.DIFF#WEEK",1)<0 AND "MACD.DIFF#WEEK">=0;{信号点}
AC:=BARSLAST(N);
HSL:100*VOL/CAPITAL,LINETHICK0;
HS100:=CROSS(SUM(HSL,AC)>=100,0.1) AND AC>0;
HS200:=CROSS(SUM(HSL,AC)>=200,0.1) AND AC>0;
HS300:=CROSS(SUM(HSL,AC)>=300,0.1) AND AC>0;
HS400:=CROSS(SUM(HSL,AC)>=400,0.1) AND AC>0;
HS500:=CROSS(SUM(HSL,AC)>=500,0.1) AND AC>0;
HS600:=CROSS(SUM(HSL,AC)>=600,0.1) AND AC>0;
HS700:=CROSS(SUM(HSL,AC)>=700,0.1) AND AC>0;
HS800:=CROSS(SUM(HSL,AC)>=800,0.1) AND AC>0;
HS900:=CROSS(SUM(HSL,AC)>=900,0.1) AND AC>0;
HS1000:=CROSS(SUM(HSL,AC)>=1000,0.1) AND AC>0;
DRAWTEXT(N,H*1.06,'起点'),COLORRED,ALIGN1;
TZHSL:=SUM(HSL,AC);
DRAWTEXTREL(10,300,'■起点至今换手率:'+NUMTOSTRN(TZHSL,2)+'% '),COLORFFCC99;
DRAWTEXT(HS100,H*1.06,'100%'),ALIGN1,COLORCYAN;
DRAWTEXT(HS200,H*1.06,'200%'),ALIGN1,COLORGREEN;
DRAWTEXT(HS300,H*1.06,'300%'),ALIGN1,COLORYELLOW;
DRAWTEXT(HS400,H*1.06,'400%'),ALIGN1,COLORFF00FF;
DRAWTEXT(HS500,H*1.06,'500%'),ALIGN1,COLORRED;
DRAWTEXT(HS600,H*1.06,'600%'),ALIGN1,COLORYELLOW;
DRAWTEXT(HS700,H*1.06,'700%'),ALIGN1,COLORFF00FF;
DRAWTEXT(HS800,H*1.06,'800%'),ALIGN1,COLORGREEN;
DRAWTEXT(HS900,H*1.06,'900%'),ALIGN1,COLORCYAN;
DRAWTEXT(HS1000,H*1.06,'1000%'),ALIGN1,COLORFFFFFF;

大智慧庄拉升主图指标公式

 

相关文章