在线检测未来函数

飞狐江恩股票行情主图指标公式

来源:Internet,编辑:股旁网,2011-10-18

input:F2(0,0,999,1),F3(0,0,999,1),F4(0,0,999,1),F5(5,0,999,1),F6(10,0,999,1),F7(20,0,999,1),F8(30,0,999,1),F9(0,0,999,1),近高(0,0,999,1),G(7,0,25),G1(5,0,10),n(0,0,10),mB(960,1,2500),调1(25,1,255);
//DRAWGBK(1, COLORRGB(180,180,180),COLORRGB(250,250,250),1);
DRAWTEXTEX(SYSPARAM(3)=BARPOS,0,10,2,'【代码:'+STKLABEL+' 名称:'+STKNAME+'】'),ColorFFFFFF,linethick1;
量:=IF(CLOSE>200,VOL/1000000,VOL/1),linethick0;
换手率:=VOL/CAPITAL*100,linethick0,PRECISion2,colorffff00;
五日换手:=SUM(换手率,5),PRECISION2,LINETHICK0 ,colorffaadd;
MAI:=CLOSE*1.017,LINETHICK0;{取得最新动态行情: 最新,DYNAINFO(7)}
MAII:=CLOSE*1.03,LINETHICK0;{取得最新动态行情: 最新,}
FMAI:=REF(MAI,1),LINETHICK0;
FMAII:=REF(MAII,1),LINETHICK0;
//当满足条件时随光标显视【交易日、自然日】
aj:=DATEDIFF(DATE,CURRENTDATE);
b:=DATACOUNT-BARPOS+0;
振幅:=((HIGH-LOW)/LOW)*100,linethick0,color00FFff;
差价:=HIGH-LOW,linethick0,color00FFff;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,7,0),COLOR0000AA;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,6,0),COLOR0000CC ;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,4,0),COLOR0000DD ;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,2,0),COLOR0000FF;
STICKLINE(CLOSE>=OPEN,HIGH,LOW,0,0),COLORRED;
STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,7,0),Colorcccc00;
STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,6,0),Colordddd00;
STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,4,0),Coloreeee00;
STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,2,0),COLORffff00;
STICKLINE(CLOSE<=OPEN,HIGH,LOW,0,0),ColorFFFF00;
VAR3:=(HIGH < REF(LOW,1));
VAR4:=(LOW > REF(HIGH,1));
DRAWTEXT(VAR3,(HIGH ),'缺口'),ALIGN0,ColorFFFF00;
DRAWTEXT(VAR4,(LOW ),'缺口'),ALIGN0,Color00FFBF;
a:=(3*CLOSE+LOW+OPEN+HIGH)/6;
X:=(20*a+19*REF(a,1)+18*REF(a,2)+17*REF(a,3)+16*REF(a,4)+15*REF(a,5)+
14*REF(a,6)+13*REF(a,7)+12*REF(a,8)+11*REF(a,9)+10*REF(a,10)+9*REF(a,11)+8*REF(a,12)
+7*REF(a,13)+6*REF(a,14)+5*REF(a,15)+4*REF(a,16)+3*REF(a,17)+2*REF(a,18)+
REF(a,20))/210;
回调认同:EMA(X,G),color208fff;
DRAWTEXT(BARSTATUS=2 AND 回调认同<>REF(回调认同,1),回调认同,'回调认同:'+NUMTOSTR(回调认同,2)),color00aaff;
箱顶:HHV(MA((HIGH),G1),30),color00ffaa,linethick1;
DRAWTEXT(BARSTATUS=2 AND 箱顶<>REF(箱顶,1),箱顶,'箱顶:'+NUMTOSTR(箱顶,2)),color00ff00,ALIGN2,pxup25;
DRAWTEXT(BARSTATUS=2 AND 箱顶=REF(箱顶,1),箱顶,'箱顶:'+NUMTOSTR(箱顶,2)),color00ff00,ALIGN2,pxup25;
//角度线
z:ZIG(3,n),COLORffffff;
f:=z-REF(z,1);
zh:=PEAK(3,n,1);
wh:=PEAKBARS(3,n,1);
zL:=TROUGH(3,n,1);
wL:=TROUGHBARS(3,n,1);
x:=ATAN((z/zh-1)/wh*100)*57.3,linethick0;
上行度数:ATAN((z/zL-1)/wL*100)*57.3,linethick0;
{www.gUPaNg.com 股旁网_最新股票指标公式}
DRAWNUMBER(wh=0 or (ISLASTBAR and wL<wh),z*1.01,REF(上行度数,1),1)ALIGN2,Color0aeeff;
DRAWTEXT(wh=0 or (ISLASTBAR and wL<wh),z*1.01,'上行: ')ALIGN2,ColorColor0aeeff;
DRAWTEXT(wh=0 or (ISLASTBAR and wL<wh),z*1.01,' 度'),Color0aeeff;
DRAWNUMBER(wL=0 or (ISLASTBAR and wL>wh),z*0.99,REF(x,1),1)ALIGN2,Coloreeff00;
DRAWTEXT(wL=0 or (ISLASTBAR and wL>wh),z*0.99,'下行: ')ALIGN2,Coloreeff00;
DRAWTEXT(wL=0 or (ISLASTBAR and wL>wh),z*0.99,' 度'),Coloreeff00;
//周期垂直线
fbars:=SYSPARAM(0);
ff5:=BARSSINCE(CLOSE)=fbars+4;
VERTLINE(ff5),POINTDOT,color996666,linethick1;
DRAWNUMBER(ff5,SYSPARAM(5),5,0),colorffffff,pxup50;
ff8:=BARSSINCE(CLOSE)=fbars+7;
VERTLINE(ff8),POINTDOT,color996666,linethick1;
DRAWNUMBER(ff8,SYSPARAM(5),8,0),colorffffff,pxup50;
ff13:=BARSSINCE(CLOSE)=fbars+12;
VERTLINE(ff13),POINTDOT,color996666,linethick1;
DRAWNUMBER(ff13,SYSPARAM(5),13,0),colorffffff,pxup50;
ff21:=BARSSINCE(CLOSE)=fbars+20;
VERTLINE(ff21),POINTDOT,color996666,linethick1;
DRAWNUMBER(ff21,SYSPARAM(5),21,0),colorffffff,pxup50;
ff34:=BARSSINCE(CLOSE)=fbars+32;
VERTLINE(ff34),POINTDOT,color996666,linethick1;
DRAWNUMBER(ff34,SYSPARAM(5),33,0),colorffffff,pxup50;
ff55:=BARSSINCE(CLOSE)=fbars+54;
VERTLINE(ff55),POINTDOT,color996666,linethick1;
DRAWNUMBER(ff55,SYSPARAM(5),55,0),colorffffff,pxup50;
ff89:=BARSSINCE(CLOSE)=fbars+88;
VERTLINE(ff89),POINTDOT,color996666,linethick1;
DRAWNUMBER(ff89,SYSPARAM(5),89,0),colorffffff,pxup50;
ff144:=BARSSINCE(CLOSE)=fbars+143;
VERTLINE(ff144),POINTDOT,color996666,linethick1;
DRAWNUMBER(ff144,SYSPARAM(5),144,0),colorffffff,pxup50;
ff233:=BARSSINCE(CLOSE)=fbars+232;
VERTLINE(ff233),POINTDOT,color996666,linethick1;
DRAWNUMBER(ff233,SYSPARAM(5),233,0),colorffffff,pxup50;
ff377:=BARSSINCE(CLOSE)=fbars+376;
VERTLINE(ff377),POINTDOT,color996666,linethick1;
DRAWNUMBER(ff377,SYSPARAM(5),377,0),colorffffff,pxup50;
ff610:=BARSSINCE(CLOSE)=fbars+610;{
vertline(ff610),pointdot,color996666,linethick1;
DRAWNUMBER(ff610,SYSPARAM(5),610,0);
ff987:=barssince(c)=fbars-987;
vertline(ff987),pointdot,color996666,linethick1;
DRAWNUMBER(ff987,SYSPARAM(5),987,0);
ff1597:=barssince(c)=fbars-1597;
vertline(ff1597),pointdot,color996666,linethick1;
DRAWNUMBER(ff1597,SYSPARAM(5),1597,0);}
//当满足条件时随光标显视文字或数字
ZGG:=REF(HIGH,近高);
HHHH:=HHV(zgg,1);
LLL:=LOW;
HHH:=CLOSE;
GF1 := HHH*0.95; GF2 := HHH*0.93;
GFA := HHH*0.91; GFB := HHH*0.90;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,0,10,80,'【上升回调,通常情况下,市场调整不会超过 二级区间】'),LINETHICK2,ColorFFFFFF;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,0,10,92,' 一级区间 :('+NUMTOSTR(GF1[SYSPARAM(1)],2)+') '+'-----('+NUMTOSTR(GF2[SYSPARAM (1)],2)+') '),LINETHICK2,Color00FFDD;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,0,10,106,' 二级区间 :('+NUMTOSTR(GFA[SYSPARAM(1)],2)+') '+'-----('+NUMTOSTR(GFB[SYSPARAM (1)],2)+') '),LINETHICK2,Color00FFFF;
LL2 := LLL;
GFB1 := LL2*1.05; GFB2 := LL2*1.07; GFB3 := LL2*1.10; GFB4 := LL2*1.12; GFBD := LL2*1.18; GFBD1 := LL2*1.21;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,0,10,20,'【起动点上升 压力区间】'),colorFFFFFF;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,0,10,32,' 一级区间:('+NUMTOSTR(GFB1[SYSPARAM(1)],2)+') '+'-----('+NUMTOSTR(GFB2[SYSPARAM
(1)],2)+') '),LINETHICK2,ColorFFFF00;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,0,10,44,' 二级区间:('+NUMTOSTR(GFB3[SYSPARAM(1)],2)+') '+'-----('+NUMTOSTR(GFB4[SYSPARAM
(1)],2)+') '),LINETHICK2,ColorFFEE00;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,0,6,56,' ☆小心市场可能出现短期市势逆转↓'+'\n'
+' 18%--21% :('+NUMTOSTR(GFBD[SYSPARAM(1)],2)+') '+'-----('+NUMTOSTR(GFBD1[SYSPARAM(1)],2)+') '),color00FF00;
xz:=DYNAINFO(7);{取得最新动态行情: 最新}
xx:=DYNAINFO(5);{取得最新动态行情: 最高}
yy:=DYNAINFO(6);{取得最新动态行情: 最低}
sz:=xz-lll;
zz:=sz/lll*100;
gsz:=xx-lll;
gzz:=gsz/lll*100;
//ggB:=hhhH-yy;
//vv:=ggB/hhhH*100;
ggA:=XZ-HHHH;
vvA:=ggA/hhhH*100;
ggB:=yy-hhhH;
vvB:=ggB/hhhH*100;
k:=hhhH-lll;
w:=k/llL*100;
DRAWTEXT(ISLASTBAR=1,HHHH,'近高/当前最低幅度/当前幅度:('+NUMTOSTR(HHHh,2)+')('+NUMTOSTR(VVB,2)+'%)('+NUMTOSTR(VVA,2)+'%)'+''+' ̄ ̄ ̄ ̄ ̄ ̄'),ALIGN2,Color8080FF,pxDN2;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,0,10,118,'★起动点/当前高幅度'+'/当前幅度★:('+NUMTOSTR(LLL[SYSPARAM(1)],2)+' 元 )('+NUMTOSTR
(GZZ[SYSPARAM(1)],2)+'%) '+'('+NUMTOSTR(ZZ[SYSPARAM(1)],2)+'%) '),LINETHICK0,ColorffFFFF;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,0,190,2,' 【当天幅度:'+NUMTOSTR(振幅[SYSPARAM(1)],2)+'%'+'--价差:'+NUMTOSTR(差价[SYSPARAM(1)],2)+'元 】'),LINETHICK2,ColorFFFF00;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,0,6,146,'▼今/明短线赢利[1.7%--3%:]'+NUMTOSTR(FMAI[SYSPARAM(1)],2)+''+'--'+NUMTOSTR(FMAII[SYSPARAM(1)],2)+'/'+NUMTOSTR(MAI[SYSPARAM(1)],2)+''+'--'+NUMTOSTR(MAII[SYSPARAM(1)],2)),LINETHICK2,ColorFFFFFF;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,0,10,133,'【换手率】:'+NUMTOSTR(换手率[SYSPARAM(1)],2)+'% '+'【五日换手】:'+NUMTOSTR(五日换手[SYSPARAM(1)],2)+'% '+ '当日成交量:'+NUMTOSTR(量[SYSPARAM(1)],0)+'手'),colorFFFF00;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,0,10,170,' 交易日:'+NUMTOSTR(b[SYSPARAM(1)],0)+'(天) '+' 自然日:'+NUMTOSTR(aj[SYSPARAM(1)],0)
+'(天) '),color00DDFF;
kk:=DYNAINFO( 3);
GGC:=kk*0.10;
Y:=kk+GGC;
U:=kk-GGC;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,0,4,157,'◆涨停价:'+NUMTOSTR(Y,2)),Color8080FF;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,0,99,157,'◆跌停价:'+NUMTOSTR(U,2)),ColorFFFF00;
//FINANCE
ZX:=DYNAINFO( 7);//当日最新价
最新市盈率:=ZX/FINANCE(33);
YS:=DYNAINFO(39);//市盈率
最新估值:=调1*FINANCE(33);{调1:固定市盈率}
DRAWTEXTEX(SYSPARAM(3)=BARPOS,0,2,186,
' 总股本:'+NUMTOSTR(FINANCE(1)/10000,2 )+'亿'+' ★'+'流通股:'+ NUMTOSTR(FINANCE(7)/10000,2)+'亿'+' ★'+'最新收益:'+ NUMTOSTR(FINANCE(33),3)+''+'\n'+' 上年市盈率:'+NUMTOSTR(YS,2 )+'%'+' ★'+'最新市盈率:'+NUMTOSTR(最新市盈率,2 )+'%'+'\n'
),ColorAEDDFF;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,0,2,210,' 最新估值:'+NUMTOSTR(最新估值,2 )+'★'+'['+NUMTOSTR(调1,0 )+'倍市盈率估算]'),ColorAEDDFF;
估值:=FINANCE(10)-(FINANCE(15)+FINANCE(16)+FINANCE(14));{总资产(千元)-流动负债-长期负债}
QE:=估值/FINANCE( 1);{每股=当前估值/ 总股本}
DRAWTEXTEX(SYSPARAM(3)=BARPOS,0,2,222,' 财务估值: '+NUMTOSTR(QE,2)+' [总资产-流动负债-长期负债]'),LINETHICK1,ColorAEDDFF;
{光标角度线}
M:=(SYSPARAM(4)-SYSPARAM(5))/(SYSPARAM(3)-SYSPARAM(2));
DRAWSL(BARPOS=SYSPARAM(1),LOW,18.5*M/50,0,0),ColorFF00FF,LINEDASHDOT;
DRAWSL(BARPOS=SYSPARAM(1),LOW,27.5*M/50,0,0),ColorFF0000,LINEDASHDOT;
DRAWSL(BARPOS=SYSPARAM(1),LOW,38.5*M/50,0,0),COLORdddddd,LINEDASHDOT;
DRAWSL(BARPOS=SYSPARAM(1),LOW,55*M/50,0,0),Color0080FF;
DRAWSL(BARPOS=SYSPARAM(1),LOW,78*M/50,0,0),Colordddddd,LINEDASHDOT;
DRAWSL(BARPOS=SYSPARAM(1),LOW,110*M/50,0,0),,ColorFF0000,LINEDASHDOT;
DRAWSL(BARPOS=SYSPARAM(1),LOW,165*M/50,0,0),,ColorFF00FF,LINEDASHDOT;
DRAWSL(BARPOS=SYSPARAM(1),LOW,220*M/50,0,0),Color458A00,LINEDASHDOT;
//均线
MC2:MA(CLOSE,F2),Colorffff00,linethick1,LINEDOT,COLORffffFF;
MC3:MA(CLOSE,F3),Colorffff00,linethick1,LINEDOT,COLORffffFF;
MC4:MA(CLOSE,F4),Colorffff00,linethick1,LINEDOT,COLORffffFF;
MC5:MA(CLOSE,F5),Colorffff00,linethick1,LINEDOT,COLORffffFF;
MC6:MA(CLOSE,F6),Colorffff00,linethick1,LINEDOT,COLOR00ffff;
MC7:MA(CLOSE,F7),Colorffff00,linethick1,LINEDOT,COLORff00ff;
MC8:MA(CLOSE,F8),Colorffff00,linethick1,LINEDOT,COLOR00ff00;
MC9:MA(CLOSE,F9),Colorffff00,linethick1,LINEDOT,COLORffff00;
DRAWTEXT(BARSTATUS=2 AND Mc5>REF(Mc5,1),Mc5,' ↑'+NUMTOSTR(Mc5,2)),COLORffffFF;
DRAWTEXT(BARSTATUS=2 AND Mc5<REF(Mc5,1),Mc5,' ↓'+NUMTOSTR(Mc5,2)),ColorffffFF;
DRAWTEXT(BARSTATUS=2 AND Mc5=REF(Mc5,1),Mc5,':='+NUMTOSTR(Mc5,2)),COLORffffFF;
DRAWTEXT(BARSTATUS=2 AND Mc6>REF(Mc6,1),Mc6,' ↑'+NUMTOSTR(Mc6,2)),COLOR00ffff;
DRAWTEXT(BARSTATUS=2 AND Mc6<REF(Mc6,1),Mc6,' ↓'+NUMTOSTR(Mc6,2)),Color00ffff;
DRAWTEXT(BARSTATUS=2 AND Mc6=REF(Mc6,1),Mc6,':='+NUMTOSTR(Mc6,2)),COLOR00ffff;
DRAWTEXT(BARSTATUS=2 AND Mc7>REF(Mc7,1),Mc7,' ↑'+NUMTOSTR(Mc7,2)),COLORff00ff;
DRAWTEXT(BARSTATUS=2 AND Mc7<REF(Mc7,1),Mc7,' ↓'+NUMTOSTR(Mc7,2)),Colorff00ff;
DRAWTEXT(BARSTATUS=2 AND Mc7=REF(Mc7,1),Mc7,':='+NUMTOSTR(Mc7,2)),COLORff00ff;
DRAWTEXT(BARSTATUS=2 AND Mc8>REF(Mc8,1),Mc8,' ↑'+NUMTOSTR(Mc8,2)),COLOR00fF00;
DRAWTEXT(BARSTATUS=2 AND Mc8<REF(Mc8,1),Mc8,' ↓'+NUMTOSTR(Mc8,2)),Color00ff00;
DRAWTEXT(BARSTATUS=2 AND Mc8=REF(Mc8,1),Mc8,':='+NUMTOSTR(Mc8,2)),COLOR00ff00;
DRAWTEXT(BARSTATUS=2 AND Mc9>REF(Mc9,1),Mc9,' ↑'+NUMTOSTR(Mc9,2)),COLORffff00;
DRAWTEXT(BARSTATUS=2 AND Mc9<REF(Mc9,1),Mc9,' ↓'+NUMTOSTR(Mc9,2)),Colorffff00;
DRAWTEXT(BARSTATUS=2 AND Mc9=REF(Mc9,1),Mc9,':='+NUMTOSTR(Mc9,2)),COLORffff00;

飞狐江恩股票行情主图指标公式

 

相关文章