在线检测未来函数

大智慧绝品MACD指标公式

来源:Internet,编辑:股旁网,2011-10-23

V1:=DMA((((HIGH + LOW) + (CLOSE * 2)) /3.90),0.9);
HY1:=REF(EMA(V1,3),1);
DRAWtext(CROSS(HY1,CLOSE),HIGH*0.01,'★卖出'),LINETHICK3,colorwhite;
DIF1:=EMA(CLOSE,2) - EMA(CLOSE,55);
DEA1:=EMA(DIF1,3);
MACD1:=2*(DIF1-DEA1);
MACD2:=EMA(MACD1,4);
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,9,0),COLORRED;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,9,0),COLORRED;
STICKLINE(MACD1<MACD2,0,MACD1,9,0),COLORFF0000;
STICKLINE(MACD1>=0 OR MACD1<=0,0,0,50,1),COLOR00FFFF;
MACD:MACD1,COLORRED,LINETHICK6;
强在量上卖:IF(DIF1>=DEA1,DIF1,0),COLORFFFF00,LINETHICK6;
持仓段:0,COLOR00CFFF;
空仓段:0,COLORFFCCFF;
DRAWTEXT(CROSS(DIF1,DEA1),DIF1+0.01,'建仓'),COLORRED,LINETHICK3;
DRAWTEXT(CROSS(DEA1,DIF1),DIF1+0.01,'空仓'),COLORGREEN,LINETHICK7;
Va19f:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
Va1Af:=(EMA(CLOSE,12)-EMA(CLOSE,26))*100;
Va1Bf:=EMA(Va1Af,9);
Va1Cf:=2*(Va1Af-Va1Bf);
DRAWTEXT(Va1Af<-50 AND Va19f>7 AND Va1Af<Va1Bf,0,'短期见底'),coloryellow,LINETHICK3 ;
{www.gUPaNg.com 股旁网_最新股票指标公式}
RSVA:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
KA:=SMA(RSVA,3,1);
DA:=SMA(KA,3,1);
买进:IF(DA<25 AND CROSS(KA,DA) ,0.05,0),COLORRED,STICK,LINETHICK5;
卖出:IF(DA>75 AND CROSS(DA,KA) ,0.05,0),COLORff0000,STICK,LINETHICK5;
Q:2*(DEA1-DIF1),COLOR00ff00,linethick5;
AS1:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
AA1:=SMA(AS1,3,1);
BB1:=SMA(AA1,3,1);
AB1:=CROSS(AA1,BB1);
DD1:=EMA(CLOSE,6)-EMA(CLOSE,13);
DD2:=EMA(DD1,3);
MACD1:(DD1-DD2)*2;
AD1:=CROSS(DD1,DD2);
MACD2:=EMA(MACD1,4);
EE:IF(AB1 AND AD1,0.8,0),STICK,LINETHICK7,COLORRED;
EE1:=C>EMA(C,13);
EE2:=EMA(C,13)>REF(EMA(C,13),1);
DRAWTEXT(EE AND EE1 AND EE2,0.8,'←买入'),LINETHICK5,COLORff33ff;
AB2:=CROSS(BB1,AA1);
AD2:=CROSS(DD2,DD1);
FF:IF(AB2 AND AD2,0.8,0),LINETHICK3,COLORff0000;

大智慧绝品MACD指标公式

 

相关文章