在线检测未来函数

飞狐神秘波浪指标公式

来源:Internet,编辑:股旁网,2011-10-26

DY1:=(2*CLOSE+HIGH+LOW)/4;
DY2:=LLV(LOW,55);
DY3:=HHV(HIGH,34);
DYA:=MA((DY1-DY2)/(DY3-DY2)*100,30),colorred;
DYB:=EMA(DYA,5),coloryellow;
A1:=MA((DY1-DY2)/(DY3-DY2)*100,10);
B1:=EMA((0.668*REF(A1,1)+0.332*A1),2),COLORred;
波:IF(A1>=B1,A1,B1),LINETHICK1,COLORf00ff0,LINETHICK2;
浪:IF(B1-A1,B1,A1),LINETHICK1,color00FF00;
开:SMA(MAX(O-REF(O,1),0),6,1)/SMA(ABS(O-REF(O,1)),6,1)*100 ,LINETHICK0;
高:SMA(MAX(H-REF(H,1),0),6,1)/SMA(ABS(H-REF(H,1)),6,1)*100 ,LINETHICK0;
低:SMA(MAX(L-REF(L,1),0),6,1)/SMA(ABS(L-REF(L,1)),6,1)*100 ,LINETHICK0;
收:SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100 ,LINETHICK0;
收均: ma(收,3);
PARTLINE(C,10),pointdot;
PARTLINE(C,90),pointdot;
STICKLINE(收>开,高,低,0,0),colorred;
STICKLINE(收>开,收,开,7,1),colorred;
STICKLINE(收< 开,高,低,0,0),COLORgreen;
STICKLINE(收< 开,收,开,7,0),COLORgreen;
DRAWTEXT(filter(Min(高,低)<20 and Min(REF(高,1),REF(低,1))<20 and Min(REF(高,2),REF(低,2))<20 and 收>REF(收,1) and c>ma(c,120),5),50,'★买'),colorred;
{www.gUPaNg.com 股旁网_最新股票指标公式}
DRAWTEXT(filter(Min(高,低)<20 and 收>REF(收,1) and c>ma(c,120),5),低,'★买'),colormagenta;
DRAWTEXT((收-低)>25,低-5,'★火箭发射'),colorred;
DRAWTEXT(MAX(高,低)>89 and 收<90 and REF(收,1)>90 and REF(收,2)>90,10,'★逃顶'),colorgreen;
DRAWTEXT(收<90 and 开>90 and REF(收,1)>REF(收,3),高+5,'★瀑布'),colorcyan;
DRAWTEXT((Min(高,低)-abs(收-开))/abs(高-低)>0.667 and 收<80 and REF(收,1)>80 ,100,'★逃'),colorcyan;
if(收>80 or 开>80,80,100),colorred;
if(收<20 or 开<20,20,0),colorgreen;
Varm1:=(REF(HIGH,1)+REF(LOW,1))/2;
Varm2:=MA(CLOSE,20)+2*STD(CLOSE,20);
Varm3:=REF(CLOSE,1);
Varm4:=SMA(MAX(CLOSE-Varm3,0),7,1)/SMA(ABS(CLOSE-Varm3),7,1)*100;
Varm5:=CROSS(79,Varm4);
Varm6:=FILTER(Varm5,4);
卖一:=if(CROSS(Varm1,Varm2),1,0);
STICKLINE(卖一=1,90,100,10,1),COLORblue,LINETHICK3;
卖二:=if(Varm6,1,0);
STICKLINE(卖二=1,90,100,10,1),COLORWHITE,LINETHICK3;
50,POINTDOT,COLORWHITE;
Vars1:=REF(CLOSE,1);
Vars2:=SUM(IF(CLOSE> REF(CLOSE,1),VOL,IF(CLOSE< REF(CLOSE,1),0-VOL,0)),0);
Vars3:= REF(Vars2,1);
Vars4:=SMA(MAX(CLOSE-Vars1,0),7,1)/SMA(ABS(CLOSE-Vars1),7,1)*100;
Vars5:=SMA(MAX(CLOSE-Vars1,0),13,1)/SMA(ABS(CLOSE-Vars1),13,1)*100;
Vars6:=SMA(MAX(Vars2-Vars3,0),26,1)/SMA(ABS(Vars2-Vars3),26,1)*100;
底部:= IF(Vars4<15 AND Vars5<20 AND Vars6<50 AND BARSCOUNT(CLOSE)>25,-100,0);
顶部:= IF(Vars4>85 AND Vars5>80 AND Vars6>50 AND BARSCOUNT(CLOSE)>25 ,100,0);
DRAWTEXT(filter(底部=-100,5),20,'底'),linethick2,POINTDOT,colorwhite;
DRAWTEXT(filter(顶部=100,5),80,'顶'),linethick2,POINTDOT,colorwhite;

飞狐神秘波浪指标公式

 

相关文章