在线检测未来函数

飞狐动能短线指标公式

来源:Internet,编辑:股旁网,2011-10-27

OSC:=C-REF(MA(C,13),5);
分界:=MA(OSC,8);
DIFF := EMA(OSC,12) - EMA(OSC,26);
DEA := EMA(DIFF,9);
MACD := 2*(DIFF-DEA);
Z_F:=IF(C>REF(H,1),EMA(L,5),IF(C<REF(EMA(L,5),1),H,EMA(L,5)));
K_d:=BARSLAST(C<=Z_F);
X_H:=K_d=1 and BARSLAST(MACD<REF(MACD,1));
{===================== 【解模板】===================== }
DRAWGBK((DATE > 0),COLORRGB(40,40,60),COLORRGB(10,10,10),1);
{柱线}
STICKLINE(MACD<ref(MACD,1) and MACD<0,0,MACD*4,0,0),LINEDOT,ColorFFCF78;
STICKLINE(MACD<ref(MACD,1) and MACD>0,0,MACD*4,0,0),LINEDOT,COLORYELLOW;
{www.gUPaNg.com 股旁网_最新股票指标公式}
STICKLINE(MACD>ref(MACD,1) and MACD<0,0,MACD*4,0,0),LINEDOT,COLORMAGENTA;
STICKLINE(MACD>ref(MACD,1) and MACD>0,0,MACD*4,0,0),LINEDOT,COLORRED;
{K柱}
STICKLINE(OSC<REF(OSC,1)||(AMOUNT/REF(AMOUNT,1)<0.97),OSC,REF(OSC,1),7,0),LINETHICK2,COLORWHITE;//离场
STICKLINE(CROSS(ref(MACD,1),MACD) and MACD<ref(MACD,1),OSC,REF(OSC,1),7,0),LINETHICK2,COLORYELLOW;//逃顶
STICKLINE(OSC>=REF(OSC,1),OSC,REF(OSC,1),7,0),LINETHICK2,COLORRED;//持股
STICKLINE(BARSLAST(X_H)<2,OSC,REF(OSC,1),7,0),LINETHICK2,COLORRED;//延时
STICKLINE(X_H,OSC,REF(OSC,1),7,0),LINETHICK2,COLORMAGENTA;//启动
STICKLINE(OSC<分界,OSC,REF(OSC,1),7,0),LINETHICK2,ColorFFA900;//空仓
动能线:OSC,ColorFFB5FF;
加速线:(DEA-DIFF)*9.8,COLORGREEN;
{字}
DRAWTEXT(BARPOS=SYSPARAM(3),0,' 启动'),ALIGN4,COLORMAGENTA;
DRAWTEXT(BARPOS=SYSPARAM(3),0,' \n 持股'),PXDN3,ALIGN4,COLORRED;
DRAWTEXT(BARPOS=SYSPARAM(3),0,' \n \n 逃顶'),PXDN6,ALIGN4,COLORYELLOW;
DRAWTEXT(BARPOS=SYSPARAM(3),0,' \n \n \n 警惕'),PXDN9,ALIGN4,COLORWHITE;
DRAWTEXT(BARPOS=SYSPARAM(3),0,' \n \n \n \n 空仓'),PXDN12,ALIGN4,ColorFFA900;

飞狐动能短线指标公式

 

相关文章

股票公式月点击榜

股票公式年点击榜

股票公式总点击榜