在线检测未来函数

通达信周KDJ双J阶梯指标公式

来源:Internet,编辑:股旁网,2011-11-03

ZJ1:=MA("KDJ.J#WEEK"(9,3,3) ,5);
STICKLINE(ZJ1>=0 AND ZJ1>=REF(ZJ1,1),0,50,4,0),COLORAA0077;
STICKLINE(ZJ1<0 ,0,50,4,0),COLOR060099;
STICKLINE(ZJ1<0 AND ZJ1>=REF(ZJ1,1),0,50,4,0),COLOR660088;
AA1:=IF(ZJ1<0 AND ZJ1<REF(ZJ1,1),-5,0),COLOR00FFFF;
BB1:=IF(ZJ1<0 AND ZJ1>=REF(ZJ1,1),-8,0),COLOR000088;
YK:=MA("KDJ.K#MONTH"(9,3,3),20),LINETHICK0;
YD:=MA("KDJ.D#MONTH"(9,3,3),20),LINETHICK0;
YJ:=MA("KDJ.J#MONTH"(9,3,3),20);
ZK:MA("KDJ.K#WEEK"(9,3,3) ,5),LINETHICK0;
ZD:MA("KDJ.D#WEEK"(9,3,3) ,5),LINETHICK0;
IF(ZJ1>85,100,DRAWNULL),COLOR00FFFF,LINETHICK4;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1),LINETHICK0;
D:=SMA(K,3,1),LINETHICK0;
J:3*K-2*D,LINETHICK0;
DRAWBAND(0,RGB(150,200,0),AA1,RGB(0,0,0));
DRAWBAND(0,RGB(200,50,150),BB1,RGB(0,0,0));
ZJ:=ZJ1,COLOR0000FF,LINETHICK2;
STICKLINE(C>0,50,50,2,0),COLOR00FFFF;
100;
周J:"KDJ.J#WEEK"(9,3,3),COLOR00FFFF,LINETHICK1;
STICKLINE(周J>REF(ZJ,1),50,100,4,0),COLOR888800;
DRAWBAND(ZK,RGB(200,0,0),ZD,RGB(0,200,200));
STICKLINE(K>=D,K,D,2,0),COLORBBAA00;
STICKLINE(K<D,K,D,2,1),COLOR00FFFF;
{www.gUPaNg.com 股旁网_最新股票指标公式}
DRAWBAND(周J,RGB(250,50,250),ZJ,RGB(100,190,250));
金叉:STICKLINE(CROSS(K,D),0,7,2,0), COLORMAGENTA,LINETHICK2;
DRAWTEXT(CROSS(K,D),9,'日金叉'),COLORMAGENTA;
日死叉:STICKLINE(CROSS(D,K),93,100,2,0), COLOR00FF00,LINETHICK2;
DRAWTEXT(CROSS(D,K),95,'日死叉'),COLOR00FF00;
周金叉:STICKLINE(CROSS(ZK,ZD),0,12,2,0),COLORRED,LINETHICK2;
DRAWTEXT(CROSS(ZK,ZD),15,'周金叉'),COLORRED;
周死叉:STICKLINE(CROSS(ZD,ZK),87,100,2,0), COLORFFFF00,LINETHICK2;
DRAWTEXT(CROSS(ZD,ZK),85,'周死叉'), COLORFFFF00;
月金叉:STICKLINE(CROSS(YK,YD),0,17,2,0),COLORYELLOW,LINETHICK2;
DRAWTEXT(CROSS(YK,YD),19,'月金叉'),COLORYELLOW;
月死叉:STICKLINE(CROSS(YD,YK),82,100,2,0),COLORFF0000,LINETHICK2;
DRAWTEXT(CROSS(YD,YK),80,'月死叉'),COLORFF0000;
DRAWTEXT_FIX(1,0.2,0,0,'★★ 深红色--提示准备★★暗粉红色--买入区★★紫粉色--加仓区★★上部绿色--持仓区★★顶部黄色带--风险提示★★'),COLORFFFF00;

通达信周KDJ双J阶梯指标公式

 

相关文章