在线检测未来函数

飞狐KDJ+主力进出指标公式

来源:Internet,编辑:股旁网,2011-11-04

DRAWGBK(C=C,COLORRGB(130,130,130),COLORRGB(30,30,30),1);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
k:=SMA(rsv,3,1),LINETHICK1;
D:=SMA(k,3,1),LINETHICK1;
j:=3*k-2*d,LINETHICK1;
{主力进出}
V1:=(CLOSE*2+HIGH+LOW)/4*10;
V2:=EMA(V1,13)-EMA(V1,34);
V3:=EMA(V2,5);
V4:=2*(V2-V3)*5.5;
吸筹:=IF(V4>=0,V4,0),LINETHICK2,colorFF00FF;
V5:=(HHV(INDEXH,8)-INDEXC)/(HHV(INDEXH,8)-LLV(INDEXL,8))*8;
V6:=EMA(3*V5-2*SMA(V5,18,1),5);
V7:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*10;
V8:=(INDEXC*2+INDEXH+INDEXL)/4;
V9:=EMA(V8,13)-EMA(V8,34);
VA:=EMA(V9,3);
VB:=(V9-VA)/3;
出动:=IF(VB>=0,VB,0),LINETHICK2,colorFFFF;
//////
KX:=SYSPARAM(3)-SYSPARAM(2)+1;
KH:=HHV(k,KX);
jH:=HHV(j,KX);
KL:=LLV(k,KX);
jL:=LLV(j,KX);
HKMAX:=MAX(KH[DATACOUNT],jH[DATACOUNT]);
LKMIN:=MIN(KL[DATACOUNT],JL[DATACOUNT]);
KHLB:=(HKMAX+LKMIN)/2;
KHLC:=HKMAX-LKMIN;
MHF:=HHV(吸筹,KX);
MHD:=HHV(出动,KX);
MLF:=LLV(吸筹,KX);
MLD:=LLV(出动,KX);
HMAX:=MAX(MHF[DATACOUNT],MHD[DATACOUNT]);
LMIN:=MIN(MLF[DATACOUNT],MLD[DATACOUNT]);
FHLB:=(HMAX-LMIN)/100;
FHLC:=HMAX-LMIN;
v000:=(吸筹-FHLB)*KHLC/FHLC+KHLB-50;
v001:=(出动-FHLB)*KHLC/FHLC+KHLB-50;
主力:V000,LINETHICK2,colorFF00FF;
散户:V001,LINETHICK2,colorFF7100;
{散户,LINESTICK,colorFF7100;
主力,LINESTICK,colorFF00FF;}
FILLRGN(散户>0,散户,0),colorFF7100;
STICKLINE(主力>0,主力,0,1,0),colorFF00FF;
/////////
AA:=(WINNER(CLOSE+CLOSE*15/100))*100;
BB:=(WINNER(CLOSE+CLOSE*0/100))*100;
CC:=AA-BB;
DD:=(WINNER(CLOSE-CLOSE*0.1/100)-(WINNER(CLOSE-CLOSE*15/100)))*100;
EE:=CC<3 AND DD<0.5 AND OPEN<>LOW;
A1:=DYNAINFO(6);
A2:=IF(LOW>A1,0,IF(HIGH<A1,1,(A1-LOW+0.01)/(HIGH-LOW+0.01)));
A3:=VOL/WINNER(LOW);
A4:=REF(HHV(CLOSE,120),1);
A5:=REF(LLV(CLOSE,120),1);
A6:=100*(CLOSE-A5)/(A4-A5);
A7:=A2>0 OR A2=1;
A8:=A7 AND A3/REF(A3,3)>=3 AND A6<80;
A9:=REF(A8,1) OR REF(A8,2) OR REF(A8,3) OR REF(A8,4);
A10:=A8 AND A9;
A11:=IF(FILTER(A8,3),13,0);
A12:=IF(FILTER(A10,5) OR EE,10,0);
资金进场日:=IF(A11,13,0);
STICKLINE(A12,0,10,5,0),colorFF00FF;
资金加仓日:=IF(A12,10,0);
STICKLINE(A12,0,10,5,0),colorCCCC;
STICKLINE(A11,0,13,5,0),colorFF7700;
STICKLINE(A11,0,13,4.5,0),colorFF8800;
STICKLINE(A11,0,13,4,0),colorFF9900;
STICKLINE(A11,0,13,3.5,0),colorFFAA00;
STICKLINE(A11,0,13,3,0),colorFFBB00;
STICKLINE(A11,0,13,2.5,0),colorFFCC00;
STICKLINE(A11,0,13,2,0),colorFFDD00;
STICKLINE(A11,0,13,1,0),colorFFEE00;
STICKLINE(A12,0,10,4.5,0),color102099;
STICKLINE(A12,0,10,4,0),color1020AA;
STICKLINE(A12,0,10,3.5,0),color1020BB;
STICKLINE(A12,0,10,3,0),color1020CC;
STICKLINE(A12,0,10,2.5,0),color1020DD;
STICKLINE(A12,0,10,2,0),color1020EE;
STICKLINE(A12,0,10,1,0),color1020FF;
DRAWTEXT(A11,35,'←进场'),COLORWHITE;
DRAWTEXT(A12,-5,'←加仓'),colorFF;
VAR1:=REF(LOW,1);
VAR2:=(SMA(ABS(LOW-VAR1),13,1))/(SMA(MAX(LOW-VAR1,0),13,1))*10;
VAR3:=EMA(VAR2,13);
VAR4:=LLV(LOW,34);
VAR5:=EMA(IF(LOW<=VAR4,VAR3,0),3);
发现主力看跌:STICKLINE(LOW>REF(CLOSE,1),0,0.15,2,0),colorFF;
STICKLINE(VAR5>REF(VAR5,1),0,VAR5,8,0),colorAA;
STICKLINE(VAR5>REF(VAR5,1),0,VAR5,5,0),colorCC;
STICKLINE(VAR5>REF(VAR5,1),0,VAR5,3,0),colorDD;
STICKLINE(VAR5>REF(VAR5,1),0,VAR5,1,0),colorFF;
洗盘拉升:STICKLINE(LOW>REF(CLOSE,1),0,0.15,2,0),colorFF00;
STICKLINE(VAR5<REF(VAR5,1),0,VAR5,8,0),color7400;
STICKLINE(VAR5<REF(VAR5,1),0,VAR5,5,0),color9F00;
STICKLINE(VAR5<REF(VAR5,1),0,VAR5,3,0),colorC000;
STICKLINE(VAR5<REF(VAR5,1),0,VAR5,1,0),colorE700;
主力出动看涨:STICKLINE(LOW>REF(CLOSE,1),0,0.15,2,0),colorFFFF;
STICKLINE(VAR5>REF(VAR5,1) AND CLOSE>OPEN,0,VAR5,8,0),colorAAAA;
STICKLINE(VAR5>REF(VAR5,1) AND CLOSE>OPEN,0,VAR5,5,0),colorCCCC;
STICKLINE(VAR5>REF(VAR5,1) AND CLOSE>OPEN,0,VAR5,3,0),colorEEEE;
STICKLINE(VAR5>REF(VAR5,1) AND CLOSE>OPEN,0,VAR5,1,0),colorFFFF;
{www.gUPaNg.com 股旁网_最新股票指标公式}
打压下跌:STICKLINE(LOW>REF(CLOSE,1),0,0.15,2,0),colorFF7100;
STICKLINE(VAR5<REF(VAR5,1) AND CLOSE<OPEN,0,VAR5,8,0),colorBB7100;
STICKLINE(VAR5<REF(VAR5,1) AND CLOSE<OPEN,0,VAR5,5,0),colorFF7100;
STICKLINE(VAR5<REF(VAR5,1) AND CLOSE<OPEN,0,VAR5,3,0),colorFF9000;
STICKLINE(VAR5<REF(VAR5,1) AND CLOSE<OPEN,0,VAR5,1,0),colorFFBE00;
IF(VAR5<REF(VAR5,0),VAR5,0),LINETHICK2,colorFF;
VAR6:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR7:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR8:=VAR6<REF(VAR7,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
STICKLINE(VAR8 AND COUNT(VAR8,18)=1,0,18,8,0),colorAA00BB;
STICKLINE(VAR8 AND COUNT(VAR8,18)=1,0,18,8,0),colorBB11BB;
STICKLINE(VAR8 AND COUNT(VAR8,18)=1,0,18,5,0),colorCC22BB;
STICKLINE(VAR8 AND COUNT(VAR8,18)=1,0,18,3,0),colorDD33BB;
STICKLINE(VAR8 AND COUNT(VAR8,18)=1,0,18,1,0),colorEE44BB;
DRAWTEXT(VAR8 AND COUNT(VAR8,18)=1,18,'←大资金'),colorFF00FF;
DRAWTEXT(VAR8 AND COUNT(VAR8,18)=1,30,'←择机买入'),colorFF00;
DRAWTEXT(VAR8 AND COUNT(VAR8,18)=1,-10,'←多数会涨'),colorFFFF;
k,LINETHICK1;
D,LINETHICK1;
j,LINETHICK1;

飞狐KDJ+主力进出指标公式

 

相关文章