在线检测未来函数

飞狐短期均线主图指标公式

来源:Internet,编辑:股旁网,2011-11-06

a5:ma(c,5)+(c-ref(c,4))/5;
a10:ma(c,10)+(c-ref(c,9))/10;
a20:ma(c,20)+(c-ref(c,19))/20;
a30:ma(c,30);
a60:ma(c,60),COLORRED,linethick2;
a120:ma(c,120);
a250:ma(c,250);
B1:=REF(C,1);B2:=REF(C,2);
SS:=IF(C>REF(C,1) AND REF(C,1)>=REF(C,2),1,IF(C<REF(C,1) AND REF(C,1)<=REF(C,2),-1,
IF(C>REF(C,2) AND REF(C,2)>REF(C,1),2,IF(C<REF(C,2) AND REF(C,2)<REF(C,1),-2,0))));
SM:=IF(REF(SS,1)<>0,REF(SS,1),IF(REF(SS,2)<>0,REF(SS,2),IF(REF(SS,3)<>0,REF(SS,3),
IF(REF(SS,5)<>0,REF(SS,5),IF(REF(SS,6)<>0,REF(SS,6),IF(REF(SS,7)<>0,REF(SS,7),0))))));
DK:=IF(REF(SS,1)<>0,B2,IF(SM>0,MIN(B1,B2),MAX(B1,B2)));
STICKLINE(c>=dk and c<o,c,o,8,1),color5454ff;
STICKLINE(c>=dk and c<o,c,o,6,0),colorffff54;
STICKLINE(c>=dk and c<o,c,l,1,0),color5454ff;
STICKLINE(c>=dk and c<o,h,o,1,0),color5454ff;
STICKLINE(c>=dk and c>o,c,h,1,0),color5454ff;
STICKLINE(c>=dk and c>o,l,o,1,0),color5454ff;
STICKLINE(c>=dk and c=o,l,h,1,0),color5454ff;
STICKLINE(c<dk and c>o,c,o,8,1),colorffff54;
STICKLINE(c<dk and c>o,c,h,1,0),colorffff54;
STICKLINE(c<dk and c>o,l,o,1,0),colorffff54;
STICKLINE(c<dk and c<o,c,l,1,0),colorffff54;
STICKLINE(c<dk and c<o,h,o,1,0),colorffff54;
STICKLINE(c<dk and c=o,h,l,1,0),colorffff54;
DRAWTEXTEX(c,1,1,10,'板块:'+STRLEFT(BLKNAME,35)),COLORYELLOW;
{www.gUPaNg.com 股旁网_最新股票指标公式}
DRAWTEXTEX(c,1,1,60,'总股本:'+NUMTOSTR(FINANCE(1)/10000 ,2 )+'亿'+' 流通A股:'+ NUMTOSTR(FINANCE(7)/10000,2)+'亿'),COLORYELLOW;
DRAWTEXTEX(c,1,1,110,
'每股收益:'+ NUMTOSTR(FINANCE(33),2)+' 市盈率:'+NUMTOSTR(DYNAINFO(39),2)+' 净资产:'+NUMTOSTR(FINANCE(34),2)+' 净资产收益率:'+NUMTOSTR(FINANCE(37),2)),COLORYELLOW;
DRAWTEXTEX(c,1,1,160,'上涨家数:'+NUMTOSTR(INDEXADV,0)+' 下跌家数:'+NUMTOSTR(INDEXDEC,0)),COLORYELLOW;
明日阻力3:=if(l<>h,(c+h+l)/3*2+h-2*l,(c+h+l)/3*1.075);
明日阻力2:=if(l<>h,(c+h+l)/3+(h-l),(c+h+l)/3*1.05);
明日阻力1:=if(l<>h,(c+h+l)/3*2-l,(c+h+l)/3*1.025);
明日轴心:=(c+h+l)/3;
明日支撑1:=if(l<>h,(c+h+l)/3*2-h,(c+h+l)/3*0.975);
明日支撑2:=if(l<>h,(c+h+l)/3-(h-l),(c+h+l)/3*0.95);
明日支撑3:=if(l<>h,(c+h+l)/3*2-2*h+l,(c+h+l)/3*0.925);
STICKLINE(BARSTATUS=2,ref(明日阻力1,1),ref(明日阻力1,1),10,0),Colorgreen;
STICKLINE(BARSTATUS=2,ref(明日支撑1,1),ref(明日支撑1,1),10,0),Colormagenta;
STICKLINE(BARSTATUS=2,ref(明日阻力2,1),ref(明日阻力2,1),10,0),Colorgreen;
STICKLINE(BARSTATUS=2,ref(明日支撑2,1),ref(明日支撑2,1),10,0),Colormagenta;
STICKLINE(BARSTATUS=2,ref(明日阻力3,1),ref(明日阻力3,1),10,0),Colorgreen;
STICKLINE(BARSTATUS=2,ref(明日支撑3,1),ref(明日支撑3,1),10,0),Colormagenta;
STICKLINE(BARSTATUS=2,ref(明日轴心,1),ref(明日轴心,1),10,0),Colorwhite;
DRAWTEXTEX(c,1,1,210,'阻力3:'+NUMTOSTR(ref(明日阻力3,1),3)),COLORYELLOW;
DRAWTEXTEX(c,1,1,260,'阻力2:'+NUMTOSTR(ref(明日阻力2,1),3)),COLORYELLOW;
DRAWTEXTEX(c,1,1,310,'阻力1:'+NUMTOSTR(ref(明日阻力1,1),3)),COLORYELLOW;
DRAWTEXTEX(c,1,1,360,'轴心:'+NUMTOSTR(ref(明日轴心,1),3)),COLORYELLOW;
DRAWTEXTEX(c,1,1,410,'支撑1:'+NUMTOSTR(ref(明日支撑1,1),3)),COLORYELLOW;
DRAWTEXTEX(c,1,1,460,'支撑2:'+NUMTOSTR(ref(明日支撑2,1),3)),COLORYELLOW;
DRAWTEXTEX(c,1,1,510,'支撑3:'+NUMTOSTR(ref(明日支撑3,1),3)),COLORYELLOW;

飞狐短期均线主图指标公式

 

相关文章