在线检测未来函数

大智慧净流入KDJ指标公式

来源:Internet,编辑:股旁网,2011-11-10

DRAWGBKlast(DATE>900101,strip(RGB(0,0,100),RGB(0,0,0),50));
VAR1:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
买盘:=IF((CLOSE > OPEN),(VAR1 * (HIGH - LOW)),IF((CLOSE < OPEN),(VAR1 * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2)));
卖盘:=IF((CLOSE > OPEN),(0 - (VAR1 * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (VAR1 * (HIGH - LOW))),(0 - (VOL / 2))));
净流入:=买盘+卖盘;
N:=5;{可选}
价涨净流入:= C>REF(C,N) AND 净流入>0 ;
价涨净流出:=C>REF(C,N) AND 净流入<0;
价跌净流入:=C<REF(C,N) AND 净流入>0;
价跌净流出:=C<REF(C,N) AND 净流入<0;
STICKLINE(价涨净流入,0,价涨净流入/4,6,0),Color6800F6;
STICKLINE(价涨净流出,0,-价涨净流出/4,6,0),ColorFF009F;
STICKLINE(价跌净流入,0,-价跌净流入/4,6,0),COLOR00FFFF;
STICKLINE(价跌净流出,0,-价跌净流出/4,6,0),Color00FF6E;
VA:EMA(净流入,3)/CAPITAL*50,LINETHICK2,ColoR00FF9D;
FILLRGN(VA,0, VA>0,(RGB(100,20,100)));
FILLRGN(VA,0,VA<0,(RGB(130,100,255)));
{www.gUPaNg.com 股旁网_最新股票指标公式}
Var2:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27));
Var3:=SMA(Var2,3,1);
Var4:SMA(Var3,9,1),Color00ffFF;
Var5:3*Var3-2*Var4;
FILLRGN(Var5,Var4,Var5>REF(Var5,1) AND Var5>Var4 ,(RGB(200,110,10)));
FILLRGN(Var5,Var4, Var5<HHV(Var5,5) ,(RGB(100,100,200)));
FILLRGN(Var5,Var4, Var5<REF(Var5,1) and Var5<ref(Var5,2) and Var5<REF(Var5,3) ,(RGB(100,100,200)));
FILLRGN(Var4,Var5,Var4>Var5,(RGB(10,100,200)));
STICKLINE( 买盘>-卖盘,0,买盘/CAPITAL*20,2,1),Color0079FF,LINETHICK2;
STICKLINE( 买盘<-卖盘,0,卖盘/CAPITAL*20,2,1),Color526E00,LINETHICK2;
0;

大智慧净流入KDJ指标公式

 

相关文章