在线检测未来函数

通达信量能饱和度全息图指标公式

来源:Internet,编辑:股旁网,2011-11-14

{上市日期:FINANCE(42),NODRAW;}
〖量〗:=VOL,NODRAW,VOLSTICK;
STICKLINE(V>=3*REF(V,1),V/3,V/3,3.9,0),COLORWHITE;
STICKLINE(V>=2*REF(V,1),V/2,V/2,3.9,0),COLORYELLOW;
流通〖亿〗:=CAPITAL/1000000,LINETHICK0;
VVOL:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,VVOL,0,-1,-1),COLOR00C0C0;
VOLUME:VOL,VOLSTICK;
短线:MA(VOLUME,5),COLORWHITE;
MAVOL2:=MA(VOLUME,10);
中线:MA(VOLUME,35),COLORYELLOW;
MAVOL3:=MA(VOLUME,20),COLORRED;
MAVOL4:=MA(VOLUME,30);
长线:MA(VOLUME,135);
MAVOL5:=MA(VOLUME,60);
MAVOL6:=MA(VOLUME,100);
倍量:=VOL/REF(VOL,1)>2;
STICKLINE(倍量 AND C>REF(C,1),0,〖量〗,1,0),COLORRED;
STICKLINE(倍量 AND C<REF(C,1),0,〖量〗,1,0),COLORGREEN;
内外比:=DYNAINFO(51),COLORYELLOW,NODRAW;
单日量比:=V/REF(V,1),COLORWHITE,NODRAW;
{www.gUPaNg.com 股旁网_最新股票指标公式}
五日量比:=V/(REF(MA(V,5),1)/240*FROMOPEN),COLORYELLOW,NODRAW;
5换:SUM(100*V/CAPITAL,5),LINETHICK0;
10换:SUM(100*V/CAPITAL,10),LINETHICK0;
20换:SUM(100*V/CAPITAL,20),LINETHICK0;
A:=MA(VOL,5)-MA(VOL,10);
B:=BACKSET(1,5)/5-BACKSET(1,10)/10;
量差:A/B,NODRAW;
AA1:=VOL<REF(LLV(VOL,20),1);
AA2:=VOL<REF(LLV(VOL,30),1);
AA3:=VOL<REF(LLV(VOL,60),1);
AA4:=VOL<REF(LLV(VOL,100),1);
STICKLINE(AA1,0,V,1,0),COLORBLUE;
STICKLINE(AA2,0,V,1,0),COLORE6E8FA;
STICKLINE(AA3,0,V,0.6,0),COLORBLACK;
STICKLINE(AA4,0,V,0.3,0),COLORYELLOW;
{量能}
N1:=80;
SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
量能:IF(SAT>1,1,SAT)*100, COLORMAGENTA,NODRAW;
中点:=REFDATE(HHV(V,200)/2,DATE);
DRAWTEXT(CURRBARSCOUNT=100,中点*1.88,'量能饱和'),COLORYELLOW;
STICKLINE(CURRBARSCOUNT=N1,中点*1.9,中点*1.5,100,1),COLOR00DDDD;
STICKLINE(CURRBARSCOUNT=N1,中点*1.88,中点*1.52,量能,0),COLOR0033FF;
STICKLINE(CURRBARSCOUNT=N1,中点*1.82,中点*1.58,量能,0),COLOR0077FF;
STICKLINE(CURRBARSCOUNT=N1,中点*1.76,中点*1.64,量能,0),COLOR0099FF;
STICKLINE(CURRBARSCOUNT=N1,中点*1.7,中点*1.7,量能,0),COLOR00DDFF;
{持币:IF(SAR(10,2,20)>=H,SAR(10,2,20),DRAWNULL),CIRCLEDOT,COLORGREEN;
持股:IF(SAR(10,2,20)<=L,SAR(10,2,20),DRAWNULL),CIRCLEDOT,COLORRED; WJ:=(H+L+C)/3;}
{现量}
{STICKLINE(REFDATE(V,DATE),REFDATE(V,DATE),REFDATE(V,DATE),6,1),COLORWHITE;}{现量};

通达信量能饱和度全息图指标公式

 

相关文章