在线检测未来函数

通达信发现庄迹指标公式

来源:Internet,编辑:股旁网,2011-11-15

AA:=(O+H+L+C)/4;
BB:=MA(AA,3);
CC:=SUM(IF(AA>REF(AA,1),AA*VOL,0),4)/SUM(IF(AA<REF(AA,1),AA*VOL,0),4);
DD:=REF(100-(100/(1+CC)),1);
A1:=HHV(AA,15);
A2:=LLV(AA,15);
A3:=A1-A2;
A4:=EMA((AA-A2)/A3,2)*100;
B1:=HHV(AA,60);
B2:=LLV(AA,60);
B3:=B1-B2;
B4:=EMA((AA-B2)/B3,2)*100;
C1:=HHV(AA,240);
C2:=LLV(AA,240);
C3:=C1-C2;
C4:=EMA((AA-C2)/C3,2)*100;
短期:A4,COLOR0099FF,LINETHICK2;
中期:B4,COLORRED,LINETHICK1;
长期:C4,COLORFF00FF,LINETHICK1;
STICKLINE(短期>90 AND 中期>70,86,94,1,0),COLORGREEN;
STICKLINE(短期<5 AND 中期<30,0,8,1,0),COLORRED;
IF(FILTER(中期<REF(中期,1)AND 中期>90 AND BB<REF(BB,1),5),80,100),COLORGREEN,LINETHICK1;
IF(FILTER(中期>REF(中期,1)AND 中期<5 AND C>REF(C,1),5),20,0),COLORCYAN,LINETHICK1;
D1:=中期>REF(中期,1) AND 短期>REF(短期,1)AND 长期>REF(长期,1)AND 长期<8 AND 中期<10 AND 短期<15;
D2:=CROSS(短期,中期) AND 中期<8;
D3:=CROSS(短期,长期) AND 长期<8 AND 中期<20;
DRAWICON(FILTER((D1 OR D2 OR D3) AND DD<15 AND C>REF(C,1),5),5,1);
{www.gUPaNg.com 股旁网_最新股票指标公式}
DRAWICON(FILTER((中期<REF(中期,1)AND 短期<REF(短期,1)AND 长期<REF(长期,1)AND 中期>95 AND 短期>85)OR (长期>100 AND 中期>100 AND 短期>100),5),95,2);
强弱分界:50,POINTDOT,COLORWHITE;
警戒区:90,LINETHICK1,COLORWHITE;
安全区:20,COLORWHITE;
N:=5; N1:=21;
VAR1:=4*SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1),3.2,1),COLORYELLOW,LINETHICK1;
VAR2:=8,COLORGREEN,LINETHICK0;
小试牛刀: IF(CROSS(VAR1,VAR2),8,0),STICK,COLORRED;
DRAWICON(小试牛刀>0,8,11);
发现庄迹: IF(VAR1<=8,8,0),STICK,COLORCYAN,LINETHICK2;
短线获利:STICKLINE(REF("KDJ.J",1)<0 AND "KDJ.J">0,60,42,1,0),COLORYELLOW;
VARK1:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
VARK2:=REVERSE(VARK1);
VARK3:=SMA(VARK1,3,1);
VAR21:=4*SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1),3.2,1);
VAR22:=8;
SS:=CROSS(VAR21,VAR22);
DRAWTEXT(SS,L*0.98,'●买进!'),COLORYELLOW;

通达信发现庄迹指标公式

 

相关文章