在线检测未来函数

通达信MACD加强版指标公式

来源:Internet,编辑:股旁网,2011-11-17

DIFF: EMA(CLOSE,12)-EMA(CLOSE,27),LINETHICK0,COLOR00FFFF;
DEA: EMA(DIFF,9),LINETHICK0,COLORFF00FF;
MACD:= 2*(DIFF-DEA);
STICKLINE(MACD>=0,MACD,0,4,1),COLORF00FF0;
STICKLINE(MACD<0,MACD,0,4,1),COLORFFFFFF;
STICKLINE(MACD<REF(MACD,1) AND MACD>0,0,MACD,4,0),COLOR00AAFF;
STICKLINE(MACD<REF(MACD,1) AND MACD>0,0,MACD,3.3,0),COLOR00BBFF;
STICKLINE(MACD<REF(MACD,1) AND MACD>0,0,MACD,2.2,0),COLOR00CCFF;
STICKLINE(MACD<REF(MACD,1) AND MACD>0,0,MACD,1.65,0),COLOR00DDFF;
STICKLINE(MACD<REF(MACD,1) AND MACD>0,0,MACD,1.1,0),COLOR00EEFF;
STICKLINE(MACD<REF(MACD,1) AND MACD>0,0,MACD,0.55,0),COLOR00FFFF;
STICKLINE(MACD>=REF(MACD,1) AND MACD>0,0,MACD,4,0),COLOR0000AA;
STICKLINE(MACD>=REF(MACD,1) AND MACD>0,0,MACD,3.3,0),COLOR0011BB;
STICKLINE(MACD>=REF(MACD,1) AND MACD>0,0,MACD,2.2,0),COLOR0022CC;
STICKLINE(MACD>=REF(MACD,1) AND MACD>0,0,MACD,1.65,0),COLOR0033DD;
STICKLINE(MACD>=REF(MACD,1) AND MACD>0,0,MACD,1.1,0),COLOR0044EE;
STICKLINE(MACD>=REF(MACD,1) AND MACD>0,0,MACD,0.55,0),COLOR0055FF;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,4,0),COLORAA00BB;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,3.3,0),COLORBB11BB;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,2.2,0),COLORCC22BB;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,1.65,0),COLORDD33BB;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,1.1,0),COLOREE44BB;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,0.55,0),COLORFF55BB;
STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,4,0),COLORFFAA00;
STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,3.3,0),COLORFFBB11;
STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,2.2,0),COLORFFCC22;
STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,1.65,0),COLORFFDD33;
STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,1.1,0),COLORFFEE44;
STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,0.55,0),COLORFFFF55;
IF(DIFF<0,DIFF,0),COLOR0000FF;
IF(DIFF<0,0,DIFF),COLOR00FFFF;
IF(DIFF<DEA,DIFF,DEA),COLOR00FF00;
IF(DIFF>DEA,DEA,DEA),COLORFFFFFF;
低位金叉:= CROSS(DIFF,DEA) AND DIFF<(-0.1);
STICKLINE(低位金叉,0,-0.18,6,0),COLOR00FFFF;
DRAWTEXT(低位金叉,-0.1,' 低位金叉'),COLOR00FFFF;
JCCOUNT:= COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:= CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
{www.gUPaNg.com 股旁网_最新股票指标公式}
STICKLINE(二次金叉,0,-0.18,6,0),COLORFF00FF;
DRAWICON(二次金叉,DEA*1.04,13),COLOR0000FF;
DRAWTEXT(二次金叉,-0.1,' 二次金叉'),COLORFF00FF;
A1:= BARSLAST(REF(CROSS(DIFF,DEA),1));
背离:= REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
STICKLINE(底背离,0,0.13,6,0),COLOR00FF00;
DRAWLINE(A1=0,DEA,底背离,DEA,0),COLOR0000FF;
DRAWTEXT(底背离,0.1,' 底背离'),COLOR00FF00;
A2:= BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:= REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLOR008000;

通达信MACD加强版指标公式

 

相关文章