在线检测未来函数

通达信买卖密码指标公式

来源:Internet,编辑:股旁网,2011-11-21

JRH:=HHV(C,2);
JRL:=LLV(C,2);
MA3:=MA(CLOSE,3);
YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;
R1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
R2:=(REF(R1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R3:=(REF(R2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R4:=(REF(R3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R5:=(REF(R4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R6:=(REF(R5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R7:=(REF(R6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R8:=(REF(R7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R9:=(REF(R8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
RA:=(REF(R9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
RB:=(REF(RA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
RC:=(REF(RB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
RD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
RE:=(REF(RD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
RF:=(REF(RE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R10:=(REF(RF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R11:=(REF(R10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R12:=(REF(R11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R13:=(REF(R12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R14:=(REF(R13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R15:=(REF(R14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R16:=(REF(R15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R17:=(REF(R16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R18:=(REF(R17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R19:=REF(RD OR RE OR RF OR R10 OR R11 OR R12 OR R13 OR R14 OR R15 OR R16 OR R17 OR R18,1) AND R1;
R1A:=((REF(R1 OR R2 OR R3 OR R4 OR R5 OR R6 OR R7 OR R8 OR R9 OR RA OR RB OR RC,1)) AND RD);
VAR3:=IF(C<200 ,MA(COST(80),3),2500),NODRAW;
VAR4:=(((HIGH + LOW) + CLOSE) / 3);
VAR55:=EMA(((((OPEN + HIGH) + LOW) + CLOSE) / 4),2330);
VAR66:=(VAR55 + ((VAR55 * 6) / 100));
短买春:=R19,NODRAW,COLOR00DD00;
秋离场:=R1A,NODRAW,COLOR2288EE;
持股:=R1 OR R2 OR R3 OR R4 OR R5 OR R6 OR R7 OR R8 OR R9 OR RA OR RB OR RC,NODRAW,COLOR0000FF;
急速超跌关注:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100<-14,COLORBBBBBB,NODRAW;
Q1:=CONST(IF(短买春,0,IF(秋离场,150,IF(红持股,150,IF(急速超跌关注,150,100))))),NODRAW;
Q2:=CONST(IF(短买春,80,IF(秋离场,100,IF(红持股,0,IF(急速超跌关注,150,100))))),NODRAW;
Q3:=CONST(IF(短买春,0,IF(秋离场,20,IF(红持股,70,IF(急速超跌关注,150,100))))),NODRAW;
DD1:=EMA((O+H+L)/3,4)COLORWHITE,NODRAW;
DD2:=EMA(C+(H-L)*0.618,3)COLORYELLOW,NODRAW;
密码1:DD2+(DD2-DD1)*0.618,NODRAW,COLORWHITE;{明卖}
密码2:EMA((O+H+L)/3,4)+((H+L)/2-REF((O+H+L)/3,3))/4,NODRAW;{明买}
密码3:=MA(REF(密码1,1),1)*1,COLORLIMAGENTA,NODRAW;{今卖}
密码4:=REF(密码2,1),COLORLIMAGENTA,NODRAW;{今买}
密码5:=MA(REF(DD2,1),1)*1,COLORLIMAGENTA,NODRAW;{今卖}
密码6:=REF(DD1,1),COLORLIMAGENTA,NODRAW;{今买}
{黄金买点:=EMA((O+H+L)/3,4)COLORWHITE,NODRAW;
黄金卖点:=EMA(C+(H-L)*0.618,3)COLORYELLOW,NODRAW;
预测明日卖点:黄金卖点+(黄金卖点-黄金买点)*0.618,NODRAW,COLORWHITE;
预测明日买点:EMA((O+H+L)/3,4)+((H+L)/2-REF((O+H+L)/3,3))/4,NODRAW;
今卖:MA(REF(预测明日卖点,1),1)*1,COLORLIMAGENTA,NODRAW;
今买:REF(预测明日买点,1),COLORLIMAGENTA,NODRAW;}
{www.gUPaNg.com 股旁网_最新股票指标公式}
换:IF(CAPITAL>0,V/CAPITAL*100,V),NODRAW;
收:=FINANCE(33),NODRAW;
流:FINANCE(7)/100000000,NODRAW;
TT:=IF(ISLASTBAR,240/FROMOPEN,1);
NN:=120;
HH:=HHV(V*TT,NN);
LL:=LLV(V,NN);
最高:=CONST(HH);
最低:=CONST(LL);
RCC:=最高*0.9-(最高-最低)*0.5;
RHL:=RCC;
HLMAX:=最高;
HLMIN:=最低;
HLMN1:=(HLMAX+HLMIN)/2;
HLMN2:=HLMAX-HLMIN;
HLMN3:=(100-0)/2*1.3;
HLMN4:=(100-0)/1*1.3;
P:=最高/120;
{顶底摸块}
神:=2*SMA(V*((C+L)/2+(H+C)/2+L)/3,2,1)/SMA(V,2,1)-(3*HHV(SMA(V*((C+L)/2+(H+C)/2+L)/3,2,1)/SMA(V,2,1),2)-2*SMA(V*((C+L)/2+(H+C)/2+L)/3,2,1)/SMA(V,2,1));
奇:=(2*神+EMA((2*(C+L)/2+(H+C)/2+L+O)/5,2)+2*((EMA((C*2+H+L+O)/5,5)+MA((C*2+H+L+O)/5,13)+MA((C*2+H+L+O)/5,21))/3)+((EMA
((C*2+H+L+O)/5,13)+MA((C*2+H+L+O)/5,21)+MA((C*2+H+L+O)/5,34))/3)+((EMA((C*2+H+L+O)/5,21)+MA((C*2+H+L+O)/5,34)+MA((C*2+H+L+O)/5,55))/3))/7;
分清:=(FORCAST(HHV((C+L)/2,1),21)+(EMA(((C+L)/2+L+(H+C)/2)/3,55)-(C-EMA(((C+L)/2+L+(H+C)/2)/3,55))))/2;
放心买入:=(((C+L)/2+(H+C)/2+L)/3+(3*(C+H+L+(O+C+L)/3)/4-2*(C+L)/2))/2;
强:=(EMA((分清+3*((EMA(放心买入,5)*5+分清)/6+((EMA(奇,5)+EMA(奇,8)+EMA(奇,13))/3))/2)/4,3)/3),POINTDOT,COLOR00FFFF;
验证:=((((C+L)/2-LLV(L,24))/(HHV((H+C)/2,24)-LLV(L,24))*1.1*(C+L)/2));
续持验证:=EMA((2*(5*((EMA((2*C+L)/3,2)-EMA((2*C+H)/3,5))
-EMA((EMA((2*C+L)/3,2)-EMA((2*C+H)/3,5)),21)))
+(((C*2+H)/3+(C*2+H)/3)/2)+EMA(验证,2))/4,2),COLOR555555;
AR:=(2*(C+L)/2+REF((C+L)/2,1))/3;
BR:=(7*(C+L)/2+6*REF((C+L)/2,1)+5*REF((C+L)/2,2)
+4*REF((C+L)/2,3)+3*REF((C+L)/2,4)
+2*REF((C+L)/2,5)+REF((C+L)/2,6))/28;
VARA2:=LLV(MA(LOW,3),3);
VARA3:=HHV(MA(HIGH,3),3);
比:=TT;
昨V:=REF(V,1);
T:=IF(ISLASTBAR,IF(FROMOPEN>60,IF(FROMOPEN-INTPART(FROMOPEN/60)*60=0,1,
60/(FROMOPEN-INTPART(FROMOPEN/60)*60)),60/FROMOPEN),1);
WJ:=(H+L+C)/3;
V1:=IF(H=L,1,H-MAX(O,C));
V2:=IF(H=L,1,MAX(C,O)-WJ);
V3:=IF(H=L,1,MIN(O,C)-L);
V4:=IF(H=L,1,WJ-MIN(C,O));
V5:=VOL/IF(H=L,4,H-L);
V6:=(V1*V5);
V7:=(V2*V5);
V8:=(V3*V5);
V9:=(V4*V5);
买盘1:=DYNAINFO(23)*比;
卖盘1:=DYNAINFO(22)*比;
买盘2:=IF(ISLASTBAR AND C>300,(V9+V8)*TT,(V9+V8));
卖盘2:=IF(ISLASTBAR AND C>300,(V6+V7)*TT,(V6+V7));
买盘:=IF(ISLASTBAR AND PERIOD=5 AND C<300,买盘1,买盘2);
卖盘:=IF(ISLASTBAR AND PERIOD=5 AND C<300,卖盘1,卖盘2);
DRAWBAND(最高,RGB(Q1,Q2,Q3),0,DRAWNULL);
买卖差:=买盘-卖盘;
STICKLINE(C>=O,0,买盘+卖盘,2.8,1),COLORRED;
STICKLINE(C<O,0,买盘+卖盘,2.8,1),COLORFFFF00;
STICKLINE(买卖差>=0,0,买盘,2.5,0),COLORRED;
STICKLINE(买卖差>=0 AND C>=MA(C,30),0,买盘,3.0,0),COLORRED;
STICKLINE(买卖差>=0,0,卖盘,1.1,0),COLOR998800;
STICKLINE(买卖差>=0 AND C>=MA(C,30),0,卖盘,1.5,0),COLORDDCC00;
STICKLINE(买卖差<0,0,买盘,2.5,0),COLORRED;
STICKLINE(买卖差<0 AND C>=MA(C,30),0,买盘,3.0,0),COLORRED;
STICKLINE(买卖差<0,0,卖盘,1.1,0),COLOR998800;
STICKLINE(买卖差<0 AND C>=MA(C,30),0,卖盘,1.5,0),COLORDDCC00;
A1:=REF(CLOSE,1);
B1:=(买盘+卖盘)<MA(V,60)/3 ;
{B1:=V<MA(V,60)/3 ;}
B2:=MA(V,5)/2>V AND V>B1;
STICKLINE(B1,0,卖盘,2,0),COLORYELLOW;
((80-HLMN3)*HLMN2/HLMN4+HLMN1),COLORCCCCCC,LINETHICK1,DOTLINE;
((50-HLMN3)*HLMN2/HLMN4+HLMN1),COLORCCCCCC,LINETHICK1,DOTLINE;
((20-HLMN3)*HLMN2/HLMN4+HLMN1),COLORCCCCCC,LINETHICK1,DOTLINE;
KA:=(EMA((CLOSE-VARA2)/(VARA3-VARA2)*100,4)-50)*0.5+50;
DB:=EMA(0.667*REF(KA,1)+0.333*KA,2);
JJ:=3*KA-2*DB;
((KA-HLMN3)*HLMN2/HLMN4+HLMN1),COLORFFF111,LINETHICK1;
((DB-HLMN3)*HLMN2/HLMN4+HLMN1),COLOR00FF00,LINETHICK1;
((JJ-HLMN3)*HLMN2/HLMN4+HLMN1),COLORFF00FF,LINETHICK1;
IF(续持验证<强,-5*P,DRAWNULL),CIRCLEDOT,COLORYELLOW,LINETHICK1;
IF(续持验证>=强,-5*P,DRAWNULL),CIRCLEDOT,COLORRED,LINETHICK1;
IF(续持验证>= REF(续持验证,1),-10*P,DRAWNULL),CIRCLEDOT,COLORRED,LINETHICK1;
IF(续持验证< REF(续持验证,1),-10*P,DRAWNULL),CIRCLEDOT,COLORYELLOW,LINETHICK1;
STICKLINE(1,HLMAX,HLMAX*0.96,3,0),COLORGREEN;
红灯买:STICKLINE(密码1>密码3,HLMAX,HLMAX*0.96,3,0),COLORRED;
STICKLINE(1,HLMAX*0.98,HLMAX*0.98,3,0),COLORWHITE;
STICKLINE(1,HLMAX*0.93,HLMAX*0.89,3,0),COLORRED;
绿灯卖:STICKLINE(密码2<=密码4,HLMAX*0.93,HLMAX*0.89,3,0),COLORGREEN;
STICKLINE(1,HLMAX*0.91,HLMAX*0.91,3,0),COLORWHITE;
操作段1:STICKLINE(密码1>(密码3) AND C>密码2 OR 密码2>密码4,HLMAX*0.82,HLMAX*0.86,3,0),COLORRED;
操作段2:STICKLINE(C>密码2 AND 密码1>密码3,HLMAX*0.82,HLMAX*0.86,3,0),COLORMAGENTA;
操作段3:STICKLINE(密码1<密码3 AND 密码2>密码4,HLMAX*0.82,HLMAX*0.86,3,0),COLORYELLOW;
STICKLINE(密码1>(密码3) AND C>密码2 OR 密码2>密码4 OR C>密码2 AND 密码1>密码3,HLMAX*0.84,HLMAX*0.84,3,0),COLORWHITE;

通达信买卖密码指标公式

 

相关文章