在线检测未来函数

飞狐精品划线波浪趋势主图指标公式

来源:Internet,编辑:股旁网,2011-11-27

input:N(10,1,88);
V1:=ISLASTBAR;
V2:=REF(HIGH,N)=HHV(HIGH,2*N+1);
V3:=FILTER(V2,N);
V4:=BACKSET(V3,N+1);
V5:=FILTER(V4,N);
V6:=V5 OR V1;
V7:=REF(LOW,N)=LLV(LOW,2*N+1);
V8:=FILTER(V7,N);
V9:=BACKSET(V8,N+1);
VA:=FILTER(V9,N);
VB:=VA AND NOT(V5);
VC:=BACKSET(V6,REF(BARSLAST(VB),1)+1);
VD:=VC>REF(VC,1);
VE:=BACKSET(VD,2);
VF:=VE>REF(VE,1);
V10:=BACKSET(VF AND COUNT(V6,REF(BARSLAST(VB),1)+2)=0,REF(BARSLAST(VB),1)+2);
V11:=V10>REF(V10,1);
V12:=BACKSET(V11 AND COUNT(V6,REF(BARSLAST(VB),1)+2)=0,REF(BARSLAST(VB),1)+2);
V13:=V12>REF(V12,1);
V14:=IF(V6,COUNT(VB,REF(BARSLAST(V6),1)+1),0);
V15:=IF(V14=1 AND V6,BARSLAST(VF),0);
V16:=IF(V6 AND REF(LOW,BARSLAST(VF))>=REF(LOW,BARSLAST(V11)),BARSLAST(V11),BARSLAST(VF));
V17:=IF(V14=2 AND V6,V16,0);
V18:=IF(V14>=3 AND V6,IF(V6 AND REF(LOW,V16)>=REF(LOW,BARSLAST(V13)),BARSLAST(V13),V16),0);
V19:=V15+V17+V18;
V1A:=BACKSET(V6,V19);
V1B:=V1A>REF(V1A,1);
V1C:=BACKSET(V1B,2);
V1D:=V1C>REF(V1C,1);
V1E:=V1D OR V1;
V1F:=BACKSET(V1E,REF(BARSLAST(V6),1)+1);
V20:=V1F>REF(V1F,1);
V21:=BACKSET(V20,2);
V22:=V21>REF(V21,1);
V23:=BACKSET(V22 AND COUNT(V1E,REF(BARSLAST(V6),1)+2)=0,REF(BARSLAST(V6),1)+2);
V24:=V23>REF(V23,1);
V25:=BACKSET(V24 AND COUNT(V1E,REF(BARSLAST(V6),1)+2)=0,REF(BARSLAST(V6),1)+2);
V26:=V25>REF(V25,1);
V27:=IF(V1E,COUNT(V5,REF(BARSLAST(V1E),1)+1),0);
V28:=IF(V27=1 AND V1E,BARSLAST(V22),0);
V29:=IF(V1E AND REF(HIGH,BARSLAST(V22))<=REF(HIGH,BARSLAST(V24)),BARSLAST(V24),BARSLAST(V22));
V2A:=IF(V27=2 AND V1E,V29,0);
V2B:=IF(V27>=3 AND V1E,IF(V1E AND REF(HIGH,V29)<=REF(HIGH,BARSLAST(V26)),BARSLAST(V26),V29),0);
V2C:=V28+V2A+V2B;
V2D:=BACKSET(V1E,V2C);
V2E:=V2D>REF(V2D,1);
V2F:=BACKSET(V2E,2);
V30:=V2F>REF(V2F,1);
DRAWLINE(V1D,LOW,V30,HIGH,0);
DRAWLINE(V30,HIGH,V1D,LOW,0);
V31:=BACKSET(V1,BARSLAST(V1D)+1);
V32:=V31>REF(V31,1);
V33:=BACKSET(V1,BARSLAST(V30)+1);
V34:=V33>REF(V33,1);
V35:=IF(BARSLAST(V32)<BARSLAST(V34),V32,V34);
V36:=IF(BARSLAST(V32)<BARSLAST(V34),LOW,HIGH);
DRAWLINE(V35,V36,V1,CLOSE,0);
V37:=BACKSET(V1,BARSLAST(V1D)+1);
V38:=V37>REF(V37,1);
V39:=BACKSET(V38,REF(BARSLAST(V1D),1)+2);
V3A:=V39>REF(V39,1);
DRAWLINE(V3A,LOW,V38,LOW,1);
V3B:=BACKSET(V1,BARSLAST(V30)+1);
V3C:=V3B>REF(V3B,1);
V3D:=BACKSET(V3C,REF(BARSLAST(V30),1)+2);
V3E:=V3D>REF(V3D,1);
DRAWLINE(V3E,HIGH,V3C,HIGH,1);
{www.gUPaNg.com 股旁网_最新股票指标公式}
前一低: REF(LOW,BARSLAST(V38)),colorccff99,LINEDOT;
前二低: REF(LOW,BARSLAST(V3A)),colormagenta,LINEDOT;
前一高: REF(HIGH,BARSLAST(V3C)),colorccff99;
前二高: REF(HIGH,BARSLAST(V3E)),colormagenta;
{以下语句是大盘指数显示}
A1:=REF(HIGH,3)=HHV(HIGH,2*3+1); B1:=FILTER(A1,3); C1:=BACKSET(B1,3+1); D1:=FILTER(C1,3);{高点}
A2:=REF(LOW,3)=LLV(LOW,2*3+1); B2:=FILTER(A2,3); C2:=BACKSET(B2,3+1); D2:=FILTER(C2,3);{低点}
E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2; E2:=(HIGH+LOW)/2;{高低点出现在同一K线上时可作取舍}
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
L1:=(D2 AND NOT(D1 AND E1<E2)); H2:=D1 AND NOT(D2 AND E1>=E2);
X1:=REF(BARSLAST(H1),1)+1; F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));
G1:=F1>REF(F1,1); I1:=BACKSET(G1,2); LD:=I1>REF(I1,1);{过滤后低点}
L2:=LD OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
X2:=REF(BARSLAST(L2),1)+1; F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));
G2:=F2>REF(F2,1); I2:=BACKSET(G2,2); HD:=I2>REF(I2,1);{过滤后高点}
UU:=BACKSET(ISLASTBAR,BARSLAST(LD)+1);
VV:=UU>REF(UU,1);
WW:=BACKSET(VV,REF(BARSLAST(LD),1)+2);
XX:=WW>REF(WW,1);
常数1:=REF(INDEXC,BARSLAST(VV))/REF(CLOSE,BARSLAST(VV));
常数2:=REF(INDEXC,BARSLAST(XX))/REF(CLOSE,BARSLAST(XX));
DRAWNUMBER(HD,HIGH*(1+0.002),HIGH,2),COLORff,ALIGN0;
DRAWNUMBER(LD,LOW*(1.001-0.002),LOW,2),COLORff00,ALIGN0;

飞狐精品划线波浪趋势主图指标公式

 

相关文章