在线检测未来函数

大智慧顶低买卖指标公式

来源:Internet,编辑:股旁网,2011-11-29

N:=2;
LC:=REF(CLOSE,1);
VAR1:=SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-LC)),ABS(LOW-LC)),14,1);
VAR2:=HIGH-REF(HIGH,1);
VAR3:=REF(LOW,1)-LOW;
VAR4:=SMA(IF(VAR2>0 AND VAR2>VAR3,VAR2,0),12,1);
VAR5:=SMA(IF(VAR3>0 AND VAR3>VAR2,VAR3,0),12,1);
VAR6:=VAR4*100/VAR1;
VAR7:=VAR5*100/VAR1;
VAR8:=SMA(ABS(VAR7-VAR6)/(VAR7+VAR6)*100,12,1);
VAR9:=(VAR8+REF(VAR8,5))/2;
VARC:=AMOUNT/VOL/100;
VARD:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
VARE:=SUM(AMOUNT,5)/VARC/100;
VARF:=SUM(AMOUNT,13)/VARC/100;
VAR10:=SUM(AMOUNT,34)/VARC/100;
VAR11:=SUM(AMOUNT,209)/VARC/100;
VAR12:=REF(VOL,1)+REF(VOL,2)+REF(VOL,3)+REF(VOL,4);
VAR13:=VAR12/CAPITAL;
VAR14:=VOL/CAPITAL*VARD+VAR13*REF(VARC,1);
VAR15:=DMA(VARD,VOL/VARE);
VAR16:=DMA(VARD,VOL/VARF);
VAR17:=DMA(VARD,VOL/VAR10);
VAR18:=DMA(VARD,VOL/CAPITAL);
VAR19:=MA(HHV(HIGH,488),18);
VAR1A:=MA(HHV(HIGH,220),18);
VAR1B:=MA(HHV(HIGH,98),18);
VAR1C:=MA(LLV(LOW,488),18);
VAR1D:=MA(LLV(LOW,220),18);
VAR1E:=MA(LLV(LOW,98),18);
VAR1F:=MA((VAR1C*0.96+VAR1D*0.96+VAR1E*0.96+VAR19*0.558+VAR1A*0.558+VAR1B*0.558)/6,18);
VAR20:=MA((VAR1C*1.25+VAR1D*1.23+VAR1E*1.2+VAR19*0.55+VAR1A*0.55+VAR1B*0.65)/6,18);
VAR21:=MA((VAR1C*1.3+VAR1D*1.3+VAR1E*1.3+VAR19*0.68+VAR1A*0.68+VAR1B*0.68)/6,18);
VAR22:=MA((VAR1F*3+VAR20*2+VAR21)/6*1.738,18);
VAR25:=REF(LOW,1);
VAR26:=SMA(ABS(LOW-VAR25),3,1)/SMA(MAX(LOW-VAR25,0),3,1)*100;
VAR27:=MA(IF(CLOSE*1.35<=VAR22,VAR26*10,VAR26/10),3);
VAR29:=HHV(VAR27,30);
VAR2A:=IF(LOW=LLV(LOW,30),(VAR27+VAR29*2)/2,0);
JD1:=VAR2A>20000 AND CLOSE<COST(1);
JD2:=(CLOSE-VAR16)/VAR16*100<N-13;
STICKLINE(JD1,0.1,0.3,4.6,0),COLOR00CC99;
STICKLINE(JD2,0,0.1,4.6,0),COLORWHITE;
STICKLINE(JD1 AND JD2,0.3,0.7,4.5,0),COLOR00FF00;
{www.gUPaNg.com 股旁网_最新股票指标公式}
QS1:=SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1);
趋势:EMA(3*QS1-2*SMA(QS1,3,1),5)/100,LINETHICK2;
圣指:IF((REF(CLOSE,13)-CLOSE)/REF(CLOSE,13)*100>15 AND SUM(VOL/CAPITAL,13)*100<18 AND VOL/CAPITAL*100<2.5 AND (LC-CLOSE)/LC*100<8,0.8,0.1),COLORFFCC99;{金指63}
V2:=(CLOSE-LC)/LC*100;
V3:=MA(VOL,2)/MA(VOL,10);
V4:=VOL/CAPITAL;
TCT:=0.015*V2-0.124*V3+17.5*V4;
TCT1:=HHV(TCT,250)-0.4;
量能:IF(TCT>TCT1,TCT1-TCT+1,1),COLORYELLOW;
DRAWICON(FILTER(0.0015*V2-0.0124*V3+1.7461*V4>0.148,10),0.6,3);
买:FILTER(-0.08473268*V2+0.10052872*V3+5.20138076*V4+0.45692105<0,3)*0.8,LINETHICK2,COLORFF00FF;
B1:=(CLOSE-MA(CLOSE,27))/MA(CLOSE,27)<-0.16;
品股:B1*0.5,COLORRED;
STICKLINE(B1,0.15,0.5,3.5,0),COLORRED;
金品:FILTER(圣指=0.8 AND B1 AND JD1 AND JD2,2);
STICKLINE(金品,0,1,6,0),COLORRED;

大智慧顶低买卖指标公式

 

相关文章