在线检测未来函数

通达信五里头量能指标公式

来源:Internet,编辑:股旁网,2011-11-30

N:=15;
M1:=5;M2:=10;M3:=20;M4:=60;
SAT:=IF((AMOUNT/C)/(HHV(AMOUNT,N)/HHV(C,N))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,N)/HHV(C,N))*100);
能量:=SAT,VOLSTICK;
DRAWTEXT(FILTER(SAT>=100,100),VOL*1.06,'爆'),COLORRED;
DRAWTEXT(SAT=100 AND ISLASTBAR,VOL*1.03,'发'),COLORYELLOW;
VAR1:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
成交:=VOL;
买盘:=IF((CLOSE > OPEN),(VAR1 * (HIGH - LOW)),IF((CLOSE < OPEN),(VAR1 *
((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2)));
卖盘:=IF((CLOSE > OPEN),(0 - (VAR1 * ((HIGH - CLOSE) +
(OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (VAR1 * (HIGH - LOW))),
(0 - (VOL / 2))));
买卖差:=(买盘 + 卖盘);
STICKLINE((买卖差 < 0),0,买卖差,3,0),LINETHICK3,COLOR339933;
STICKLINE((买卖差 < 0),0,买卖差,2,0),LINETHICK3,COLOR33AA33;
STICKLINE((买卖差 < 0),0,买卖差,1,0),LINETHICK3,COLOR33DD33;
STICKLINE((买卖差 < 0),0,买卖差,0.5,0),LINETHICK3,COLOR33FF33;
量比1:=(VOL / MA(VOL,5));
VAR10:=买盘;
VAR20:=卖盘;
JX1:=BARSSINCE(买盘);
JY1:=IF(((121 > JX1) AND (JX1 > 0)),JX1,120);
JY2:=IF(((4 > JX1) AND (JX1 > 0)),JX1,3);
VAR30:=MA(VOL,JY2);
动神:=买盘;
鬼力:=VAR20;
神比:=(动神 / VAR30);
鬼比:=(鬼力 / VAR30);
VAR2:=(HIGH - LOW);
VAR3:=ABS((OPEN - CLOSE));
VAR4:=(HIGH - IF((CLOSE > OPEN),CLOSE,OPEN));
VAR5:=(IF((CLOSE > OPEN),OPEN,CLOSE) - LOW);
VAR6:=((VAR3 / VAR2) * VOL);
VAR7:=((VAR4 / VAR2) * VOL);
VAR8:=((VAR5 / VAR2) * VOL);
VAR9:=IF(((VOL / CAPITAL) > 0.001),1,EXP(ABS(LOG(((VOL / CAPITAL) * 100)))));
{www.gUPaNg.com 股旁网_最新股票指标公式}
VARA:=(((CLOSE - MA(CLOSE,5)) / MA(CLOSE,5)) * 100);
VARB:=(((MA(CLOSE,5) > MA(CLOSE,10)) AND (MA(CLOSE,10) > MA(CLOSE,30))) AND (MA(CLOSE,30) > MA(CLOSE,60)));
VARC:=((MA(CLOSE,5) < MA(CLOSE,10)) AND (MA(CLOSE,10) < MA(CLOSE,30)));
VARD:=REF(CLOSE,1);
VARE:=((SMA(MAX((CLOSE - VARD),0),6,1) / SMA(ABS((CLOSE - VARD)),6,1)) * 100);
VAR40:=((IF((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)),VAR6,动神) + 动神) / 2);
VAR41:=((IF(((VAR7 > VAR6) AND (VAR7 > VAR8)),VAR7,动神) + 动神) / 2);
VAR42:=((IF(((VAR8 > VAR6) AND (VAR8 > VAR7)),VAR8,动神) + 动神) / 2);
VAR50:=((IF((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE < OPEN)),VAR6,鬼力) + 鬼力) / 2);
三日上攻:=MA((((VAR40 + VAR41) + VAR42) / 3),JY2);
三日下攻:=MA(VAR50,JY2);
多头:STICKLINE((CLOSE > MA(CLOSE,30)),0,VOL,3,0),COLOR000088;
STICKLINE((CLOSE > MA(CLOSE,30)),0,VOL,2,0),COLOR0000AA;
STICKLINE((CLOSE > MA(CLOSE,30)),0,VOL,1,0),COLOR0000DD;
STICKLINE((CLOSE > MA(CLOSE,30)),0,VOL,0.5,0),COLOR0000FF;
空头:STICKLINE((CLOSE < MA(CLOSE,30)),0,VOL,3,0),COLOR008800;
STICKLINE((CLOSE < MA(CLOSE,30)),0,VOL,2,0),COLOR00AA00;
STICKLINE((CLOSE < MA(CLOSE,30)),0,VOL,1,0),COLOR00DD00;
STICKLINE((CLOSE < MA(CLOSE,30)),0,VOL,0.5,0),COLOR00FF00;
STICKLINE((鬼力 > 0),鬼力,0,4,0),COLORFF3399;
加仓:STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8))
AND (CLOSE > OPEN)),0,VAR6,3,0),COLOR880088;
STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8))
AND (CLOSE > OPEN)),0,VAR6,2,0),COLORAA00AA;
STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8))
AND (CLOSE > OPEN)),0,VAR6,1,0),COLORDD00DD;
STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8))
AND (CLOSE > OPEN)),0,VAR6,0.5,0),COLORFF00FF;
减仓:STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8))
AND (CLOSE < OPEN)),0,VAR6,3,0),COLOR880000;
STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8))
AND (CLOSE < OPEN)),0,VAR6,2,0),COLORBB0000;
STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8))
AND (CLOSE < OPEN)),0,VAR6,1,0),COLORDD0000;
STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8))
AND (CLOSE < OPEN)),0,VAR6,0.5,0),COLORFF0000;
洗盘:STICKLINE(((VAR8 > VAR6) AND (VAR8 > VAR7)),0,VAR8,3,0),COLOR999999;
STICKLINE(((VAR8 > VAR6) AND (VAR8 > VAR7)),0,VAR8,2,0),COLORAAAAAA;
STICKLINE(((VAR8 > VAR6) AND (VAR8 > VAR7)),0,VAR8,1,0),COLORDDDDDD;
STICKLINE(((VAR8 > VAR6) AND (VAR8 > VAR7)),0,VAR8,0.6,0),COLORFFFFFF;
高卖:STICKLINE(((VAR7 > VAR6) AND (VAR7 > VAR8)),0,VAR7,3,0),COLOR008888;
STICKLINE(((VAR7 > VAR6) AND (VAR7 > VAR8)),0,VAR7,2,0),COLOR00AAAA;
STICKLINE(((VAR7 > VAR6) AND (VAR7 > VAR8)),0,VAR7,1,0),COLOR00DDDD;
STICKLINE(((VAR7 > VAR6) AND (VAR7 > VAR8)),0,VAR7,0.5,0),COLOR00FFFF;
相对地量:=STICKLINE(((VAR9 > 2) AND (VOL < (MA(VOL,5) / 2))),0,VOL,3,0);
白进:1,LINETHICK0,COLORWHITE;
黄警:1,NODRAW,COLOR00FFFF;
粉追:2,NODRAW,COLORFF00FF;
兰绿卖:3,NODRAW,COLOR00FF00;
MAV1:MA(V,M1),LINETHICK1,COLOR00FFFF;
MAV2:=MA(V,M2),LINETHICK1,COLORFF00FF;
IF(MA(V,5)>=REF(MA(V,5),1),MA(V,5),DRAWNULL),COLORRED,LINETHICK2;

通达信五里头量能指标公式

 

相关文章