在线检测未来函数

通达信多功能VOL指标公式

来源:Internet,编辑:股旁网,2011-11-30

股价趋势:= 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
底部警戒:=10,COLORRED,LINETHICK2;
底1:=CROSS(股价趋势,底部警戒);
A1:=(2*CLOSE+HIGH+LOW)/4;
A2:=LLV(LOW,27);
A3:=HHV(HIGH,27);
A4:=EMA((A1-A2)/(A3-A2)*100,13);
A5:=EMA(0.618*REF(A4,1)+0.382*A4,3);
底2:=CROSS(A4,A5) AND A4<16;
波底:=底1 AND 底2;
{牛年奔牛}
VAR2:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR3:=SMA(SMA(VAR2,3,1),3,1)/28.57;
VAR4:=EMA(VAR3,5);
VAR5:=3*VAR3-2*VAR4;
牛:=CROSS(VAR5,VAR3) AND VAR3<2.1 AND C>O;
{逃顶提示}
VARA2:=LLV(LOW,10);
VARA3:=HHV(HIGH,25);
动力线:= EMA((CLOSE-VARA2)/(VARA3-VARA2)*4,4);
{突破与破位}
N:=19;
VARB1:=HHV(HIGH,N);
VARB2:=LLV(LOW,N);
阻力线:=EMA((CLOSE-VARB2)/(VARB1-VARB2),21)-0.5;
操作线:=EMA((CLOSE-VARB2)/(VARB1-VARB2),5)-0.5;
突破:=CROSS(操作线,阻力线) AND 阻力线<0.1;
破位:=CROSS(阻力线,操作线) AND 阻力线>0.25;
{立桩成立判断}
V2:=IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1);
T12:=V2>=1;
T0:=BARSLAST(T12);
L1:=REF(L,T0);
H1:=REF(H,T0);
L11:=MIN(REF(L,1),L);
L10:=MIN(L11,REF(L,2));
L21:=MAX(REF(L,1),L);
L20:=MAX(L21,REF(L,2));
T111:=(REF(V2>=1,3) OR REF(V2>=1,2) OR REF(V2>=1,1)) AND
((L10>L1 AND L20>H1) OR (L11>L1 AND L21>H1) OR (L>H1));
T11:=T111 AND REF(T111,1)=0;
{涨跌停}
C3:=REF(C,1);
涨停:=IF((C-C3)*100/C3>=(10-0.01*100/C3),1,0);
跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0);
{顶背离与底背离}
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
顶背离:=CROSS(88,RSI);
底背离:=CROSS(FF,MA15);
{45度攻击}
X1:=(3*C+L+H+O)/6;
BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;
EMA8:=EMA(C,8);
T1:=FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10);
{获利盘提示}
获利盘:=WINNER(C)*100;
{彩色成交量柱线}
VOLUME:VOL,VOLSTICK;
MAVOL1:MA(VOLUME,5),COLORWHITE;
MAVOL2:MA(VOLUME,35),COLORYELLOW;MAVOL3:MA(VOLUME,135),COLORGREEN;
{V2:IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1),NODRAW,COLORRED;}
STICKLINE(V2>=1,0,VOL*0.5,2,0),COLORYELLOW;
STICKLINE(动力线>=3.2,0,VOL,1,0),COLOR238E23;
STICKLINE(波底,0,VOL,2,0),COLORMAGENTA;
DRAWTEXT(波底,VOL*0.8,'底'),COLORWHITE;
{www.gUPaNg.com 股旁网_最新股票指标公式}
DRAWICON(波底,VOL*1.1,5);
STICKLINE(牛,0,VOL,2,0),COLORRED;
DRAWTEXT(牛,VOL*1.15,'牛'),COLORWHITE;
STICKLINE(突破,0,VOL,1,0),COLORBLUE;
DRAWTEXT(突破,VOL*0.5,'突破'),COLORWHITE;
DRAWICON(突破,VOL*1.2,1);
STICKLINE(破位,0,VOL,0.5,0),COLORBROWN;
DRAWTEXT(破位,VOL*0.5,'破位'),COLORWHITE;
DRAWICON(破位,VOL*1.05,2);
STICKLINE(T11,O,VOL,2,0),COLORFF00FF;
STICKLINE(涨停,VOL*0.5,VOL,2.5,0),COLORLIRED;
STICKLINE(涨停,VOL*0.5,VOL,0,0),COLORRED;
STICKLINE(跌停,VOL*0.5,VOL,2.5,0),COLOR2F4F2F;
STICKLINE(跌停,VOL*0.5,VOL,0,0),COLORBLACK;
STICKLINE(顶背离,VOL*0.8,VOL,2.5,0),COLORGREEN;
STICKLINE(底背离,0,VOL*0.2,3,0),COLOR7F017F;
DRAWTEXT(T1,VOL*1.1,'∠45'),COLOR00F3F5;
DRAWTEXT(获利盘>=90 AND 动力线>=3.2,VOL*1.1,'获利90●'),COLORRED;
DRAWTEXT(获利盘<75 AND 动力线>=3.2,VOL*1.1,'●'),COLORGREEN;
VAR1:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;
DRAWTEXT(CROSS(82,VARR1) OR CROSS(82,RSI),VOL*1.2,'逃'),COLOR22FF33;
F:=(EMA(CLOSE,5)-EMA(CLOSE,21))*4;
A:=EMA(F,5);
MMD:=2*(F-A);
{STICKLINE(MMD>0,0,MMD,1,1),COLOR0000FF;
STICKLINE(MMD<0,0,MMD,1,1),COLOR00FF00;}
短DIF:F,COLORFFFFFF;
短DEA:A,COLOR00FFFF;
DRAWICON(CROSS(短DIF,短DEA) AND 短DIF<=0.08,短DIF,1);
DRAWICON(CROSS(短DEA,短DIF) AND 短DIF>=0.09,短DEA*1.05,2);
MA13:MA(C,4),COLOR0000FF,LINETHICK3;
VAR10:=C=HHV(C,4) AND REF(C,1)=LLV(C,4);
VAR20:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)=HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND C<REF(C,1) AND C<REF(C,2);
VAR30:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
VAR40:=(20*X1+19*REF(X1,1)+18*REF(X1,2)+17*REF(X1,3)+16*REF(X1,4)+15*REF(X1,5)+
14*REF(X1,6)+13*REF(X1,7)+12*REF(X1,8)+11*REF(X1,9)+10*REF(X1,10)+9*REF(X1,11)+8*REF(X1,12)
+7*REF(X1,13)+6*REF(X1,14)+5*REF(X1,15)+4*REF(X1,16)+3*REF(X1,17)+2*REF(X1,18)+REF(X1,20))/210;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
CB:=EMA(VAR40,13);
{VAR5:=C>REF(C,1)*1.08;}
MA130:MA(VOL,13),COLORE011FF,LINETHICK3;
变异:IF(MA(X1,13)>MA(X1,5),MA(VOL,13),DRAWNULL),COLOR00FF00,LINETHICK3;
卖:=HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX);
DRAWTEXT(FILTER(卖=1,1),VOL*1.02,'卖'),COLORGREEN;
买:=LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2));
DRAWTEXT(FILTER(买=1,5),VOL*1.13,'买'),COLORRED;
加仓:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;
DRAWTEXT(FILTER((CROSS(加仓,0) OR CROSS(CLOSE,CB)) AND 买=1,3),VOL*1.05,'加'),COLORWHITE;
跟:=MA(X1,18)>=REF(MA(X1,18),3) AND CROSS(CLOSE,MA(X1,18));
DRAWTEXT(跟,VOL*1.06,'跟'),COLORCC66FF;

通达信多功能VOL指标公式

 

相关文章