在线检测未来函数

通达信乖离率+MACD指标公式

来源:Internet,编辑:股旁网,2011-12-07

DIF:(EMA(CLOSE,12) - EMA(CLOSE,26)),COLORRED,NODRAW;
DEA:EMA(DIF,9),COLOR00FFFF,NODRAW;
MACD:8*(DIF-DEA),NODRAW;
GLM:COST(50)-COST(20),COLORRED,LINETHICK0;
GL50:EMA(C-COST(50),5),COLOR00FFFF,LINETHICK0;
GL20:EMA(C-COST(20),5),COLORFF00FF,LINETHICK0;
DRAWBAND(GLM,RGB(60,60,60),0,RGB(60,60,60));
DRAWBAND(GL20,RGB(100,40,100),GLM,RGB(30,100,30));
STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,1.8,0),COLOR000055;
STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,1.1,0),COLOR000099;
STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,0.6,0),COLOR0000BB;
STICKLINE(MACD<=REF(MACD,1) AND MACD>0,0,MACD,1.8,0),COLOR888888;
STICKLINE(MACD<=REF(MACD,1) AND MACD>0,0,MACD,1.1,0),COLORBBBBBB;
STICKLINE(MACD<=REF(MACD,1) AND MACD>0,0,MACD,0.6,0),COLORDDDDDD;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,1.8,0),COLOR3377AA;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,1.1,0),COLOR3388BB;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,0.6,0),COLOR4499CC;
STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,1.8,0),COLORFF3300;
STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,1.1,0),COLORFF5500;
STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,0.6,0),COLORFF7700;
{www.gUPaNg.com 股旁网_最新股票指标公式}
IF(C,0,DRAWNULL),COLORRED,LINETHICK2;
IF(DIF>0 AND MACD<=0,0,DRAWNULL),COLORFFFFFF,LINETHICK2;
IF(DIF<=0 AND MACD>0,0,DRAWNULL),COLORFF09FF,LINETHICK2;
IF(DIF<=0 AND MACD<=0,0,DRAWNULL),COLORBBB000,LINETHICK2;
GLM,COLORRED,LINETHICK1;
IF(GLM<REF(GLM,1),GLM,DRAWNULL),COLOR00FF00;
STICKLINE(CROSS(GL20,GLM),GLM*2,GLM,2,0),COLORFF00FF;
GL50,COLOR00FFFF,LINETHICK1;
GL20,COLORFF00FF,LINETHICK1;
IF(GL50<=REF(GL50,1),GL50,DRAWNULL),COLORBB0000;
IF(GL20<=REF(GL20,1),GL20,DRAWNULL),COLORFFF000;

通达信乖离率+MACD指标公式

 

相关文章