在线检测未来函数

通达信主控K线主图指标公式

来源:Internet,编辑:股旁网,2011-12-07

N1:=6;
N2:=16;
N3:=34;
N4:=60;
启动:EMA(C,N1),COLORWHITE,LINETHICK1;
持股线:EMA(C,N2),COLORYELLOW;
牛熊线:EMA(MA(CLOSE,3),N3),COLORRED;
长期线:EMA(C,N4),COLORMAGENTA;
STICKLINE(CLOSE>OPEN OR CLOSE=OPEN AND CLOSE>REF(CLOSE,1),LOW,HIGH,0.1,0),COLORRED;
STICKLINE(CLOSE>OPEN OR CLOSE=OPEN AND CLOSE>REF(CLOSE,1),OPEN,CLOSE,10,0),COLORRED;
STICKLINE(CLOSE<OPEN OR CLOSE=OPEN AND CLOSE<=REF(CLOSE,1),LOW,HIGH,0.1,0),COLORFF00FF;
STICKLINE(CLOSE<OPEN OR CLOSE=OPEN AND CLOSE<=REF(CLOSE,1),OPEN,CLOSE,7,0),COLORFF00FF;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,0,0 ),COLOR00FF11;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,8,0 ),COLOR008855;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,7,0 ),COLOR009900;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,6,0 ),COLOR00AA00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,5,0 ),COLOR00BB00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,4,0 ),COLOR00CC00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLOR00DD00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLOR00EE00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),COLOR00FF55;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0) ,COLORFF66FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLORFF88FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLORFF99FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLORFFAAFF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0,0) ,COLORFFBBFF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0) ,COLORFF00FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0) ,COLORFF22FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,COLORFF44FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0) ,COLORFF66FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLORFF88FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLORFF99FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLORFFAAFF;
STICKLINE(C>=持股线 AND C>=O,C,O,9,0),COLORRED;
STICKLINE(C>=持股线 AND C>=O,H,L,0,0),COLORRED;
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1)
AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2)
AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1)
AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2)
AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1)
AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2)
AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1)
AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2)
AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1)
AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2)
AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1)
AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2)
AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1)
AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2)
AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1)
AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2)
AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(C,2)-EMA(C,150);
买点1:=(VAR11+VAR13+VAR15+VAR17);
买点2:=(VAR13+VAR15+VAR17);
卖点1:=(VAR12+VAR14+VAR16+VAR18);
卖点2:=(VAR14+VAR16+VAR18);
STICKLINE( 买点1>0 ,H,L, 10,1),COLORWHITE,LINETHICK1;STICKLINE( 买点1>0,O,C,6,0),COLORWHITE,LINETHICK1;
STICKLINE( 买点2>0 ,H,L, 10,1),COLORWHITE,LINETHICK1;STICKLINE( 买点2>0,O,C,6,0),COLORRED,LINETHICK1;
STICKLINE( 卖点1>0,H,L, 11,5),COLORBLUE,LINETHICK1;STICKLINE( 卖点1>0,O,C,6,0),COLORBROWN,LINETHICK1;
STICKLINE( 卖点2>0,H,L, 11,5),COLORBLUE,LINETHICK1;STICKLINE( 卖点2>0,O,C,6,0),COLORWHITE,LINETHICK1;
{www.gUPaNg.com 股旁网_最新股票指标公式}
DRAWTEXT(卖点2>0, H,'顶'),COLORBLUE,LINETHICK3;
LOWV:=LLV(LOW,9);
HIGHV:=HHV(HIGH,9);
RSV:=EMA((CLOSE-LOWV)/(HIGHV-LOWV)*100,3);
K:=EMA(RSV,3);
D:=MA(K,3);
买卖差:=K-D;
BU:=CROSS(K,D);
多头排列:=启动>持股线 AND 启动>长期线 AND 持股线>长期线;
买进价:=((C-REF(MA(C,6),1))/6+MA(C,6))*1.004;
STICKLINE(1,C,O,0,0),COLORWHITE;
上线:=SMA(C,2.5,1);
下线:=SMA(C,6.5,1);
上线1:=SMA(C,6,2);
下线1:=SMA(C,8,2);
攻击:BBI+3*STD(BBI,10),LINETHICK1;
STICKLINE( 上线>下线 AND (CLOSE>攻击),C,O,7,3),COLORYELLOW;STICKLINE(上线>下线 AND (CLOSE>攻击),H,L,1,2),COLORYELLOW;
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
金叉:=CROSS(K,50);
DRAWTEXT(金叉>0 AND K<80 AND K>D AND OPEN>牛熊线 ,LOW*0.942,' 大胆作多'),COLORRED;

通达信主控K线主图指标公式

 

相关文章