在线检测未来函数

通达信支撑压力MACD及吸拉派落指标公式

来源:Internet,编辑:股旁网,2011-12-14

DIF1:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA1:=EMA(DIF1,9);
MACD1:=2*(DIF1-DEA1),STICK;
MACD2:=EMA(MACD1,3);
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,3.2,0),COLOR000055;
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,2.7,0),COLOR000077;
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,2.1,0),COLOR000099;
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,1.5,0),COLOR0000BB;
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,0.9,0),COLOR0000DD;
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,0.3,0),COLOR0000FF;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,3.2,0),COLOR555555;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,2.7,0),COLOR777777;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,2.1,0),COLOR999999;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,1.5,0),COLORBBBBBB;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,0.9,0),COLORDDDDDD;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,0.3,0),COLORFFFFFF;
STICKLINE(MACD1<MACD2,0,MACD1,3.2,0),COLORB20000;
STICKLINE(MACD1<MACD2,0,MACD1,2.7,0),COLOREC0000;
STICKLINE(MACD1<MACD2,0,MACD1,2.1,0),COLORFF4600;
STICKLINE(MACD1<MACD2,0,MACD1,1.5,0),COLORFF6300;
STICKLINE(MACD1<MACD2,0,MACD1,0.9,0),COLORFF8B00;
STICKLINE(MACD1<MACD2,0,MACD1,0.3,0),COLORFFAB00;
STICKLINE(MACD1>=0 OR MACD1<=0,0,0,50,1),COLORWHITE;
DIF:DIF1,COLOR33FF33,LINETHICK1;
DEA:DEA1,COLORYELLOW,LINETHICK1;
MACD:MACD1,NODRAW,COLORMAGENTA;
VAR1:=HHV(DEA,53);
VAR2:=LLV(DEA,55);
VAR3:=DEA-(DIF-DEA);
UP:IF(DIF>VAR1 AND DEA=VAR1,MAX(LLV(VAR1,10),VAR3),VAR1),COLORBB0000,LINETHICK2;
DN:IF(DIF<VAR2 AND DEA=VAR2,MIN(HHV(VAR2,10),VAR3),VAR2),COLORAA00AA,LINETHICK2;
DIF,COLORGREEN;
DEA,COLORGREEN;
{www.gUPaNg.com 股旁网_最新股票指标公式}
零上金叉买:0,COLORBLUE,CROSSDOT,LINETHICK1;
IF(DIF>DEA,DIF,DRAWNULL),COLORRED,LINETHICK1;
IF(DEA>REF(DEA,1),DEA,DRAWNULL),COLORMAGENTA;
DRAWICON(CROSS(DIF,DEA),DEA,1);
DRAWICON(CROSS(DEA,DIF),DEA,2);
LOWV:=LLV(LOW,3);
HIGHV:=HHV(HIGH,3);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
STICKLINE(MACD<REF(MACD,1)AND CROSS(K,J),0,MACD,2,0),COLORGREEN;
STICKLINE(MACD>REF(MACD,1)AND CROSS(J,K),0,MACD,2,0),COLORRED;
M1 := EMA( CLOSE, 9 );
M2 := EMA( CLOSE, 18 );
MD : M1 - M2, COLORWHITE, LINETHICK2;
MM := EMA( MD, 3 );
吸 : IF( MD >= MM AND MD < 0, MD, DRAWNULL ), COLORLIRED, LINETHICK2;
拉 : IF( MD >= MM AND MD >= 0, MD, DRAWNULL ), COLORRED, LINETHICK2;
派 : IF( MD < MM AND MD >= 0, MD, DRAWNULL ), COLORGREEN, LINETHICK2;
落 : IF( MD < MM AND MD < 0, MD, DRAWNULL ), COLORWHITE, LINETHICK2;

通达信支撑压力MACD及吸拉派落指标公式

 

相关文章