在线检测未来函数

通达信于氏K线战法主图指标公式

来源:Internet,编辑:股旁网,2011-12-15

VAR1:=EMA(CLOSE,3);
VAR2:=EMA(CLOSE,8);
MA5:=MA(CLOSE,5);
MA21:EMA(CLOSE,21),LINETHICK2,COLORYELLOW;
STICKLINE((VAR1 < MA21),C,O,4,0),COLORGREEN;
STICKLINE((VAR1 > MA21) ,C,O,4,0),COLORRED;
STICKLINE(((VAR1 > VAR2) AND (VAR1 < MA21)) ,C,O,4,0),COLOR1DBB00;
STICKLINE(((VAR1 < VAR2) AND (VAR1 > MA21)) ,C,O,4,0),COLORFB6E0B;
STICKLINE((C < O),L,H,0,0), COLORGREEN;
STICKLINE((C > O),L,H,0,0), COLORRED;
MA2:=MA(CLOSE,10);
MA34:=MA(CLOSE,34);
VARA:=((AMOUNT / VOL) / 100);
VARB:=(((((3 * HIGH) + LOW) + OPEN) + (2 * CLOSE)) / 7);
VARC:=((SUM(AMOUNT,7) / VARA) / 100);
VARD:=DMA(VARB,(VOL / VARC));
VARE:=(((CLOSE - VARD) / VARD) * 100);
VARF:=(((CLOSE - LLV(LOW,34)) / (HHV(HIGH,34) - LLV(LOW,34))) * 100);
VARJ:=(MA(VARE,20) + STD(VARE,20));
BIAS18:=(((CLOSE - MA(CLOSE,18)) / MA(CLOSE,18)) * 100);
K:=SMA(VARF,3,1);
顶:(((REF(BIAS18,1) >= 5) AND CROSS(VARJ,VARE)) AND (K > 79)),NODRAW;
DRAWTEXT(FILTER(((((REF(BIAS18,1) >= 5) AND CROSS(VARJ,VARE))) AND (K > 79)),3),(HIGH * 1.04),'↓S'),COLORGREEN;
VVAR1:=(EMA(CLOSE,30) - EMA(CLOSE,17));
VVAR2:=EMA(VVAR1,5);
DRAWTEXT(FILTER((CROSS(VVAR1,VVAR2) ),3),(CLOSE * 0.96),'↑B'),COLORYELLOW;
DRAWTEXT((FILTER((((((((REF(CLOSE,13) - CLOSE) / REF(CLOSE,13)) * 100) > 15) AND ((SUM((VOL / CAPITAL),13) * 100) < 18)) AND (((VOL / CAPITAL) * 100) < 2.5)) AND ((((REF(CLOSE,1) - CLOSE) / REF(CLOSE,1)) * 100) < 8)),3)),CLOSE * 0.96,'↑B'),COLORLIRED;
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),7);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),7);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),7);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),7);
ADXR:=((ADX + REF(ADX,7)) / 2);
DRAWTEXT(FILTER((((COUNT(PDI,4) = 0)) AND ((HHV(HIGH,10) / LLV(LOW,10)) > 1.2)),3),(CLOSE * 0.96),'↑B'),COLORRED;
VAR1J:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
VAR2J:=SMA(VAR1J,3,1);
VAR3J:=SMA(VAR2J,3,1);
VAR4J:=(VAR1J * 1.05);
VAR6J:=(((HHV(HIGH,36) - CLOSE) / (HHV(HIGH,36) - LLV(LOW,36))) * 100);
VAR7J:=SMA(VAR6J,5,1);
VAR9J:=(((MA((VOL / CAPITAL),30) * MA(VOL,60)) / 10000) + MA(CLOSE,30));
DRAWTEXT(FILTER((((CROSS(VAR2J,VAR4J) AND (VAR3J > 60))) AND (VAR7J < (VAR9J + 10))),3),(H * 1.02),'↓S'),COLORBROWN;
早晨之星:((((((REF(CLOSE,2) / REF(OPEN,2)) < 0.95) AND (REF(OPEN,1) < REF(CLOSE,2))) AND ((ABS((REF(OPEN,1) - REF(CLOSE,1))) / REF(CLOSE,1)) < 0.03)) AND ((CLOSE / OPEN) > 1.05)) AND (CLOSE > REF(CLOSE,2))) ,NODRAW;
黄昏之星:((((((REF(CLOSE,2) / REF(OPEN,2)) > 1.03) AND (REF(OPEN,1) > REF(CLOSE,2))) AND ((ABS((REF(OPEN,1) - REF(CLOSE,1))) / REF(CLOSE,1)) < 0.02)) AND ((CLOSE / OPEN) < 0.97)) AND (CLOSE < REF(CLOSE,2))) ,NODRAW;
长十字:((CLOSE = OPEN) AND ((HIGH / LOW) > 1.03)),NODRAW;
垂死十字:(((CLOSE = OPEN) AND (CLOSE = LOW)) AND NOT(CLOSE=HIGH)) ,NODRAW;
早晨十字星:((((((REF(CLOSE,2) / REF(OPEN,2)) < 0.95) AND (REF(OPEN,1) < REF(CLOSE,2))) AND (REF(OPEN,1) = REF(CLOSE,1))) AND ((CLOSE / OPEN) > 1.05)) AND (CLOSE > REF(CLOSE,2))) ,NODRAW;
黄昏十字星:((((((REF(CLOSE,2) / REF(OPEN,2)) > 1.05) AND (REF(OPEN,1) > REF(CLOSE,2))) AND (REF(OPEN,1) = REF(CLOSE,1))) AND ((CLOSE / OPEN) < 0.95)) AND (CLOSE < REF(CLOSE,2))) ,NODRAW;
射击之星:(((MIN(OPEN,CLOSE) = LOW) AND ((HIGH - LOW) > (3 * (MAX(OPEN,CLOSE) - LOW)))) AND (CLOSE > MA(CLOSE,5))) ,NODRAW;
倒转锤头:(((MIN(OPEN,CLOSE) = LOW) AND ((HIGH - LOW) > (3 * (MAX(OPEN,CLOSE) - LOW)))) AND (CLOSE < MA(CLOSE,5))),NODRAW;
锤头:(((HIGH = MAX(OPEN,CLOSE)) AND ((HIGH - LOW) > (3 * (HIGH - MIN(OPEN,CLOSE))))) AND (CLOSE < MA(CLOSE,5))) ,NODRAW;
吊颈:(((HIGH = MAX(OPEN,CLOSE)) AND ((HIGH - LOW) > (3 * (HIGH - MIN(OPEN,CLOSE))))) AND (CLOSE > MA(CLOSE,5))) ,NODRAW;
穿头破脚:(((((REF(CLOSE,1) / REF(OPEN,1)) > 1.03) AND ((CLOSE / OPEN) < 0.96)) AND (CLOSE < REF(OPEN,1))) AND (OPEN > REF(CLOSE,1))) OR ((((((REF(CLOSE,1) / REF(OPEN,1)) < 0.97) AND ((CLOSE / OPEN) > 1.04)) AND (CLOSE > REF(OPEN,1))) AND (OPEN < REF(CLOSE,1)))),NODRAW;
乌云盖顶:(((((REF(CLOSE,1) / REF(OPEN,1)) > 1.03) AND ((CLOSE / OPEN) < 0.97)) AND (OPEN > REF(CLOSE,1))) AND (CLOSE < REF(CLOSE,1))) ,NODRAW;
曙光初现:(((((REF(CLOSE,1) / REF(OPEN,1)) < 0.97) AND ((CLOSE / OPEN) > 1.03)) AND (OPEN < REF(CLOSE,1))) AND (CLOSE > REF(CLOSE,1))),NODRAW;
身怀六甲:(((((ABS((REF(CLOSE,1) - REF(OPEN,1))) / REF(CLOSE,1)) > 0.04) AND ((ABS((CLOSE - OPEN)) / CLOSE) < 0.005)) AND (MAX(CLOSE,OPEN) < MAX(REF(CLOSE,1),REF(OPEN,1)))) AND (MIN(CLOSE,OPEN) > MIN(REF(CLOSE,1),REF(OPEN,1)))),NODRAW;
十字胎:(((((ABS((REF(CLOSE,1) - REF(OPEN,1))) / REF(CLOSE,1)) > 0.04) AND (CLOSE = OPEN)) AND (CLOSE < MAX(REF(CLOSE,1),REF(OPEN,1)))) AND (CLOSE > MIN(REF(CLOSE,1),REF(OPEN,1)))) ,NODRAW;
平顶:((ABS((HIGH - REF(HIGH,1))) / HIGH) < 0.001) ,NODRAW;
平底:(((ABS((LOW - REF(LOW,1))) / LOW) < 0.001) AND ((ABS((REF(LOW,1) - REF(LOW,2))) / REF(LOW,1)) <= 0.001)),NODRAW;
大阳烛:(((CLOSE / OPEN) > 1.05) AND ((HIGH / LOW) < ((CLOSE / OPEN) + 0.018))) ,NODRAW;
{www.gUPaNg.com 股旁网_最新股票指标公式}
三个白武士:(((((REF(CLOSE,2) > REF(OPEN,2)) AND (REF(CLOSE,1) > REF(OPEN,1))) AND (CLOSE > OPEN)) AND (REF(CLOSE,1) > REF(CLOSE,2))) AND (CLOSE > REF(CLOSE,1))) ,NODRAW;
双飞乌鸦:(((REF(CLOSE,1) < REF(OPEN,1)) AND (CLOSE < OPEN)) AND ((CLOSE / OPEN) < 0.98)) ,NODRAW;
孕育线:(((((((((((REF(CLOSE,2) > REF(OPEN,2)) AND (((REF(CLOSE,2) - REF(OPEN,2)) / REF(OPEN,2)) >= (2 / 100))) AND (REF(OPEN,1) >= REF(CLOSE,1))) AND (((REF(OPEN,1) - REF(CLOSE,1)) / REF(CLOSE,1)) <= (2 / 100))) AND (REF(OPEN,1) <= REF(CLOSE,2))) AND (REF(CLOSE,1) >= REF(OPEN,2))) AND (CLOSE >= OPEN)) AND (((CLOSE - OPEN) / OPEN) >= (2 / 100))) AND (CLOSE >= REF(OPEN,1))) AND (OPEN <= REF(CLOSE,1))) AND (((MAX(CLOSE,REF(CLOSE,2)) - MIN(CLOSE,REF(CLOSE,2))) / MIN(CLOSE,REF(CLOSE,2))) <= (1 / 100))),NODRAW;
多方炮:(((REF(CLOSE,2) > REF(OPEN,2)) AND (REF(CLOSE,1) < REF(OPEN,1))) AND (CLOSE > OPEN)) ,NODRAW;
出水芙蓉:(((((OPEN < EMA(CLOSE,20)) OR (OPEN < EMA(CLOSE,40))) OR (OPEN < EMA(CLOSE,60))) AND (CLOSE > MAX(EMA(CLOSE,20),MAX(EMA(CLOSE,40),EMA(CLOSE,60))))) AND (((VOL / MA(VOL,30)) > 1.2) AND ((CLOSE / REF(CLOSE,1)) > 1.049))) ,NODRAW;
上升三部曲:(((((((((((((REF(CLOSE,4) / REF(OPEN,4)) > 1.03) AND (REF(CLOSE,3) < REF(OPEN,3))) AND (REF(CLOSE,2) < REF(OPEN,2))) AND (REF(CLOSE,1) < REF(OPEN,1))) AND (REF(LOW,4) < REF(LOW,3))) AND (REF(LOW,4) < REF(LOW,2))) AND (REF(LOW,4) < REF(LOW,1))) AND (REF(HIGH,4) > REF(HIGH,3))) AND (REF(HIGH,4) > REF(HIGH,2))) AND (REF(HIGH,4) > REF(HIGH,1))) AND ((CLOSE / OPEN) > 1.03)) AND (CLOSE > REF(CLOSE,4))) ,NODRAW;
下跌三部曲:(((((((((((((REF(CLOSE,4) / REF(OPEN,4)) < 0.97) AND (REF(CLOSE,3) > REF(OPEN,3))) AND (REF(CLOSE,2) > REF(OPEN,2))) AND (REF(CLOSE,1) > REF(OPEN,1))) AND (REF(LOW,4) < REF(LOW,3))) AND (REF(LOW,4) < REF(LOW,2))) AND (REF(LOW,4) < REF(LOW,1))) AND (REF(HIGH,4) > REF(HIGH,3))) AND (REF(HIGH,4) > REF(HIGH,2))) AND (REF(HIGH,4) > REF(HIGH,1))) AND ((CLOSE / OPEN) < 0.97)) AND (CLOSE < REF(CLOSE,4))),NODRAW;
跳空缺口:(HIGH < REF(LOW,1)) OR ((LOW > REF(HIGH,1)) ),NODRAW;
三只乌鸦:(((((REF(CLOSE,2) < REF(OPEN,2)) AND (REF(CLOSE,1) < REF(OPEN,1))) AND (CLOSE < OPEN)) AND (REF(CLOSE,1) < REF(CLOSE,2))) AND (CLOSE < REF(CLOSE,1))) ,NODRAW;
光脚阴线:((LOW = CLOSE) AND NOT(HIGH= LOW)) ,NODRAW;
光头阳线:((HIGH = CLOSE) AND NOT(HIGH=LOW)),NODRAW;
分离:((OPEN = REF(OPEN,1)) AND (((CLOSE - OPEN) * (REF(CLOSE,1) - REF(OPEN,1))) < 0)) ,NODRAW;
长下影:(((MIN(CLOSE,OPEN) - LOW) / (HIGH - LOW)) > 0.667) ,NODRAW;
长上影:(((HIGH - MAX(CLOSE,OPEN)) / (HIGH - LOW)) > 0.667) ,NODRAW;
十字星:((CLOSE = OPEN) AND NOT(HIGH=LOW)) ,NODRAW;
大阴烛:(((OPEN / CLOSE) > 1.05) AND ((HIGH / LOW) < ((OPEN / CLOSE) + 0.018))) ,NODRAW;
好友反攻:(((REF(CLOSE,1) < REF(OPEN,1)) AND (CLOSE > OPEN)) AND ((ABS((CLOSE - REF(CLOSE,1))) / CLOSE) < 0.002)) OR ((((REF(CLOSE,1) > REF(OPEN,1)) AND (CLOSE < OPEN)) AND ((ABS((CLOSE - REF(CLOSE,1))) / CLOSE) < 0.002)) ),NODRAW;
倾盆大雨:(((((REF(CLOSE,1) / REF(OPEN,1)) >= 1.03) AND (OPEN < REF(CLOSE,1))) AND (OPEN > REF(OPEN,1))) AND (CLOSE < REF(OPEN,1))) ,NODRAW;

通达信于氏K线战法主图指标公式

 

相关文章