在线检测未来函数

通达信牛金筹码指标公式

来源:Internet,编辑:股旁网,2011-12-16

量比:=2;上涨:=30;换手:=30;低价:=5;高价:=20;离线:=4;深度:=50;变量00:=5;变量01:=30;
A02:=(WINNER((CLOSE*1.100)) *100.000);
A03:=(WINNER((CLOSE*0.9))*100.000);
A04:=MA(A03,变量00);
STICKLINE(1.000,0,A04,1,-1),COLOR000033;
A06:=(100.000-MA(A02,变量00));
STICKLINE(1.000,100.000,MA(A02,变量00),1,-1),COLOR333300;
A08:=(MA(A02,变量00)-MA(A03,变量00));
STICKLINE(1.000,A04,MA(A02,变量00),1,-1),COLOR006699;
A0A:=(((((HHV(A04, 15.000) - A03) / A03)*100.000)>变量01) AND (HHV(A04, 15.000)>50.000));
STICKLINE(A0A,(0-2.000),2.000,8.000,0),COLORRED;
STICKLINE(NOT(A0A),(0-2.000),2.000,8.000,0),COLORGREEN;
获利:MA(A03,变量00),COLORRED,LINETHICK1;
套牢:(100.000-MA(A02,变量00)),COLORCYAN,LINETHICK1;
浮动:(MA(A02,变量00)- MA(A03,变量00)),COLORYELLOW,LINETHICK1;
HSL:=EMA(V/CAPITAL,3);
ZDL:=HHV(HSL,240);
ZXL:=LLV(HSL,240);
XS:=MA(C,33);
X4:=EMA(C,20);
锁定:EMA((HSL-ZXL)/ZXL*XS,13)/10,LINETHICK0;
二十斜:(X4-REF(X4,1))/REF(X4,1)*100,LINETHICK0;
十换手:SUM(VOL,10)/CAPITAL*100,LINETHICK0;
ZLCM:=EMA(WINNER(CLOSE)*70,3);
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);
ZSHTL:=SHCM/(ZLCM+SHCM)*100;
ZZLKP:=ZLCM/(ZLCM+SHCM)*100;
主控度:(ZZLKP),LINETHICK0,COLORRED;
SHORT:=12;
LONG:=26;
MID:=9;
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
MACD:=(DIF-DEA)*2;
N:=9;
M1:=3;
M2:=3;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,M1,1);
D:=SMA(K,M2,1);
J:=3*K-2*D;
换手率:=VOL/CAPITAL*100;
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
中线:=EMA(X,13);
AAA:=(3*C+L+O+H)/6;
C2:=EMA(AAA,6);
C3:=EMA(AAA,5);
短线:=EMA(CLOSE,17);
上涨天数:=BARSLAST(短线<中线);
N1:=5;
N4:=34;
CQ:=100*(C-LLV(L,N4))/(HHV(C,N4)-LLV(L,N4));
SAT:=(AMOUNT/C)/(HHV(AMOUNT,N4)/HHV(C,N4));
饱和度:=IF(SAT>1,1,SAT)*100;
W1:=C=HHV(C,20);
W2:=BARSLAST(W1);
W3:=IF(W2>0,REF(C,W2),REF(C,W2));
W4:=CROSS(C,REF(W3,1));
突破:=W4 AND COUNT(W4,5)=1;
峰顶:=饱和度>=97 AND CQ>90;
{www.gUPaNg.com 股旁网_最新股票指标公式}
短期:=100*(C-LLV(L,N1))/(HHV(C,N1)-LLV(L,N1));
KAAAA:=EXIST(CROSS(C2,C3),2);
KAAAB:=EXIST(MACD>0,4) AND MACD<0;
KAAAC:=MA(VOL,10)>MA(VOL,5);
KBBB:=EVERY(C>中线 AND O>中线,5);
KCCC:=HHV(VOL,30)/VOL>量比;
KDDD:=上涨天数<上涨;
KEEE:=SUM(换手率,30)>换手;
KFFF:=C>低价 AND C<高价;
KHHH:=EXIST(峰顶,30) OR EXIST(突破,30);
KJJJ:=C/中线<1+0.01*离线;
KIII:=短期<深度;
游资:IF(KAAAA AND KBBB AND KCCC AND KDDD AND KEEE AND KFFF AND KHHH,100,0),COLORYELLOW,NODRAW;
主力:IF(KAAAB AND KBBB AND KCCC AND KDDD AND KEEE AND KFFF AND KHHH,80,0),COLORGREEN,NODRAW;
机构:IF(KAAAC AND KBBB AND KCCC AND KDDD AND KEEE AND KFFF AND KHHH AND KJJJ AND KIII,60,0),COLORRED,NODRAW;
STICKLINE(游资,0,38,1.5,0),COLORYELLOW;
STICKLINE(主力,0,28,1,0),COLORGREEN;
STICKLINE(机构,0,18,0.5,0),COLORRED;
获利1:=WINNER(C)*100,COLOR0033FF,NODRAW;
短套:=EMA(100*(1-WINNER(1.10*C)),1),COLORFFDD00,NODRAW;
中套:=EMA(100*(1-WINNER(1.2*C)),1),COLORFF0000 ,NODRAW;
长套:=EMA(100*(1-WINNER(1.5*C)),1),COLOR00FF00,LINETHICK2;
STICKLINE(CURRBARSCOUNT=90,40,50,100,1),COLOR0033FF;
STICKLINE(CURRBARSCOUNT=90,40,50,获利1,0),COLOR0033AA;
DRAWTEXT(CURRBARSCOUNT=116,51,'日获利盘:'),COLOR0033FF;
DRAWNUMBER(CURRBARSCOUNT=108,51,CONST(获利1)),COLOR0033FF;
STICKLINE(CURRBARSCOUNT=90,60,70,100,1),COLORFFFF00;
STICKLINE(CURRBARSCOUNT=90,60,70,短套,0),COLOR888800;
DRAWTEXT(CURRBARSCOUNT=116,71,'短线套牢:'),COLORFFFF00;
DRAWNUMBER(CURRBARSCOUNT=108,71,CONST(短套)),COLORFFFF00;
STICKLINE(CURRBARSCOUNT=30,40,50,100,1),COLORFF6600;
STICKLINE(CURRBARSCOUNT=30,40,50,中套,0),COLORFF6600;
DRAWTEXT(CURRBARSCOUNT=56,51,'中线套牢:'),COLORFF9900;
DRAWNUMBER(CURRBARSCOUNT=48,51,CONST(中套)),COLORFF9900;
STICKLINE(CURRBARSCOUNT=30,60,70,100,1),COLOR00FF00;
STICKLINE(CURRBARSCOUNT=30,60,70,长套,0),COLOR008833;
DRAWTEXT(CURRBARSCOUNT=56,71,'长线套牢:'),COLOR00FF00;
DRAWNUMBER(CURRBARSCOUNT=48,71,CONST(长套)),COLOR00FF00;

通达信牛金筹码指标公式

 

相关文章